Forum Linux.débutant installation d'ArchLinux sur un vieux Vaio

Posté par (page perso) . Licence CC by-sa.
Tags :
0
18
nov.
2013

Bonsoir,

je rencontre un problème après avoir installé ArchLinux (dernière mouture) sur un vieux Vaio datant peut-être de 2001. La carte graphique est une GeForce 6400 (et le reste est du même tonneau : Pentium M 1, 512 Mo de RAM, etc.)

Mon problème apparaît toujours de la même manière : j'en suis à ma deuxième installation sur cette machine et à chaque fois, aussitôt après l'installation de base (sans X, sans même avoir créé d'utilisateur), après avoir rebooté, l'ordinateur s'arrête pendant le boot avant même de me donner la main sur une console TTY. Pour être sûr de moi, j'ai attendu 30 bonnes minutes pour être sûr que la machine avait réellement planté.

Pour avoir le maximum d'informations j'ai supprimé dans GRUB la ligne :
set gfxpayload=keep
et j'utilise l'option ignore_loglevel à la fin de la ligne linux.

Le boot s'arrête toujours après les mêmes lignes, relatives à l'initialisation vidéo :
[...]
nouveau [DRM] BIOS FP mode : 1280x800 (71100khZ pixel clock)
nouveau [DRM] Saving VGA fonts
[drm] Supports vblank timestamp caching Rev 1 (10.10.2010)

Ces lignes sont les dernières à s'afficher : je n'ai aucun message d'erreur. La valeur affichée (1280x800) me paraît anormale pour l'écran (le test du matériel me donner 1024x768 comme valeur maximale) mais je ne sais pas corriger cela.

Une idée ? Merci d'avance !

  • # nomodeset au boot

    Posté par . Évalué à 3. Dernière modification le 18/11/13 à 22:33.

    probleme de detection des resolutions lors du boot,

    il faut desactiver tout ce qui est graphique pendant le boot, sur certaines distribs on trouve
    vga=ABCD (ABCD etant un code pour forcer la resolution)
    splash (pour dire de masquer les ligne de boot)
    quiet (pour masquer certaines lignes meme en mode texte)

    et ajouter l'eventuel
    nomodesetpour desactiver les options de KMS (Kernel Mode Settings)

    • [^] # Re: nomodeset au boot

      Posté par (page perso) . Évalué à 1. Dernière modification le 18/11/13 à 22:52.

      Merci du coup de main : j'ai déjà essayé vga=1024x768 par exemple mais j'ai l'impression que l'écran n'affiche pas tous les messages d'erreur. De façon générale, j'ai déjà un bug lors de l'installation : le curseur clignote toujours au même endroit sur l'écran (et je me déplace alors au jugé dans les éditeurs type vim ou nano) et le scrolling ne fonctionne pas bien : pour voir les dernières lignes affichées normalement en bas de l'écran, j'ai besoin de basculer sur une autre console tty avant de revenir sur la première tty, comme si je "nettoyais" l'écran qui affiche alors les lignes manquantes !

      J'évitais jusqu'à présent de laisser quiet et le remplaçais par debug ou ignore_loglevel mais il est vrai que ton raisonnement se tient : il me faut essayer de supprimer tout affichage si c'est l'affichage au boot qui pose problème. Merci aussi pour l'idée du nomodeset à laquelle je n'avais pas songé.

      J'essaye tout cela demain !

      Trust the Python !

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.