Forum Linux.débutant problème de point de montage

Posté par .
Tags : aucun
0
24
août
2005
Bonjour,
J'essaie de passer doucement mais surement à Linux : j'ai un disque dur maître dans un rack, où je peux mettre alternativement Windows xp ou Mandrake 10. J'ai ajouté un disque dur slave, avec 2 partitions en format NTFS, que je lis avec windows XP. Mais quand je veux avoir accès à ces 2 partitions du slave sous Linux Mandrake 10, je n'arrive à accéder qu'à une seule de ces partitions (/mnt/windows), et pas à l'autre. Alors il faut dire que celle que je n'arrive pas à ouvrir, j'avais modifié son point de montage (usr/hdd1/, puis finalement mnt/windows25/) via le centre de contrôle de Mandrake. J'ai sans doute fait une mauvaise manip car ce fichier /mnt/windows25 apparaît avec une petite clé, et un message indique je ne peux accéder à ce fichier. Comment le rendre accessible ?
C'est très gentil de me répondre.
merci
Hélène
  • # repertoire

    Posté par . Évalué à 0.

    > car ce fichier /mnt/windows25

    ca doit etre un repertoire, pas un fichier

    su -
    mkdir /mnt/window25
    mount /dev/hdd1 /mnt/windows25

    replacer "hdd1" par le vrai device
    • [^] # Re: repertoire

      Posté par . Évalué à 1.

      Alors, alors, voici ce que cela donne quand je tape vos commandes :

      [root@pha75-8-82-228-227-106 helene]# mkdir /mnt/windows25
      mkdir: Ne peut créer le répertoire `/mnt/windows25': File exists
      [root@pha75-8-82-228-227-106 helene]# mount dev/hdd1 /mnt/windows25
      mount: périphérique spécial dev/hdd1 n'existe pas
      [root@pha75-8-82-228-227-106 helene]# mount /dev/windows25 /mnt/windows25
      mount: périphérique spécial /dev/windows25 n'existe pas

      Bon, j'ai sans doute mal tapé un truc. Au début je n'avais pas mis d'espace entre mkdir et /mnt) : je précise que je suis totalement novice. La preuve, la question suivante : c'est quoi un "device" ?
      Euh, c'est vraiment gentil de me répondre comme si j'étais neuneu.
      Merci
      Hélène
  • # plus d'information...

    Posté par (page perso) . Évalué à 2.

    Etant donné que j'ai pas de mandrake sous la main, tu peux nous donner le contenu du fichier /etc/fstab ?
    tape :
    cat /etc/fstab

    et recopie nous le resultat ici.

    Fait aussi un ls -l /mnt/ et donne nous aussi le résultat de la commande.
    • [^] # Re: plus d'information...

      Posté par . Évalué à 1.

      Alors, voici le résultat de ces commandes :
      [root@pha75-8-82-228-227-106 helene]# cat /etc/fstab
      /dev/hdc1 / ext3 defaults 1 1
      none /dev/pts devpts mode=0620 0 0
      /dev/hdc6 /home ext3 defaults 1 2
      /dev/hda /mnt/cdrom auto umask=0,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec 0 0
      /dev/hdb /mnt/cdrom2 auto umask=0,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec 0 0
      none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-15,sync,codepage=850 0 0
      /dev/hdd5 /mnt/windows ntfs umask=0,nls=iso8859-15,ro 0 0
      /dev/hdd1 /mnt/windows25 ntfs defaults 0 0
      none /proc proc defaults 0 0
      /dev/hdc5 swap swap defaults 0 0
      [root@pha75-8-82-228-227-106 helene]# ls -l /mnt/
      total 16
      drwxr-xr-x 2 root root 4096 aoû 24 15:38 cdrom/
      drwxr-xr-x 2 root root 4096 aoû 24 15:38 cdrom2/
      drwxrwxrwx 0 root root 0 aoû 29 22:09 floppy/
      dr-xr-xr-x 1 root root 4096 aoû 25 23:34 windows/
      dr-x------ 1 root root 4096 aoû 25 23:25 windows25/

      Euh, tout va bien, docteur ? Que dois-je faire ?
      Merci beaucoup
      Hélène
  • # Petite clé ?

    Posté par (page perso) . Évalué à 1.

    Cela voudrait dire que le fichier est accessible seulement par root ?
    Dans une console en tant que root (taper su puis mot de passe root), tappe kate /etc/fstab. Tu vas voir les deux lignes concernant le montage de tes disques. Il te suffit de reproduire en adaptant les valeurs le schéma de celle qui marche sur celle qui marche pas. Si tu n'y arrive pas envoie nous le contenu de ce fichier.
    Bonne chance
    Madcat
    • [^] # Re: Petite clé ?

      Posté par . Évalué à 1.

      En fait, c'est un petit cadenas (et pas une clé...).
      La commande kate ne marche pas, par contre, quand je tape cat, cela donne les résultats suivants :
      [root@pha75-8-82-228-227-106 helene]# cat /etc/fstab
      /dev/hdc1 / ext3 defaults 1 1
      none /dev/pts devpts mode=0620 0 0
      /dev/hdc6 /home ext3 defaults 1 2
      /dev/hda /mnt/cdrom auto umask=0,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec 0 0
      /dev/hdb /mnt/cdrom2 auto umask=0,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec 0 0
      none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-15,sync,codepage=850 0 0
      /dev/hdd5 /mnt/windows ntfs umask=0,nls=iso8859-15,ro 0 0
      /dev/hdd1 /mnt/windows25 ntfs defaults 0 0
      none /proc proc defaults 0 0
      /dev/hdc5 swap swap defaults 0 0
      [root@pha75-8-82-228-227-106 helene]# ls -l /mnt/
      total 16
      drwxr-xr-x 2 root root 4096 aoû 24 15:38 cdrom/
      drwxr-xr-x 2 root root 4096 aoû 24 15:38 cdrom2/
      drwxrwxrwx 0 root root 0 aoû 29 22:09 floppy/
      dr-xr-xr-x 1 root root 4096 aoû 25 23:34 windows/
      dr-x------ 1 root root 4096 aoû 25 23:25 windows25/

      Alors, pas trop grave ? Merci de me répondre comme pour une vraie neu-neu
      Hélène
      Hélène
      • [^] # Re: Petite clé ?

        Posté par (page perso) . Évalué à 1.

        comme tu vois les options umask et nls et ro diffèrent d'une ligne à l'autre. La ligne concernant windows25 devrait donc être

        /dev/hdd1 /mnt/windows25 ntfs umask=0,nls=iso8859-15,ro 0 0
        • [^] # Re: Petite clé ?

          Posté par . Évalué à 1.

          Y'a du mieux, mais c'est pas encore tout à fait ça. C'est beaucoup mieux car grâce à tes indications, j'ai pu effectivement changer la ligne de /etc/fstab avec kwrite. Donc, le fichier est reconnu, monté, et il reconnaît bien les fichiers qui st dedans quand je fais ls /...
          Le seul hic, c'est qu'il est toujours verrouillé (icône avec petit cadenas) et que je ne peux pas l'ouvrir : quand je regarde ses propriétés, il n'est effectivement accesible que par root et est indiqué comme dossier verrouillé. J'ai bien essayé de le déverrouiller dans les différents onglets de la fenêtre propriété, ou en passant par le centre de contrôle, sécurité, permissions, mais rien n'y fait. Il reste verrouillé et utilisable seulement par root, ce qui n'est pas le cas des autres dossiers /mnt
          Si tu as une idée pour accéder à ce putain de bordel de merde de fichier, je suis preneuse.
          En tout cas, merci beaucoup déjà pour les informations précédentes.
          A bientôt
          Hélène
          • [^] # Re: Petite clé ?

            Posté par (page perso) . Évalué à 1.

            Faire mumuse avec les options uid/gid alors ? Typiquement, si tu es la seule utilisatrice de ta machine (un seul compte en dehors de root), ton uid est 500. Sinon vérifie dans /etc/passwd, par exemple mon uid est 500 :
            madcat:x:500:500:Adrien BUSTANY:/home/madcat:/bin/bash
            Et donc rajouter ces options à la ligne de montage ce qui donne
            /dev/hdd1 /mnt/windows25 ntfs umask=0,nls=iso8859-15,ro,uid=500,gid=500 0 0
            Ainsi tu deviens la propriétaire du dossier monté.
  • # Montage

    Posté par . Évalué à 2.

    mkdir /mnt/windows
    mount -t ntfs -o ro /dev/hdXY /mnt/windows

    X: a (IDE0) maitre
    X: b (IDE0) exclave
    X: c (IDE1) maitre
    X: d (IDE1) exclave

    Y: numero de la partition

    si cela marche, il faut modifier ton fichier /etc/fstab et rajouter la ligne
    /dev/hdXX /mnt/windows ntfs user,noauto,ro,exec,umask=0 0 0

    mount /dev/hdXX
    • [^] # Re: Montage

      Posté par . Évalué à 1.

      Je n'ai pas du bien m'y prendre, voilà les réponses :
      [root@pha75-8-82-228-227-106 helene]# mkdir /mnt/windows
      mkdir: Ne peut créer le répertoire `/mnt/windows': File exists
      [root@pha75-8-82-228-227-106 helene]# mount -t ntfs -o ro /dev/hdd1 /mnt/windows
      [root@pha75-8-82-228-227-106 helene]#

      Pout X et Y, il faut pourtant bien mettre hdd1 car ce disque dur est l'esclave de l'IDE 1, et car cette partition à laquelle je veux accéder est la première.
      Quand je tape cat /etc/fstab, puis ls -l /mnt/, voici ce que cela donne:
      [root@pha75-8-82-228-227-106 helene]# cat /etc/fstab
      /dev/hdc1 / ext3 defaults 1 1
      none /dev/pts devpts mode=0620 0 0
      /dev/hdc6 /home ext3 defaults 1 2
      /dev/hda /mnt/cdrom auto umask=0,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec 0 0
      /dev/hdb /mnt/cdrom2 auto umask=0,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec 0 0
      none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-15,sync,codepage=850 0 0
      /dev/hdd5 /mnt/windows ntfs umask=0,nls=iso8859-15,ro 0 0
      /dev/hdd1 /mnt/windows25 ntfs defaults 0 0
      none /proc proc defaults 0 0
      /dev/hdc5 swap swap defaults 0 0
      [root@pha75-8-82-228-227-106 helene]# ls -l /mnt/
      total 16
      drwxr-xr-x 2 root root 4096 aoû 24 15:38 cdrom/
      drwxr-xr-x 2 root root 4096 aoû 24 15:38 cdrom2/
      drwxrwxrwx 0 root root 0 aoû 29 22:09 floppy/
      dr-xr-xr-x 1 root root 4096 aoû 25 23:34 windows/
      dr-x------ 1 root root 4096 aoû 25 23:25 windows25/

      Voili, voilà : que faut-il faire docteur ?
      Hélène
      • [^] # Re: Montage

        Posté par . Évalué à 1.

        Si tu fais
        #mount -t ntfs -o ro /dev/hdd1 /mnt/windows
        #ls /mnt/windows
        tu veras que tu as réussi à monter ta partition

        Mets cette ligne dans /etc/fstab
        /dev/hdd1 /mnt/windows ntfs user,noauto,ro,exec,umask=0 0 0

        Ensuite tu fais
        #mount /mnt/windows
        #ls /mnt/windows
        (il faut que la partition ne soit pas deja montee)
        • [^] # Re: Montage

          Posté par . Évalué à 1.

          Bonsoir,
          Effectivement, la partition est montée et lisible car en faisant ls /mnt/windows
          il m'a affiché le contenu de la partition.
          Le problème, c'est que je n'arrive pas à accéder à la ligne etc/fstab : quand je tape cette ligne, il me dit "Permission denied". Et pourtant, je suis en mode root (avant j'avais fait su, puis j'avais mis mon mot de passe). Comment accéder à cette ligne ?
          Merci et à bientôt
          Hélène
          • [^] # le ficher c'est /etc/fstab

            Posté par . Évalué à 1.

            le fichier c'est /etc/fstab et non etc/fstab (cela aurait marché si tu étais à la racine /)

            Il est imperatif d'être en root pour pouvoir l'éditer

            Soit tu te loggues en root au démarrage de ta session
            (c'est fortement déconseillé mais tu auras l'acces à tous les fichiers et tu pourras l'éditer avec kwrite au gedit)

            Soit tu tapes en console
            #su root
            (tu rentres ton password root)
            #kwrite /etc/fstab
            dans ce fichier tu rentres la ligne que je t'avais dit dans le message précédent et tu sauvegardes

            enfin tu fais:
            mount /mnt/windows

            Bon courage
            • [^] # Re: le ficher c'est /etc/fstab

              Posté par . Évalué à 1.

              Y'a du mieux, mais c'est pas encore tout à fait ça. C'est beaucoup mieux car grâce à tes indications, j'ai pu effectivement changer la ligne de /etc/fstab avec kwrite. Donc, le fichier est reconnu, monté, et il reconnaît bien les fichiers qui st dedans quand je fais ls /...
              Le seul hic, c'est qu'il est toujours verrouillé (icône avec petit cadenas) et que je ne peux pas l'ouvrir : quand je regarde ses propriétés, il n'est effectivement accesible que par root et est indiqué comme dossier verrouillé. J'ai bien essayé de le déverrouiller dans les différents onglets de la fenêtre propriété, ou en passant par le centre de contrôle, sécurité, permissions, mais rien n'y fait. Il reste verrouillé et utilisable seulement par root, ce qui n'est pas le cas des autres dossiers /mnt
              Si tu as une idée, je suis preneuse.
              En tout cas, merci beaucoup déjà pour les informations précédentes.
              A bientôt
              Hélène
              • [^] # Est ce que tu as monté ta partition en root?

                Posté par . Évalué à 1.

                Si tu as monté la partition en root, c'est normal que le répertoire soit en root.

                est ce que tu as fait un #su nom_de_ton_user? (pour repasser sous ton utilisateur).

                puis #mount /mnt/windows

                Si tu as bien fait cette procédure, il faut vérifier la ligne que tu as écrit dans /etc/fstab. Renvoie la moi s'il y a un soucie ou réecrit la ligne que j'ai dû écrire quelques réponses plus haut.

                Bon courage
  • # Montage

    Posté par . Évalué à 0.

    mkdir /mnt/windows
    mount -t ntfs -o ro /dev/hdXY /mnt/windows

    X: a (IDE0) maitre
    X: b (IDE0) exclave
    X: c (IDE1) maitre
    X: d (IDE1) exclave

    Y: numero de la partition

    si cela marche, il faut modifier ton fichier /etc/fstab et rajouter la ligne
    /dev/hdXX /mnt/windows ntfs user,noauto,ro,exec,umask=0 0 0

    mount /mnt/windows

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.