Forum Linux.débutant violent bug graphique

Posté par  . Licence CC By‑SA.
Étiquettes :
2
25
jan.
2018

Bonsoir à tous.

J'ai un problème pour le moins ""éclatant"" sans faire de jeu de mots bidons.
Avant je faisais mes backups avec Clonezilla mais sur une clé usb multisystem, et tout à l'heure j'ai eu la bonne (ou mauvaise) idée de vérifier que mon backup était fonctionnel, eh bin devinez quoi, il ne l'est pas… je fais des backups qui ne fonctionnent pas depuis quasi un an, heureusement j'ai jamais eu à m'en servir.

Du coup j'aimerai trouver une solution pour utiliser Clonezilla dans des conditions normales, pour au moins voir ce que je fais, histoire de pas écraser tout mon système en choisissant la mauvaise partoche hein.

sur clonezilla, au boot en live usb, j'ai essayé tous les modes différents pour la résolution et également le mode ""sécurisé"" enfin je crois que c'est ça le terme, je sais plus trop ce qui était écrit..

j'ai trouvé juste ce post qui témoigne du même bug, et sur un Toshiba comme moi (le mien c'est un Satellite p870-338)
https://forum.ubuntu-fr.org/viewtopic.php?id=1311761

et plutot que de mal vous expliquer l'étendue des dégats graphiques rien ne vaut une bonne petite photo (à garder en souvenir tellement elle est exceptionnellement explosée ^

http://pix.toile-libre.org/upload/original/1516915185.jpg
http://pix.toile-libre.org/upload/original/1516915180.jpg

Vous comprenez pourquoi c'est complexe de faire des sauvegardes dans de telles conditions, c'est juste illisible..
Si quelqu'un a une solution miracle je suis vraiment preneuse..
ce problème graphique je le connais aussi sur les iso netinstall et mini iso de Debian (comme sur la photo)
et les backups sont pour moi essentiels, je tourne sur plusieurs systèmes dont Debian Sid, et je ne veux pas prendre de risques.

En espérant de l'aide pour une solution viable.
Merci.
j'ai vraiment besoin d'aide, je peux pas rester dans une telle situation sans backup

  • # Carte graphique.

    Posté par  . Évalué à 1.

    Tu as vérifié le support de la technologie Optimus par Clonezilla ? Ça vient probablement de là.

    Peux-tu changer de méthode de backup ? Il existe d'autres solutions sur lesquelles je t'invite à te renseigner : tar, dd ou encore rsync.

    • [^] # Re: Carte graphique.

      Posté par  . Évalué à 1.

      je me doute que c'est un problème par rapport à cette technologie Optimus, mais je connais des gens sur d'autres forums qui ont des pc portables et en Optimus et pour qui Clonezilla fonctionne bien, pas le moindre soucis graphique, donc visiblement c'est supporté, et je pense pas avoir un pc ""exotique""

      je pense qu'il me reste plus que cette solution de chercher un autre moyen, mais clonezilla est assez simple à prendre en main je trouve..

      et comment expliquer que ce même bug est aussi présent sur les iso netinstall de Debian.???

      Comment être insensible face à cette cruauté envers les animaux :'(

      • [^] # Re: Carte graphique.

        Posté par  . Évalué à 2.

        Tu peux essayer ces options pour le kernel :

        nomodeset i915.modeset=0 nouveau.modeset=0
        

        Si c'est vraiment un bug Optimus ça devrait résoudre ton souçis

        • [^] # Re: Carte graphique.

          Posté par  . Évalué à 1. Dernière modification le 26/01/18 à 12:14.

          bon en faite, j'ai honte de moi là….
          Dans les options de boot de Clonezilla, y a une option KMS
          hier je l'ai pas vu, surement trop fatiguée….
          du coup je viens d'essayer en sélectionnant KMS, et j'ai enfin un écran normal et lisible surtout.
          bel ecran de clonezilla

          Mais par contre ce bug de Clonezilla je l'ai aussi sur les iso netinstall de Debian, et avec le mini iso Debian.
          et sur ces iso, pas d'options KMS ou autres.

          donc sur le mini iso debian, j'ai essayé ton option
          nomodeset i915.modeset=0 nouveau.modeset=0
          mais ça marche pas, j'ai toujours un écran explosé et donc impossible d'installer debian dans de telles conditions..

          une idée.??
          on peut passer une option KMS sur ces iso.???
          ou un truc du genre.??
          enfin un moyen d'avoir un écran normal comme tout le monde

          Comment être insensible face à cette cruauté envers les animaux :'(

          • [^] # Re: Carte graphique.

            Posté par  . Évalué à 2.

            en supprimant les options "splash" ou "quiet" pour forcer un demarrage en mode texte :D

            • [^] # Re: Carte graphique.

              Posté par  . Évalué à 1. Dernière modification le 26/01/18 à 15:43.

              mais il est déjà en mode texte le mini iso de Debian..
              et y a juste une option (d'origine)

              ""priority=low vga=768 ---""

              me demande pas ce que c'est ce charabia :/

              Comment être insensible face à cette cruauté envers les animaux :'(

              • [^] # Re: Carte graphique.

                Posté par  (site Web personnel) . Évalué à 2.

                Pour le vga=, ça permet de spécifier une configuration pour l'affichage lors du boot. Voir la doc du kernel et le VESA BIOS extension. 768 c'est 256 couleurs en 640x400.

                Pour le priority=, ça semble un truc pour l'installeur debian

                Python 3 - Apprendre à programmer dans l'écosystème Python → https://www.dunod.com/EAN/9782100809141

                • [^] # Re: Carte graphique.

                  Posté par  . Évalué à 1.

                  merci pour les liens, et l'explication.
                  donc si je comprends bien, comme mon écran fait 1600*900.
                  je devrais tenter avec vga=864, c'est ça.??
                  j'aurais théoriquement une meilleure résolution.

                  je vais tenter ça quand j'aurais fini d'encoder ma vidéo
                  j'aimerai trop que ça soit la bonne piste, t'imagine même pas à quel point :/

                  Comment être insensible face à cette cruauté envers les animaux :'(

                  • [^] # Re: Carte graphique.

                    Posté par  (site Web personnel) . Évalué à 1.

                    L'idée serait plutôt d'enlever vga= qui force (ou essaie de forcer) une résolution donnée, et de laisser le noyau choisir ce qui lui semble le mieux. Mais bon, il est préférable de centraliser les suggestions sur le rapport de bogue que tu as ouvert chez Debian : #888513, et de continuer le débogage là-bas.

                    Debian Consultant @ DEBAMAX

                    • [^] # Re: Carte graphique.

                      Posté par  . Évalué à 1.

                      j'ai essayé aussi en enlevant la résolution, mais hélas aucun changement…
                      oui je surveille le rapport de bogue, et j'essaye d'appliquer tout ce qu'on me dit, je me rends compte que quand je réponds aux mainteneurs ça y mets pas sur la rapport de bogues, j'ai fais une fausse manip, je suis définitivement tete en l'air :/

                      je sais que je suis un cas totalement isolé, du coup une résolution de bogue va être complexe voire même impossible, mais j'espère qu'à force d'acharnement et de manip avec les mainteneurs, on va réussir à trouver une éventuelle alternative, même si mon pessimisme actuel est à 200% :'(

                      Comment être insensible face à cette cruauté envers les animaux :'(

                      • [^] # Re: Carte graphique.

                        Posté par  (site Web personnel) . Évalué à 1.

                        Effectivement, notre système de suivi de bogue est ultra-pénible. Pour s'assurer que tout le monde reçoive les réponses, une règle simple : reply-all, tout le temps. :-/

                        Debian Consultant @ DEBAMAX

                        • [^] # Re: Carte graphique.

                          Posté par  . Évalué à 1.

                          je tacherais de m'en souvenir, ça sera + compréhensible, si un autre malheureux subit le même bug que moi…
                          j'espère que mon anglais est pas trop mauvais, et que c'est un peu compréhensible pour les mainteneurs.
                          je suis pas très douée pour l'anglais technique.!!!

                          Comment être insensible face à cette cruauté envers les animaux :'(

                • [^] # Re: Carte graphique.

                  Posté par  . Évalué à 1.

                  ça ne fonctionne pas…………….
                  mon niveau de pessimisme a atteint les 200%
                  j'en peux plus sérieux, ça m'irrite les nerfs ce bug

                  Comment être insensible face à cette cruauté envers les animaux :'(

  • # suis-je un cas désespéré

    Posté par  . Évalué à 1.

    personne n'a d'idées alors.??
    c'est mort de chez mort mon bug, y a rien à espérer :'(

    Comment être insensible face à cette cruauté envers les animaux :'(

  • # résolu

    Posté par  . Évalué à 1.

    C'est bon problème résolu ou plutôt contourner.

    En désactivant l'option de démarrage rapide dans le bios, j'ai enfin un affichage clair qui prend bien en compte la résolution de mon écran.

    Ça c'est cool enfin un problème réglé.
    Maintenant me reste plus qu'à trouver la solution pour la wifi non reconnu en post installation.

    Merci a tous.

    Comment être insensible face à cette cruauté envers les animaux :'(

Suivre le flux des commentaires

Note : les commentaires appartiennent à celles et ceux qui les ont postés. Nous n’en sommes pas responsables.