Forum Linux.général Branchement du câble réseau gigabit pas détecté sous Fedora 23, mais OK sous windows 10

Posté par . Licence CC by-sa.
0
19
jan.
2016

Bonjour,

Je suis un peu perplexe. Mon ordi fixe se connecte correctement à internet avec mon windows 10, et pas du tout sous fedora23: Le câble branché n'est pas détecté. Plus secondairement, la xbox360 ne détecte pas non plus le réseau. Ça me dérange moins mais ça peut être lié…

lspci: 05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)

Pour précision, j'ai emménagé dans un appartement, où un câblage rj45/ cat6 a été effectué entre le salon et l'entrée. Dans l'entrée, j'ai mis la freebox, relié à la prise murale. Puis dans le salon, j'ai relié l'ordi à la prise murale correspondante.

Windows 10 détecte le branchement et obtient un lien gigabit.

Je suis un peu à sec sur les raisons qui font qu'il y a une différence. Avez vous des idées pour que je diagnostique le problème?

Merci d'avance !!

  • # Diagnostique niveau 1

    Posté par . Évalué à 2. Dernière modification le 19/01/16 à 18:29.

    Regarder les led de la prise de ton pc
    Sans cable sous linux
    Puis en branchant
    Avec cable sous linux
    En général verte et orange, elles indiquent la présence cable et la communication data.
    Que donne l'indication ?

    Diag Niveau 2 :
    Linux t'indique que le câble est débranché ou bien constate simplement que le réseau ne marche pas? Qu'indique précisément le kernel ?
    Ne serait ce pas une mauvaise configuration de la freebox? style elle ne fait plus serveur dhcp mais serait passé en mode bridge ? (suite à un déménagement peut être que la config usine c'est ré-appliquée ?)
    As tu vérifié les paramètres de ta freebox ?

    En fait si deux terminaux (ton pc et ta xbox) ne vois pas le réseau je ne chercherais pas trop niveau linux l'origine du soucis mais il peut aider au diagnostique.

    • [^] # Re: Diagnostique niveau 1

      Posté par . Évalué à 2.

      La freebox peut être capricieuse.
      Essaye de brancher un switch gigabit ou autre chose à la place de la freebox…

      • [^] # Re: Diagnostique niveau 1

        Posté par . Évalué à 2.

        J'ai souvent recours à mii-tool ou ethtool pour forcer les vitesse de ports ; l'auto-négociation de la vitesse…bof, bof, bof, j'ai régulièrement des problèmes en fonction du matériel utilisé. Que se passe-t-il en forçant la vitesse des ports de part et d'autre ? quelle est la vitesse détectée dans le cas présent ?

        • [^] # Re: Diagnostique niveau 1

          Posté par . Évalué à 1.

          Merci pour vos tips.

          Sans vraiment y croire j'ai changé le câble freebox<->mural 'tout blanc' par un autre câble 'tout bleu avec des chiffres dessus' et là linux à détecté le branchement et établi une liaison 100mb… J'ai donc commandé de bons câble réseau cat6 pour être bien tranquille.
          Je précise de nouveau que windows 10 n'a pas bronché, même avec le câble 'tout blanc'.

          Du coup par rapport à mii-tool et ethtool, je connais pas du tout, mais ça m'intéresse fortement puisque ça a tout à fait l'air d'être dans le thème concerné. As tu un lien vers une page un peu didactique? Le man me semble un peu aride. Je ferai alors des tests et ferai part des résultats!

          Merci en tout cas :)

  • # IP (V6)

    Posté par . Évalué à 1.

    Est-ce que tu obtiens une adresse IP ?
    Est-ce que ta xbox et linux sont paramétrés pour IPV6 ?

    Julien_c'est_bien (y'a pas que Seb)

    • [^] # Re: IP (V6)

      Posté par . Évalué à 1.

      Alors dans l'ordre:
      Non,
      Je sais pas, oui.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.