Forum Linux.général Controleur PCI / SATA : Disque non reconnu dans le Bios

Posté par .
Tags : aucun
0
16
juin
2009
Bonjour,

J'ai monté un disque SCSI Western Digital 320GB, avec une carte controleur PCI/SATA Advance PCI-ST101 dont le chipset est un VIA VT6421.

Le but final n'est pas de faire du raid, mais de mettre le système sur le disque le plus rapide.

Normalement, cette carte permet de booter sur le disque.
Si je boote sur mon ancien disque (une Ubuntu 8.04), le disque SCSI est visible (en scsi3)
Le module sata_via est chargé.
J'ai partionné le nouveau disque (via gParted), puis j'ai installé avec succès une Ubuntu Jaunty Jackalope sur mon nouveau disque.
Jusque là, tout va bien.

Mais quand je veux rebooter, pas moyen de démarrer sur le nouveau disque.

Pour info, voilà la sortie de fdisk /dev/sdb :



Disque /dev/sdb: 320.0 Go, 320072933376 octets
255 heads, 63 sectors/track, 38913 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes
Identifiant disque: 0x0005dd0e

Périphérique Amorce Début Fin Blocs Id Système
/dev/sdb1 * 1 131 1052226 83 Linux
/dev/sdb2 18475 38913 164176267+ 83 Linux
/dev/sdb3 132 18148 144721552+ 5 Extended
/dev/sdb5 132 262 1052226 82 Linux swap / Solaris
/dev/sdb6 263 1045 6289416 83 Linux
/dev/sdb7 1046 1698 5245191 83 Linux
/dev/sdb8 1699 2351 5245191 83 Linux
/dev/sdb9 2352 18148 126889371 83 Linux


Du coup, j'ai copié la commande de boot du menu.lst de la nouvelle install sur celui de l'ancienne.
Mais quand je veux rebooter sur la Jauty Jackalope (donc sur le nouveau disque), j'ai un message d'erreur qui m'indique qu'il ne trouve pas le fichier image.

De plus, je me suis aperçu que le disque SATA n'était pas détecté par le Bios.

Que faire ?
Evidemment, n'hésitez pas à me demander des infos complémentaires

Merci de votre aide.
J-L
  • # Erratum

    Posté par . Évalué à 1.

    Evidemment, dans le message, il ne faut pas lire SCSI, mais SATA... Avec toutes mes excuses.
  • # pas detecter au bios

    Posté par . Évalué à 2.

    le disque en question n'est pas detecter dans le bios de ta machine ?
    c'est normal dans le cas ou ta carte est une carte additionnelle
    c'est elle qui detecte le disque.

    il faut donc demander à ton bios de demarrer sur la carte additionnelle (et pas sur les disques durs) pour que celle-ci demarre ensuite le disque dur.

    evidemment il faut que cette carte PCI/SATA soit une carte bootable
    • [^] # Re: pas detecter au bios

      Posté par . Évalué à 1.

      Bonjour,

      Alors, normalement, elle est bootable. Mais comment faire avec mon bios pour lui dire de démarrer là dessus.
      Ma carte mère est une "vieille" ABIT VH6 II avec un bios AWARD.
      Je n'ai rien fait d'autre qu'installer "mécaniquement" la carte dans le PC. D'ailleurs, il n'y avait pas de CD avec la carte pour une install logicielle quelconque.

      Cela dit, que ça ne démarre pas sur la carte ne me gêne pas trop. Là, je démarre sur le disque IDE. Le menu Grub s'affiche. Donc à partir de là, j'espérais pouvoir faire démarrer la distrib sur le disque SATA... qui est normalement en /dev/sdb.
      Mais, ça ... ça ne marche pas :(
      • [^] # Re: pas detecter au bios

        Posté par . Évalué à 2.

        il faut que la carte PCI/SATA ait initialisé le disque avant de pouvoir booter dessus

        probleme ?
        la carte ne s'initialise peut-etre qu'au chargement du module sata_via.

        quand tu as installé cette carte dans ta machine, cela a-t-il rajouté un menu dans ta sequence de demarrage ?
        genre entre le bios et le grub ?

        cela pourrait alors permettre de configurer une ou deux options dans cette carte fille.

        Sinon, il faut regarder dans le bios de la carte mere, il y a peut-etre une option pour lui dire d'initialiser la carte fille des le boot

        enfin si tu ne trouves ni l'une, ni l'autre,

        il va falloir mettre la partition /boot de ta nouvelle install sur le disque IDE, afin que le noyau, et l'initrd se trouve sur un disque accessible par grub
        le reste du systeme pouvant se trouver sur le disque SATA
        • [^] # Re: pas detecter au bios

          Posté par . Évalué à 1.

          Merci pour l'idée.

          En fait, j'y avais bien pensé, mais je voulais essayer de faire mieux.
          Pour info complémentaire, l'erreur au chargement est :


          Error 15 File not Found


          Et pour compléter, la commande de lancement dans le menu.lst est :

          title Ubuntu 9.04, kernel 2.6.28-11-generic
          uuid 0db0c8b9-f274-4898-9b12-bd844e8dd1c7
          kernel /boot/vmlinuz-2.6.28-11-generic root=UUID=0db0c8b9-f274-4898-9b12-bd844e8dd1c7 ro quiet splash
          initrd /boot/initrd.img-2.6.28-11-generic
          quiet


          Merci de votre aide.
          • [^] # Re: pas detecter au bios

            Posté par . Évalué à 2.

            ou se trouve le /boot ?
            contient-il les fichiers
            vmlinuz-2.6.28-11-generic
            et
            initrd.img-2.6.28-11-generic

            pour que cela fonctionne actuellement il semblerait qu'il faille que /boot soit sur ton disque IDE (vu que ton grub est sur le disque IDE)
            • [^] # Re: pas detecter au bios

              Posté par . Évalué à 1.

              Bonsoir,

              Voici quelques éléments de réponses.
              Si je monte la partition racine sur /mnt, je peux m'assurer que les fichiers en question sont bien là où ils doivent être.


              # sudo mount /dev/sdb1 /mnt
              # ls -1 /mnt/boot
              abi-2.6.28-11-generic
              config-2.6.28-11-generic
              grub
              initrd.img-2.6.28-11-generic
              memtest86+.bin
              System.map-2.6.28-11-generic
              vmcoreinfo-2.6.28-11-generic
              vmlinuz-2.6.28-11-generic


              J'ai aussi vérifié que l'UUID présent dans le menu.lst est le bon.


              title Ubuntu 9.04, kernel 2.6.28-11-generic
              uuid 0db0c8b9-f274-4898-9b12-bd844e8dd1c7
              kernel /boot/vmlinuz-2.6.28-11-generic root=UUID=0db0c8b9-f274-4898-9b12-bd844e8dd1c7 ro quiet splash
              initrd /boot/initrd.img-2.6.28-11-generic
              quiet

              # sudo blkid

              ...
              /dev/sdb1: UUID="0db0c8b9-f274-4898-9b12-bd844e8dd1c7" SEC_TYPE="ext2" TYPE="ext3"
              ...



              La question est donc sûrement de savoir si au moment de l'exécution de grub, le système est capable où non de monter /dev/sdb1.
              Neox, si je comprends ce que tu dis, ça ne semble pas possible... D'ailleurs, sur quel répertoire se ferait le montage ?
              • [^] # Re: pas detecter au bios

                Posté par . Évalué à 2.

                d'apres ce que tu dis,
                quand tu bootes sur la ubuntu 8.04, le disk sata est visible APRES le chargement du module sata_via

                quand tu demandes à grub de booter directement sur le disk sata
                le disque n'est pas encore disponible/visible

                pour confirmer cela, tu peux essayer de mettre uniquement le disque sata et de tenter de faire l'installation dessus/booter dessus (vu que c'est l'unique disque)
                • [^] # Re: pas detecter au bios

                  Posté par . Évalué à 1.

                  Bonjour,

                  Mon premier problème, c'est d'essayer de trouver le moyen de demander au Bios de démarrer sur le SATA. Hormis les options classiques , j'ai SCSI et Boot Other Device.
                  J'ai désactivé toutes les autres possibilités, mais pas moyen de démarrer sur le SATA.
                  Je vais donc me créer une partition de boot sur l'IDE (100M, ça doit suffire ?), et installer le reste sur le SATA. J'imagine que pour des questions de rapidité de démarrage, il vaut mieux que la partition de boot soit au début du disque.

                  J'ai aussi cherché s'il y avait un bios à charger/mettre à jour sur la carte contrôleur, mais je n'ai rien trouvé. Et il n'y a plus de mise à jour pour mon antique carte mère ABIT VH6-II.

                  En tous cas, merci pour le coup de main.

                  Cordialement,
                  J-L
                  • [^] # Re: pas detecter au bios

                    Posté par . Évalué à 2.

                    effectivement dans le bios de ta carte mere, c'est les options
                    - SCSI
                    - boot other device

                    qui peuvent passer la main à la carte fille lors du demarrage
                    helas encore faut-il que cette derniere soit prevue pour, voir peut-etre la documentation du fabricant afin de savoir si on peut "demarrer" sur cette carte

                    enfin, si cela ne le fait pas, oui il faut mettre grub /boot sur le disque IDE
                    meme si c'est un vieux disque, je ne penses pas que tu vois reellement la difference entre un /boot au debut ou à la fin du disque
                    car finalement il n'y a pas grand chose à charger (le noyau et l'initrd)

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.