Forum Linux.général Est ce que mes drivers ATI sont installés ?!

Posté par  .
Étiquettes : aucune
0
10
mai
2006
Bonjour à tous
j'ai suivi à la lettre le script d'installation des drivers ATI de ma 9600XT, X se lance bien mais lorsque je tente un fgl_glxgears j'obtiens :


Using GLX_SGIX_pbuffer
libGL error: failed to open DRM: Operation not permitted
libGL error: reverting to (slow) indirect rendering
X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 144 (GLX)
Minor opcode of failed request: 5 (X_GLXMakeCurrent)
Serial number of failed request: 36
Current serial number in output stream: 36


Voici ma bécane :
debian testing
xorg 6.9.0.dfsg.1-6
kernel 2.6.15-1-686
drivers fglrx-6-8-0_8.24.8-2_i386

Voici mon glxinfo :

name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_OML_swap_method, GLX_SGI_make_current_read,
GLX_SGIS_multisample, GLX_SGIX_hyperpipe, GLX_SGIX_swap_barrier,
GLX_SGIX_fbconfig
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_ATI_pixel_format_float,
GLX_ATI_render_texture
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_multisample
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9600 XT Generic
OpenGL version string: 2.0.5755 (8.24.8)
OpenGL extensions:
GL_ARB_multitexture, GL_EXT_texture_env_add, GL_EXT_compiled_vertex_array,
GL_S3_s3tc, GL_ARB_depth_texture, GL_ARB_fragment_program,
GL_ARB_fragment_program_shadow, GL_ARB_fragment_shader,
GL_ARB_multisample, GL_ARB_occlusion_query, GL_ARB_point_parameters,
GL_ARB_point_sprite, GL_ARB_shader_objects, GL_ARB_shading_language_100,
GL_ARB_shadow, GL_ARB_shadow_ambient, GL_ARB_texture_border_clamp,
GL_ARB_texture_compression, GL_ARB_texture_cube_map,
GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
GL_ARB_texture_env_crossbar, GL_ARB_texture_env_dot3,
GL_ARB_texture_mirrored_repeat, GL_ARB_transpose_matrix,
GL_ARB_vertex_blend, GL_ARB_vertex_buffer_object, GL_ARB_vertex_program,
GL_ARB_vertex_shader, GL_ARB_window_pos, GL_ARB_draw_buffers,
GL_ATI_draw_buffers, GL_ATI_element_array, GL_ATI_envmap_bumpmap,
GL_ATI_fragment_shader, GL_ATI_map_object_buffer, GL_ATI_separate_stencil,
GL_ATI_texture_env_combine3, GL_ATI_texture_float,
GL_ATI_texture_mirror_once, GL_ATI_vertex_array_object,
GL_ATI_vertex_attrib_array_object, GL_ATI_vertex_streams,
GL_ATIX_texture_env_combine3, GL_ATIX_texture_env_route,
GL_ATIX_vertex_shader_output_point_size, GL_EXT_abgr, GL_EXT_bgra,
GL_EXT_blend_color, GL_EXT_blend_func_separate, GL_EXT_blend_minmax,
GL_EXT_blend_subtract, GL_EXT_clip_volume_hint,
GL_EXT_draw_range_elements, GL_EXT_fog_coord, GL_EXT_framebuffer_object,
GL_EXT_multi_draw_arrays, GL_EXT_packed_pixels, GL_EXT_point_parameters,
GL_EXT_rescale_normal, GL_EXT_secondary_color,
GL_EXT_separate_specular_color, GL_EXT_shadow_funcs, GL_EXT_stencil_wrap,
GL_EXT_texgen_reflection, GL_EXT_texture3D,
GL_EXT_texture_compression_s3tc, GL_EXT_texture_cube_map,
GL_EXT_texture_edge_clamp, GL_EXT_texture_env_combine,
GL_EXT_texture_env_dot3, GL_EXT_texture_filter_anisotropic,
GL_EXT_texture_lod_bias, GL_EXT_texture_mirror_clamp,
GL_EXT_texture_object, GL_EXT_texture_rectangle, GL_EXT_vertex_array,
GL_EXT_vertex_shader, GL_HP_occlusion_test, GL_NV_blend_square,
GL_NV_occlusion_query, GL_NV_texgen_reflection, GL_SGI_color_matrix,
GL_SGIS_generate_mipmap, GL_SGIS_texture_border_clamp,
GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod, GL_SUN_multi_draw_arrays
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess


Merci
  • # A vue de nez

    Posté par  . Évalué à 3.

    Il te manque la section :

    Section "DRI"
        Mode 0666
    EndSection

    a la fin de ton /etc/X11/xorg.conf
    • [^] # Re: A vue de nez

      Posté par  . Évalué à 1.

      Hum j'ai ajouté ce que tu m'as dit, mais X ne se lance pas après avoir modifié le xorg.conf
      Voici le log :


      X Window System Version 6.9.0 (Debian 6.9.0.dfsg.1-6 20060403233528 David Nusinow <dnusinow@debian.org>)
      Release Date: 21 December 2005
      X Protocol Version 11, Revision 0, Release 6.9
      Build Operating System: Linux 2.6.12-1-686 i686 [ELF]
      Current Operating System: Linux keke 2.6.15-1-686 #2 Mon Mar 6 15:27:08 UTC 2006 i686
      Build Date: 04 April 2006
      Before reporting problems, check http://wiki.X.Org
      to make sure that you have the latest version.
      Module Loader present
      OS Kernel: Linux version 2.6.15-1-686 (Debian 2.6.15-8) (waldi@debian.org) (gcc version 4.0.3 20060212 (prerelease) (Debian 4.0.2-9)) #2 Mon Mar 6 15:27:08 UTC 2006 F
      Markers: (--) probed, (**) from config file, (==) default setting,
      (++) from command line, (!!) notice, (II) informational,
      (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
      (==) Log file: "/var/log/Xorg.0.log", Time: Wed May 10 14:07:37 2006
      (==) Using config file: "/etc/X11/xorg.conf"
      Parse error on line 373 of section Screen in file /etc/X11/xorg.conf
      "Mode" is not a valid keyword in this section.
      (EE) Problem parsing the config file
      (EE) Error parsing the config file

      Fatal server error:
      no screens found

      Please consult the The X.Org Foundation support
      at http://wiki.X.Org
      for help.
      Please also check the log file at "/var/log/Xorg.0.log" for additional information.

      (WW) xf86CloseConsole: VT_GETSTATE failed: Bad file descriptor
      (WW) xf86CloseConsole: KDSETMODE failed: Bad file descriptor
      (WW) xf86CloseConsole: VT_GETMODE failed: Bad file descriptor
    • [^] # Re: A vue de nez

      Posté par  . Évalué à 1.

      Mon xorg.conf :
      http://pastebin.com/709238
      • [^] # Re: A vue de nez

        Posté par  . Évalué à 1.

        La section à ajouter dans le xorg.conf permet d'activer de dri sur les cartes ATI mais pour qu'un utlisateur normal puissent en tirer parti, il faut qu'il ait les droits nécessaires.

        Va dans /etc/dri
        et modifie les droits pour y avoir accès.

        Tu n'auras plus ce message:

        libGL error: failed to open DRM: Operation not permitted
        libGL error: reverting to (slow) indirect rendering

        qui apparait pour glx_gears, openoffice (et oui!!!) et autres
        • [^] # Re: A vue de nez

          Posté par  . Évalué à 1.

          Et pour les commandes en double ?
          Je suppose que les engrenages qui tournent prouvent que l'accélération est bien activée.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.