Forum Linux.général impossible d’accéder à un volume monté sur le serveur nfs

Posté par  .
Étiquettes :
0
29
juin
2012

salut à tous;

bon je vais essayer d'être clair:
- j'ai un poste 1 sur lequel est monté différentes partitions dans /media
- poste 1 configuré comme serveur nfs.
- poste 2 comme client qui accéde directement à 1 par la racine avec touts les droits (777);
- poste 2 qui peut accéder à tout poste 1 mais qui "voit" pas les partitions de /media sur poste 1.

une idée ?

merki.

  • # précision

    Posté par  . Évalué à -1.

    j'avais oublié que les partions sont ntfs.

    • [^] # Re: précision

      Posté par  (site Web personnel) . Évalué à 3.

      NFSv3 ou NFSv4 ?

      Options d'export / de montage ?

      Bref, un peu plus de détails.

      Python 3 - Apprendre à programmer dans l'écosystème Python → https://www.dunod.com/EAN/9782100809141

    • [^] # Re: précision

      Posté par  . Évalué à 2.

      Le montage dans /media doit être fait par un utlisateur, avec visibilté restreinte à cet utilisateur.

      Pour exporter du ntfs, monte-les avec /etc/fstab

      ⚓ À g'Auch TOUTE! http://afdgauch.online.fr

  • # par défaut nfs n'exporte pas les sous montages ;)

    Posté par  . Évalué à 4.

    par contre c'est pas méga clair.
    Tu as deux poste 2 et on ne sais pas ce que tu veux précisément, on ne peut que déviner

    un petit man exports et les options nohide ou crossmnt a lire sont pas mal.

    Lire bien le man, car ces options peuvent avoir des comportement particulier

    Il ne faut pas décorner les boeufs avant d'avoir semé le vent

    • [^] # Re: par défaut nfs n'exporte pas les sous montages ;)

      Posté par  . Évalué à 1. Dernière modification le 29/06/12 à 18:37.

      en fait:
      poste 1 linux, partition ntfs montée;
      poste 1 comme serveur nfs;
      poste 2 linux en client nfs qui ne pouvait "lire" la partition ntfs de poste 1;

      mais bon merci, nohide était la solution. comme quoi rtfm :P

      Normally, if a server exports two filesystems one of which is mounted on the other, then the client will have to mount both filesystems explicitly to get
      access to them. If it just mounts the parent, it will see an empty directory at the place where the other filesystemis mounted. That filesystem is "hidden".
      Setting the nohide option on a filesystem causes it not to be hidden, and an appropriately authorised client will be able to move from the parent to that filesystem without noticing the change.

      j'ai également rajouté "no_root_squash" dans les /etc/exports; apparemment une question de POSIX non pris en charge par ntfs, source de bug dans le cas d'un montage nfs.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.