Forum Linux.général Libreoffice consommation anormale du CPU

Posté par . Licence CC by-sa
Tags : aucun
3
13
jan.
2018

bonsoir à tous.

depuis quelques jours, j'ai un problème avec Libreoffice 5.4.4-1
lorsque je le lance, la consommation CPU s'envole subitement, alors qu'aucun document est ouvert….. :(

je l'ai lancé via le terminal et j'ai eu ce retour

javaldx: Could not find a Java Runtime Environment!
Warning: failed to read path from javaldx

il peut pas trouver les éléments java, mais j'en ai aucun d'installé, ni openjdk, parce qu'ils me sont inutiles, puis ça fait un an et demi que je suis sous Linux, j'ai jamais installé les trucs java, et libreoffice a toujours bien fonctionné jusqu'à présent…

ce qui me parait bizarre, c'est que ce bug est présent sur mes 2 linux, à savoir AchLinux Cinnamon, et Debian Sid Cinnamon..

en lançant libreoffice et en regardant htop, voilà le résultat
http://pix.toile-libre.org/upload/original/1515880975.png

comme on peut y voir j'ai un cœur du cpu pris à 100% alors que je suis simplement sur la page d'accueil de libreoffice….

et je pense pas avoir un cpu merdique, même Blender (qui est pourtant + lourd) ne me pose pas ce soucis…

j'ai purgé libreoffice, en virant tous les fichiers de conf dans mon /home, mais après réinstallation le problème persiste…

là c'est sur ArchLinux, mais c'est exactement le même problème sur Debian..

si quelqu'un a une idée je suis preneuse..

Merci.

  • # glib ?

    Posté par . Évalué à 3 (+2/-0).

    Ça n'a peut-être rien à voir mais il y a eu un problème similaire sur voidlinux l'année dernière. Apparemment, ça venait de glib : https://github.com/voidlinux/void-packages/issues/6375.

    • [^] # Re: glib ?

      Posté par . Évalué à 1 (+0/-0).

      en effet j'étais tombée sur cette page de github, et sur un bugreport également, qui parlait du même soucis..

      sur ArchLinux, glib2 (version 2.54.3-1), a été mis à jour le 11 janvier lors de mon dernier upgrade donc.
      je sais pas si j'avais les soucis avant la mise à jour, avec les fêtes de fin d'année, j'ai pas utilisé mon pc…

      en revanche sur debian, glib2.0 (version 2.54.3-1 également) a été mis à jour le 9 janvier, et idem que pour Arch je sais pas si avant la mise à jour j'avais ces problèmes, je pas utilisé Libreoffice depuis + d'un mois et demi..

      si c'est ce paquet qui fout le bordel, il devrait y avoir des bugreports, je suis pas la seule à utiliser libreoffice sur debian et arch quand même :/
      je vais continuer mes recherches des bugreports pour glib2, on sait jamais si c'est la piste

      Comment être insensible face à cette cruauté envers les animaux :'(

      • [^] # Re: glib ?

        Posté par . Évalué à 1 (+0/-0).

        EDIT :
        je viens de voir sur le site de ArchLinux que dans les dépots testing, une nouvelle version de glib2 est dispo.

        en date du 11 janvier, la version 2.54.3-1 dans les dépots stables
        et en date du 12 janvier la version 2.54.3-2 dans les dépots testing.

        si en un jour une nouvelle version est dispo, c'est souvent signe d'un bug, quand le bugreport de arch je vois 3 bugs, mais aucun pour libreoffice.
        et du coté de debian visiblement y a rien du tout..

        Comment être insensible face à cette cruauté envers les animaux :'(

        • [^] # Re: glib ?

          Posté par . Évalué à 1 (+0/-0). Dernière modification le 14/01/18 à 15:01.

          Pas de soucis sur debian avec ces versions:
          libreoffice: 5.4.4-1
          libglib2.0-0: 2.54.2-5

          Pas tester version supérieur.

          "Comme ta création n’est pas en vain, la création de ces événements n’est pas non plus en vain." Bediüzzaman

          • [^] # Re: glib ?

            Posté par . Évalué à 1 (+0/-0).

            de toute façon si dans les prochains jours y a pas de nouvelles versions, je ferais un bugreport, vu que je vais devoir utiliser à plein régime libreoffice, ou sinon je rétrograde la version de Glib en attendant ;)

            sur ArchLinux, la nouvelle version de glib (2.54.3-2) est dispo je viens de voir sur leur site.
            va falloir que je fasse un upgrade complet ce soir, pour voir si ça résolut ou non le soucis

            Comment être insensible face à cette cruauté envers les animaux :'(

            • [^] # Re: glib ?

              Posté par . Évalué à 2 (+0/-0). Dernière modification le 14/01/18 à 20:45.

              Eu, non, en fait, rien. Je me suis trompé dans mon commentaire donc j'ai préféré supprimer pour ne pas polluer la discussion.

            • [^] # Re: glib ?

              Posté par . Évalué à 1 (+0/-0).

              Avec libglib2.0-0 en version 2.54.3-1 sous debian toujours aucun soucis.

              "Comme ta création n’est pas en vain, la création de ces événements n’est pas non plus en vain." Bediüzzaman

  • # Pareil sur Mageia

    Posté par . Évalué à 3 (+1/-0).

    Par curiosité, j'ai lancé LibreOffice, que j'utilise rarement, pour voir sa conso cpu sur ma machine (mageia Cauldron "à jour").

    Un core occupé à 100% également version : LibreOffice 5.4.4.2 40(Build:2) / glib2 2.54.3

    En le lançant en console, je n'ai aucune erreur affichée (mais j'ai un environnement java installé.

    En libreoffice --safe-mode : 100% également

       --safe-mode         Starts in a safe mode, i.e. starts temporarily with a
                           fresh user profile and helps to restore a broken
                           configuration.
    

    En safe-mode, tant que la fenêtre de choix à faire (mode normal, sans échec, restoration etc est ouverte, consommation à O mais une fois validée , elle monte à 100%

    De même, en demandant d'ouvrir un fichier ou les options, le temps que la boite de dialogue est ouverte, le cpu retourne à 0.

    Bizarre.

  • # remonter eventuellement le bug

    Posté par . Évalué à 2 (+1/-0).

    Ha ça fait ""plaisir"" de voir que je suis pas la seule à avoir ce problème.

    C'est exactement pareil que comme tu l'as décris littlebreizhman, dès qu'une boite de dialogue est ouverte (celle des options de libreoffice pour ma part) le cpu redescend a 0%

    Drôle de bug.
    A voir si la nouvelle version de glib2 sur arch corrige le bug.
    Si non, faudra rapporter le bug, vu qu'a nous trois, on peut déjà confirmer qu'il y a 4 distrib différentes impactées.

    Comment être insensible face à cette cruauté envers les animaux :'(

  • # glib etait bien coupable

    Posté par . Évalué à 4 (+3/-0).

    Bon bah je confirme que le bug venait bien de glib.
    La version 2.54.3-2 sur archlinux est dans les dépôts stables, je viens de faire l'upgrade complet, et libreoffice tourne comme une horloge suisse désormais, OUFFFFFF a partir de demain j'en ai besoin donc nickel.

    Sous Debian toujours rien en vue en revanche.
    Je rapporterais le bug dans les prochains jours, en attendant je vais rétrograder et blacklister le glib actuel et récupérer celui de testing.

    Vous devriez rapporter les bugs pour mageia et antergos :D

    Comment être insensible face à cette cruauté envers les animaux :'(

    • [^] # Re: glib etait bien coupable

      Posté par . Évalué à 2 (+0/-0).

      Pour Debian, au cas ou tu en aies besoin, tu as dans /var/cache/apt/archives les paquets que tu as déjà installés (dossier qui tend à grossir pas mal, d'ailleurs) si rien ne les vide régulièrement. Du coup, tu as peut-être moyen de trouver une version plus ancienne du paquet glib qui ne pose pas le problème, en espérant que la plus récente ne soit pas imposée par un autre paquet.

    • [^] # Re: glib etait bien coupable

      Posté par . Évalué à 1 (+0/-0).

      Sur la version 2.54.3-1 sous debian, aucun soucis.

      "Comme ta création n’est pas en vain, la création de ces événements n’est pas non plus en vain." Bediüzzaman

      • [^] # Re: glib etait bien coupable

        Posté par . Évalué à 1 (+0/-0).

        J'ai vidé le dossier l'autre jour avec un apt autoclean, justement il avait tendance a grossir énormément.

        Mais le paquet peut se récupérer directement sur le site de Debian donc c'est pas trop grave.
        Je vais essayer la version de testing ou de stretch selon les versions, je verrais si ça pose un soucis quelconque avec les dépendances par exemple.

        Et kripteks, tu utilises testing.??
        T'as fais l'upgrade de glib en le piochant depuis les depots sid.?!

        Bizarre que t'es pas le bug.!!!

        Comment être insensible face à cette cruauté envers les animaux :'(

        • [^] # Re: glib etait bien coupable

          Posté par . Évalué à 1 (+0/-0). Dernière modification le 15/01/18 à 14:53.

          J'ai pu tester sur testing, la nouvelle version vient de passer en testing.

          "Comme ta création n’est pas en vain, la création de ces événements n’est pas non plus en vain." Bediüzzaman

          • [^] # Re: glib etait bien coupable

            Posté par . Évalué à 1 (+0/-0).

            c'est bizarre que t'es pas le problème alors :/
            ça peut venir de l'environnement de bureau peut-être.?!!
            dans experimental, y a libglib2.0-0 en version 2.55.1-1.

            donc dans Sid y aura pas de corrections, je pense que la version 2.55 va arriver dans les prochaines semaines.

            Comment être insensible face à cette cruauté envers les animaux :'(

            • [^] # Re: glib etait bien coupable

              Posté par . Évalué à 1 (+0/-0). Dernière modification le 16/01/18 à 14:32.

              J'ai le très gros openbox + tint2 comme environnement :)

              Faut voir la liste des changements s'il y a ou non quelques chose, c'est peut-être lier à la distribution et le mainteneur du paquet.

              Pour les warnings libreoffice, j'ai ceci dans la console:
              javaldx: Could not find a Java Runtime Environment!
              Please ensure that a JVM and the package libreoffice-java-common
              is installed.
              If it is already installed then try removing ~/.libreoffice/3/user/config/javasettings_Linux_*.xml
              Warning: failed to read path from javaldx

              "Comme ta création n’est pas en vain, la création de ces événements n’est pas non plus en vain." Bediüzzaman

              • [^] # Re: glib etait bien coupable

                Posté par . Évalué à 1 (+0/-0).

                ha oui en effet un énorme environnement 100 fois + lourd que kde :p

                dans le terminal, j'ai le même message d'erreur, vu qu'on utilise pas d'environnement java, c'est normal, bah Cinnamon doit utiliser glib d'une autre façon ou je ne sais trop quoi.!!!!

                Comment être insensible face à cette cruauté envers les animaux :'(

  • # C'est une RC1

    Posté par . Évalué à 1 (+0/-0).

    LO 5.4.4.1 est une RC1, la version finale qui a été publiée par TDF est la RC2 (5.4.4.2) qui corrige quelques bugs supplémentaires : https://wiki.documentfoundation.org/Releases/5.4.4/RC2

    Ceci dit il faudrait vérifier si vous avez le même problème avec la version compilée par TDF et disponible sur le site LibreOffice : https://fr.libreoffice.org/download/libreoffice-fresh/

    Pour ma part je n'ai pas le problème avec la version 5.4.4.2 pour Ubuntu 16.04 fournie par le PPA de Canonical.

    Pour Java, vérifiez si votre LibreOffice a l'extension Mediawiki-Publisher. Si c'est le cas désinstallez la, c'est elle qui a besoin de Java et qui vérifie la présence d'un JRE au démarrage.

    Sinon pour les suspicions de bug, merci d'en faire part sur qa@fr.libreoffice.org

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.