Forum Linux.général Logiciels Libres et Collectivités : gestion des convocations

Posté par . Licence CC by-sa.
Tags : aucun
0
30
avr.
2014

Bonjour,

ça fait une petite semaine que j'essaie de faire fonctionner le logiciel libre i-delibre de l'adullact. L'installation ne pose pas plus de problèmes que ça (apache php postgresql) mais l'initialisation du truc ça c'est une autre paire de manche.

Création des databases vides via les scripts sql fournis ça ça va :-)

Mais comment se loguer sur le machin je trouve pas :-( (compte administrateur ? quel mot de passe ?)

Certains d'entre vous ont-ils tenté l'expérience avec succès ? Et si oui seraient-ils prêt à partager un peu de leur expérience ?

Je comprends bien que le modèle économique de l'adullact est nécessaire mais un logiciel libre sans documentation je trouve ça assez peu productif (maintenant ça n'est qu'un avis personnel) pour ensuite convaincre des élus que le mode contributif serait intéressant pour eux.

Bonne journée à tous :-)

  • # page d'accueil

    Posté par (page perso) . Évalué à 1.

     Identifiant: secretaire@adullact
    Mot de passe: idelibre
    
    • [^] # Re: page d'accueil

      Posté par . Évalué à 1.

      Ça c'est le login/password de la version démo en ligne.

      J'ai testé au cas où quand même mais à part si je me suis trompé quelque part (peut être :-) )ça ne fonctionne pas.

      Dans les scripts sql je ne vois pas cette entrée non plus à part dans le script 999_utils_empty_database.sql où l'on trouve un delete from users where username != 'administrateur' and username != 'secretaire'; donc rien qui crée ça :-(

      Mais merci quand même de la réponse

  • # manque de doc (euphémisme)

    Posté par . Évalué à 1. Dernière modification le 30/04/14 à 16:44.

    trouvé un :
    COPY users (id, firstname, lastname, username, password, last_login, group_id, userconf_id, created, modified, active, last_logout, last_import, mail, pwdmodified, rev, rev_date, seance_sync_date) FROM stdin;
    e64e47b6-9027-4d73-a49b-70fd2ee0475e Administrateur Administrateur Administrateur mot de pass non valide \N 26b380d8-93b2-41e9-9f68-da98c55ccb30 5e213ed2-09e2-4638-a2a4-67b22829657f 2013-11-07 15:54:40.942895 2013-11-07 15:54:40.942895 t \N \N \N f \N \N \N
    .

    dans :
    101_idelibre_coll.sql

    donc
    username = Administrateur
    password = Administrateur (à modifier à la première connexion ?)

    je n'ai pas trouvé de doc ou de readme pour faire l'install……..
    je suppose qu'il faut exécuter les instructions sql des fichiers 000 à 101 (ou 200 ?)

    Envoyé depuis mon Archlinux

    • [^] # Re: manque de doc (euphémisme)

      Posté par . Évalué à 1.

      Pareil,

      là ça crée un user avec
      Prénom : Administrateur
      Nom : Administrateur
      Username : Administrateur
      password : mot de pass non valide \N

      mais ça marche pas non plus

      Et effectivement pas de doc ou de readme donc faut faire du reverse au pire pour trouver la requête de login et rentrer les bonnes données.

      De ce que j'ai trouvé les fichiers 001 et 002 vont dans une database idelibre (config serveur) et le fichier 101_ lui dans une database idelibrecoll :-)

      Je continue de chercher :-)

      • [^] # Re: manque de doc (euphémisme)

        Posté par . Évalué à 1.

        bonjour,
        si t as realisé une petit doc ou si t as des infos pour l'installation je suis preneur.
        Je me galere un peu.
        Merci

        • [^] # Re: manque de doc (euphémisme)

          Posté par . Évalué à 1.

          Perso j'ai bien installé la base vide bien sur,ensuite lorsque je clique sur connexion il me dit :The requested URL /Srvusers/login was not found on this server.

          J'imagine qu'il y a un truc à activer ou a parametrer mais je ne vois pas.
          Apparement dans un fichier ils disent de ne pas activer le mod_rewrite?
          Une piste?
          merki

          • [^] # Re: manque de doc (euphémisme)

            Posté par . Évalué à 1.

            Bonjour,
            j'ai eu le même problème lors de l'installation …
            Il faut s'assurer que le mod_rewrite est bien installé et chargé dans apache ( vérifier dans le dossier /etc/apache2/mods-enabled/ la présence du lien rewrite.load-> ../mods-available/rewrite.load ).

            Ensuite il faut changer les droits des dossiers dossier apache (/etc/apache2/sites-enabled/000-default). c'est surtout le AllowOverride à All qui importe :

            <VirtualHost *:80>
            DocumentRoot /var/www/
            <Directory />
            Options FollowSymLinks
            AllowOverride All
            </Directory>
            <Directory /var/www/>
            Options Indexes FollowSymLinks MultiViews
            AllowOverride All
            </Directory>
            ...................
            </VirtualHost>

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.