Forum Linux.général Ma souris bouge mais ne clique pas

Posté par  .
Étiquettes : aucune
0
10
fév.
2005
Bonjour,

Après l'essai de plusieurs distributions, livecd, ... j'ai le même problème avec toutes les distrib. Ma souris USB sans-fil polaroid (avec clavier qui fonctionne sans pb) ne clique pas !
Elle bouge bien, la molette fonctionne sans problème, mais je n'ai ni le clic droit, ni le clic gauche !

J'ai essayé pleins de configuration avec xmodmap, mais à partir le clic gauche quand je monte ma roulette et le droit quand je descend, .... je n'ai rien trouvé de concluant ....

Quelqu'un a une idée ?

Sinon existe t'il un logiciel qui permetrait de voir au moins si le port USB recoit quelquechose quand je clic ? et comment je pourrais mapper ce quelque chose sur un clic ? (sous windows sans drivers ca marche nickel)

Merci d'avance !

Gav
  • # /dev/input/...

    Posté par  (site Web personnel) . Évalué à 3.

    Ta souris doit être accessible sur les dev suivants (pas forcément tous hein):
    /dev/psaux
    /dev/mouse
    /dev/input/mice
    /dev/input/mouse0 ou 1 ou 2 ...

    pour vérifier ce qui se passe :
    cat /dev/XXX et tu bouges la souris
    Ya aussi xxd : xxd /dev/XXX qui hexdump ou le contraire ...
    Bouge et clique, essaie de voir s'il se passe quelque chose, éventuellement, essaie de voir s'il n'y a pas un dev qui marche mieux qu'un autre et adapté ta conf X en fonction.
    • [^] # Re: /dev/input/...

      Posté par  . Évalué à 1.

      oki alors déjà merci pour ta réponse,
      j'ai testé un peu tout ca.
      Déjà j'ai remarqué que /dev/input/mouse0 pointe vers l'autre souris PS2 que j'ai installé en plus, et /dev/input/mouse1 pointe vers ma souris USB kiclikpa !

      au niveau de ce qui s'affiche, les résultats différents en fonction des souris, mais quelque chose se passe quand je clic.

      Autre chose, en shell avec gpm, quand je clic gauche ca tape "S" et quand je clic droit ca affiche "D"

      .......
      • [^] # Re: /dev/input/...

        Posté par  (site Web personnel) . Évalué à 3.

        Et "xev" sous X, il dit quoi quand tu cliques ? Ici, ça donne un truc comme ça pour un clic gauche suivi d'un clic droit :
        ButtonPress event, serial 27, synthetic NO, window 0x3a00001,
            root 0x5e, subw 0x0, time 694357165, (113,110), root:(685,132),
            state 0x10, button 1, same_screen YES
        
        ButtonRelease event, serial 27, synthetic NO, window 0x3a00001,
            root 0x5e, subw 0x0, time 694357267, (113,110), root:(685,132),
            state 0x110, button 1, same_screen YES
        
        ButtonPress event, serial 27, synthetic NO, window 0x3a00001,
            root 0x5e, subw 0x0, time 694359565, (113,110), root:(685,132),
            state 0x10, button 3, same_screen YES
        
        ButtonRelease event, serial 27, synthetic NO, window 0x3a00001,
            root 0x5e, subw 0x0, time 694359667, (113,110), root:(685,132),
            state 0x410, button 3, same_screen YES
        
        note les "button 3" et "button 1"
        • [^] # Re: /dev/input/...

          Posté par  . Évalué à 1.

          Déjà encore merci pour ta réponse,

          La souris en question est chez moi, je testerais en rentrant.
          En fonction des résultats tu as une idée de ce que je pourrais faire ?

          Merci d'avance,
          • [^] # Re: /dev/input/...

            Posté par  (site Web personnel) . Évalué à 2.

            Déjà, il faudra que tu sélectionnes le bon périph pour ta souris dans la config de X.
            Que tu rêgles un peu les params éventuellement.
            Et puis après, si ça ne marche toujours pas, mais je ne sais pas trop ce qu'il faudra faire. Ça dépendra quand même pas mal des valeurs retournées pour les évènements ...
            • [^] # Re: /dev/input/...

              Posté par  . Évalué à 1.

              Et bien pour faire simple, quand je clic avec xev il ne se passe rien !
              quand je bouge pas de pb ... quand je clic avec mon autre souris, des résultats similaires aux tiens, et quand je clic avec ma souris usb .... rien.

              Je commence à penser qu'il n'y a pas de solution ....

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.