Forum Linux.général Mise à jour raspbian échoue avec un timeout, impossible de continuer

Posté par  . Licence CC By‑SA.
Étiquettes :
1
22
nov.
2019

Bonjour.

Je suis loin d'être spécialiste avec Debian; même si j'ai une bonne expérience du système, je n'ai jamais osé "chipoter" avec le gestionnaire de paquets.

Les faits: j'ai formaté une carte SD avec Raspbian Buster, la version du 29 septembre 2019. Le raspberry démarre et veut se mettre à jour mais échoue. J'essaie de me débrouiller avec une mise à jour manuelle mais je ne fais que récolter un message comme celui-ci:

    Hit:1 http://raspbian.raspberrypi.org/raspbian buster InRelease
    Hit:2 http://archive.raspberrypi.org/debian buster InRelease
    Error: Timeout was reached

J'essaie en modifiant les serveurs source (sans trop comprendre d'où vient le problème) et je recommence. Ça donne pareil. Aucun des paquets ne peut s'installer, il y a des dépendances non satisfaites, notamment avec python 2.7 — mais c'est seulement une conséquence de la mise à jour défaillante, je pense.

Je lance la commande (que je découvre quelques instants plus tôt):

apt-get update --list-uris

et je vois ça:

    'http://archive.raspberrypi.org/debian/dists/buster/InRelease' archive.raspberrypi.org_debian_dists_buster_InRelease 0 
    'http://archive.raspberrypi.org/debian/dists/buster/main/binary-armhf/Packages.xz' archive.raspberrypi.org_debian_dists_buster_main_binary-armhf_Packages 0 
    'http://archive.raspberrypi.org/debian/dists/buster/main/binary-all/Packages.xz' archive.raspberrypi.org_debian_dists_buster_main_binary-all_Packages 0 
    'http://archive.raspberrypi.org/debian/dists/buster/main/i18n/Translation-en_US.xz' archive.raspberrypi.org_debian_dists_buster_main_i18n_Translation-en%5fUS 0 
    'http://archive.raspberrypi.org/debian/dists/buster/main/i18n/Translation-en.xz' archive.raspberrypi.org_debian_dists_buster_main_i18n_Translation-en 0 
    'http://archive.raspberrypi.org/debian/dists/buster/main/i18n/Translation-en_US.UTF-8.xz' archive.raspberrypi.org_debian_dists_buster_main_i18n_Translation-en%5fUS.UTF-8 0 
    'http://raspbian.raspberrypi.org/raspbian/dists/buster/InRelease' raspbian.raspberrypi.org_raspbian_dists_buster_InRelease 0 
    'http://raspbian.raspberrypi.org/raspbian/dists/buster/main/binary-armhf/Packages.xz' raspbian.raspberrypi.org_raspbian_dists_buster_main_binary-armhf_Packages 0 
    'http://raspbian.raspberrypi.org/raspbian/dists/buster/main/binary-all/Packages.xz' raspbian.raspberrypi.org_raspbian_dists_buster_main_binary-all_Packages 0 
    'http://raspbian.raspberrypi.org/raspbian/dists/buster/main/i18n/Translation-en_US.xz' raspbian.raspberrypi.org_raspbian_dists_buster_main_i18n_Translation-en%5fUS 0 
    'http://raspbian.raspberrypi.org/raspbian/dists/buster/main/i18n/Translation-en.xz' raspbian.raspberrypi.org_raspbian_dists_buster_main_i18n_Translation-en 0 
    'http://raspbian.raspberrypi.org/raspbian/dists/buster/main/i18n/Translation-en_US.UTF-8.xz' raspbian.raspberrypi.org_raspbian_dists_buster_main_i18n_Translation-en%5fUS.UTF-8 0 
    'http://raspbian.raspberrypi.org/raspbian/dists/buster/contrib/binary-armhf/Packages.xz' raspbian.raspberrypi.org_raspbian_dists_buster_contrib_binary-armhf_Packages 0 
    'http://raspbian.raspberrypi.org/raspbian/dists/buster/contrib/binary-all/Packages.xz' raspbian.raspberrypi.org_raspbian_dists_buster_contrib_binary-all_Packages 0 
    'http://raspbian.raspberrypi.org/raspbian/dists/buster/contrib/i18n/Translation-en_US.xz' raspbian.raspberrypi.org_raspbian_dists_buster_contrib_i18n_Translation-en%5fUS 0 
    'http://raspbian.raspberrypi.org/raspbian/dists/buster/contrib/i18n/Translation-en.xz' raspbian.raspberrypi.org_raspbian_dists_buster_contrib_i18n_Translation-en 0 
    'http://raspbian.raspberrypi.org/raspbian/dists/buster/contrib/i18n/Translation-en_US.UTF-8.xz' raspbian.raspberrypi.org_raspbian_dists_buster_contrib_i18n_Translation-en%5fUS.UTF-8 0 
    'http://raspbian.raspberrypi.org/raspbian/dists/buster/non-free/binary-armhf/Packages.xz' raspbian.raspberrypi.org_raspbian_dists_buster_non-free_binary-armhf_Packages 0 
    'http://raspbian.raspberrypi.org/raspbian/dists/buster/non-free/binary-all/Packages.xz' raspbian.raspberrypi.org_raspbian_dists_buster_non-free_binary-all_Packages 0 
    'http://raspbian.raspberrypi.org/raspbian/dists/buster/non-free/i18n/Translation-en_US.xz' raspbian.raspberrypi.org_raspbian_dists_buster_non-free_i18n_Translation-en%5fUS 0 
    'http://raspbian.raspberrypi.org/raspbian/dists/buster/non-free/i18n/Translation-en.xz' raspbian.raspberrypi.org_raspbian_dists_buster_non-free_i18n_Translation-en 0 
    'http://raspbian.raspberrypi.org/raspbian/dists/buster/non-free/i18n/Translation-en_US.UTF-8.xz' raspbian.raspberrypi.org_raspbian_dists_buster_non-free_i18n_Translation-en%5fUS.UTF-8 0 
    'http://raspbian.raspberrypi.org/raspbian/dists/buster/rpi/binary-armhf/Packages.xz' raspbian.raspberrypi.org_raspbian_dists_buster_rpi_binary-armhf_Packages 0 
    'http://raspbian.raspberrypi.org/raspbian/dists/buster/rpi/binary-all/Packages.xz' raspbian.raspberrypi.org_raspbian_dists_buster_rpi_binary-all_Packages 0 
    'http://raspbian.raspberrypi.org/raspbian/dists/buster/rpi/i18n/Translation-en_US.xz' raspbian.raspberrypi.org_raspbian_dists_buster_rpi_i18n_Translation-en%5fUS 0 
    'http://raspbian.raspberrypi.org/raspbian/dists/buster/rpi/i18n/Translation-en.xz' raspbian.raspberrypi.org_raspbian_dists_buster_rpi_i18n_Translation-en 0 
    'http://raspbian.raspberrypi.org/raspbian/dists/buster/rpi/i18n/Translation-en_US.UTF-8.xz' raspbian.raspberrypi.org_raspbian_dists_buster_rpi_i18n_Translation-en%5fUS.UTF-8 0 

En testant les URIs l'une après l'autre, je vois que l'une d'entre elles n'aboutit pas: 'http://archive.raspberrypi.org/debian/dists/buster/main/binary-armhf/Packages.xz' d'où je me dis que c'est probablement celle-là qui fait avorter apt update.

J'élimine alors les fichiers sous /var/lib/apt/lists/ et je relance apt update… ben non, toujours la même chose. Quand ça veut pas, ça veut pas. Et ça m'emmerde. Je voulais juste tester les transferts bluetooth avec mon raspberry étant donné que ça déconne entre mon PC et le téléphone. Ce faisant, j'ai vu la carte SD se corrompre et je n'ai pas d'alimentation plus puissante. J'ai donc trois problèmes sur les bras au lieu d'un. J'ose pas trop tester davantage de peur d'en avoir un nouveau… (Je plaisante. Enfin juste un peu.)

Quelqu'un aurait une idée?

  • # Indisponibilité temporaire ? Ou ...

    Posté par  . Évalué à 2.

    Là maintenant, je n'ai aucune problème pour récupérer le package et le décompresser à la main.
    Il y avait peut-être un soucis entre chez toi et les serveurs au moment du problème.

    Autre possibilité : j'ai récemment testé Pi-Hole sur un R-Pi. Tout allait bien jusqu'à une mise à jour de la Raspbian.
    Il m'a fallu un moment pour déterminer que la carte µSD, a priori de qualité pourtant (Samsung ?), avait à moitié rendue l'âme : accessible en lecture seule. Mon Pi-Hole tourne dans une VM maintenant …

    • [^] # Re: Indisponibilité temporaire ? Ou ...

      Posté par  . Évalué à 2.

      Merci. Le paquet est bien accessible. Je vais réessayer, c'est que je commençais à désespérer à force, au bout de plusieurs heures.

    • [^] # Re: Indisponibilité temporaire ? Ou ...

      Posté par  . Évalué à 2.

      Je viens de terminer une mise à jour, c'est réussi. Par contre, j'ai toujours le message d'erreur:

      Hit:1 http://archive.raspberrypi.org/debian buster InRelease
      Hit:2 http://raspbian.raspberrypi.org/raspbian buster InRelease
      Error: Timeout was reached

      Comment puis-je savoir exactement à quoi est dû ce message? J'imaginais que c'était le second lien mais là je n'en suis plus très sûr.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.