Forum Linux.général Pas de son sous RTCW

Posté par .
Tags : aucun
0
7
août
2004
Bonjour,

Hello,

Comme j'ai une nouvelle machine, j'ai voulu voir ce que donne quake3 et wolfenstein :)

Malheureusement, impossible de faire marcher le son sous wolf...

Le probleme est le suivant :

------- sound initialization -------
/dev/dsp: Input/output error
Could not mmap /dev/dsp
------------------------------------
Sound memory manager started
Sys_LoadDll(/home/zerbro/.wolf/main/ui.mp.i386.so)...
Sys_LoadDll(/home/zerbro/.wolf/main/ui.mp.i386.so) failed:
"/home/zerbro/.wolf/main/ui.mp.i386.so: cannot open shared object file: No such file or directory"
Sys_LoadDll(/usr/local/games/wolfenstein/main/ui.mp.i386.so)... ok
Sys_LoadDll(ui) found **vmMain** at 0x49497548
Sys_LoadDll(ui) succeeded!

J'avais un probleme similaire avec quake 3, et j'ai trouve la solution qui est de taper :
echo "quake3.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss
echo "quake3.x86 0 0 disable" > /proc/asound/card0/pcm0c/oss

Mais pour wolf, je ne trouve aucune solution...

Pour info, j'utilise le noyau 2.6.7 de debian, avec les drivers ALSA. Le son est gere par le chipset SIS de ma carte mere (drivers i8x0).

Quelqu'un a une idee ?

Merci !
  • # peut être

    Posté par . Évalué à 1.

    si tu utilise KDE essayes :
    killall artsd
    mais sinon je vois pas trop, à part peut être les permission sur /dev/, ou alors j'ai lu sur un forum qu'il fallait démarer ET et lancer la console "~" puis tapper
    snddevice "/dev/sound/adsp"
    ou /dev/adsp ou un truc dans le genre. le thread en question: http://www.linuxquestions.org/questions/archive/14/2004/01/1/131206(...)
    • [^] # Re: peut être

      Posté par . Évalué à 2.

      peut etre quelque chose qui peut marcher:

      lance les jeux avec artsdsp si artsd est lancé

      $ artsd &
      $ artsdsp -m q3demo

      pour les jeux autre que quake pareil mais sans le '-m'

      Bon courage pour jouer avec artsd comme serveur de son !
      • [^] # Re: peut être

        Posté par (page perso) . Évalué à 1.

        La solution analogue à Quake3 et QuiMarcheChezMoi(TM)

        echo "et.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss
        echo "et.x86 0 0 disable" >> /proc/asound/card0/pcm0c/oss
  • # solution

    Posté par . Évalué à 1.

    La solution est bien analogue a celle de quake3, pas besoin de tuer esd (ou arts) :

    echo "wolf.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss
    echo "wolf.x86 0 0 disable" >> /proc/asound/card0/pcm0c/oss
    echo "wolfsp.x86 0 0 disable" >> /proc/asound/card0/pcm0c/oss
    echo "wolfsp.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss

    et voila :)

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.