Forum Linux.général Probleme avec SSHFS

Posté par  (site Web personnel) .
Étiquettes : aucune
0
10
juin
2006
Bonjour a tous,
je pose cette question ne trouvant aucune réponse et surtout qui enleve un interet pour moi a sshfs.

Est-ce que quelqu'un connait une solution pour sshfs quand le client change d'ip alors qu'il y a des fichiers inuse pour pouvoir reconnecter automatique le lecteur distant sans avoir l'erreur que le périphérique est "busy" ?

Cela me serait d'une grande aide, merci de vos conseil/lumieres sur le sujet :)

A bientot,
--Sylvain
  • # option "reconnect" ?

    Posté par  . Évalué à 2.

    Si tu lances sshfs avec l'option "reconnect" et que tu spécifies le nom de ton serveur, la connexion n'est pas restaurée lorsque ce dernier change d'@ip ?

    http://www.google.com/search?q=sshfs+reconnect
    • [^] # Re: option "reconnect" ?

      Posté par  (site Web personnel) . Évalué à 1.

      merci de ta réponse je vais essayer, mais c'est pas le serveur qui change d'ip mais le client ..
      • [^] # Re: option "reconnect" ?

        Posté par  . Évalué à 2.

        Au temps pour moi, je suis benêt mais néanmoins content car le résultat de mon google inapproprié m'interesse néanmoins.

        Si tu arrives à trouver une solution pour ton problème, ca m'interesse aussi :)
        • [^] # Re: option "reconnect" ?

          Posté par  . Évalué à 1.

          Si on a le contrôle root du client et du serveur, un VPN peut être une solution (pas testé avec un montage fuse, mais avec rsync).

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.