Forum Linux.général [resolu] curlftpfs impossible de modifier les fichiers sur le disque monte

Posté par  . Licence CC By‑SA.
Étiquettes : aucune
0
29
mai
2020

Bonjour,

J'ai installé curlftpfs pour pouvoir monter un disque ftp et pouvoir ainsi modifier mon site directement, (mais peu importe la raison) voici ce que j'ai fait :
- J'ai installé curlftpfs

sudo apt install curlftpfs

-J'ai créé un groupe fuse et me suis ajouté dedans
-J'ai fait appartenir mon point de montage au groupe fuse :

chgrp fuse /media/monCompteLinux/toto

-J'ai édité le fichier /etc/fuse.conf pour décommenter user_allow_other
-J'ai ajouté la ligne suivante au fichier /etc/fstab
loginFTP:passFTP@urlFTP /media/monCompteLinux/toto fuse.curlftpfs rw,user,allow_other,uid=1000,_netdev 0 2

le point de montage se fait bien je vois tous les dossier et fichier mais je ne peu pas les modifier.

Détails peu être important je suis xubuntu 20.04

Avez vous une idée ?

  • # Se reloguer ?

    Posté par  . Évalué à 2 (+0/-0).

    Salut,

    En général, s'il n'y a pas déconnection/reconnection (pas besoin de redémarrer quand même, hein ! ;)), l'utilisateur n'est par défaut pas considéré dans le groupe.

    Pas du tout sûr que ça soit ça, mais au cas où…

  • # probleme UID ?

    Posté par  . Évalué à 2 (+0/-0).

    tes UIDs sont les memes entre les machines ?

    Perso j'ai ca pour activer mon serveur FTP, et je peux alors transférer des fichiers depuis/sur ce FTP

    curlftpfs#ftp://ftp-login:ftp-mot-de-passe@serveur.ftp.example.tld /mnt/dossier-ftp fuse    defaults,_netdev    0   0
    • [^] # Re: probleme UID ?

      Posté par  . Évalué à 1 (+0/-0).

      j'ai essayé dans de noter dans /etc/fstab
      comme toi mais j'avais vu quelque part sur le net que cette facon de noter était déprécier et qu'il fallait noté comme je l'ai fait

      mais dans les deux cas j'ai le même problème

      pour le UIDs je ne sais pas ou regarder ? peux tu me donner la commande pour vérifier cela ?

      • [^] # Re: probleme UID ?

        Posté par  . Évalué à 2 (+0/-0).

        pour le UIDs je ne sais pas ou regarder ? peux tu me donner la commande pour vérifier cela ?

        getent peut t'aider

        root@machine # getent passwd root
        root:x:0:0:root:/root:/bin/bash
        root@machine # getent group root
        root:x:0:

        le premier nous montre que l'UID de root est 0 (le premier après le x)
        le 2e nous montre que le groupe root a le GID 0 (le premier après le x)

        et que l'utilisateur lambda

        getent passwd lambda
        lambdax:1001:100:,,,:/home/lambda:/bin/bash

        a l'UID 1001, le GID 100 (groupe users)

        • [^] # Re: probleme UID ?

          Posté par  . Évalué à 1 (+0/-0).

          mon uid c'est bien 1000 mais j'avoue que c'est un coup de chance je n'avais pas vérifié cela

          • [^] # Re: probleme UID ?

            Posté par  . Évalué à 2 (+0/-0).

            si tu es le seul utilisateur de la machine, ton numero est 1000 sur beaucoup de distribution, 1001 pour le 2e utilisateur, etc

  • # Une vérification de base

    Posté par  . Évalué à 2 (+0/-0).

    -J'ai ajouté la ligne suivante au fichier /etc/fstab
    loginFTP:passFTP@urlFTP /media/monCompteLinux/toto fuse.curlftpfs rw,user,allow_other,uid=1000,_netdev 0 2
    […]
    Avez vous une idée ?

    uid=1000, l’as-tu juste repris d’un exemple ou as‐tu vérifié que c’est bien ton uid local ?

    La commande id t’indiquera ton uid (entre autres) ; si ce n’est pas 1000, remplace celui-ci.

    Frаnсе : 29875, Allеmаgnе : 9003. Масrоn : 20872.

    • [^] # Re: Une vérification de base

      Posté par  . Évalué à 1 (+0/-0).

      mon uid c'est bien 1000 mais j'avoue que c'est un coup de chance je n'avais pas vérifié cela

      • [^] # Une autre vérification de base

        Posté par  . Évalué à 2 (+0/-0).

        Est-ce que le serveur FTP donne bien le droit d’écriture à ton loginFTP ?

        Essaie par exemple avec lftp ou ftp de faire mkdir test

        Frаnсе : 29875, Allеmаgnе : 9003. Масrоn : 20872.

        • [^] # Re: Une autre vérification de base

          Posté par  . Évalué à 1 (+0/-0).

          Il s'agit d'un serveur FTP de free (ftpperso.free.fr)
          J'ai bien les droits pour modifier les fichiers dessus avec Filezilla que j'utilise depuis des années aucun soucis.

          Le comportement est vraiment étrange :

          mkdir test
          => ok

          cd test
          => ok

          echo "toto" > titi
          => ok

          more titi
          => ok :il affiche bien toto

          vi titi
          => ko : "titi" [Permission Denied] vi s'ouvre je vois le contenu du fichier mais j'ai le message en bas

          sudo vi titi
          => ko : E200: *ReadPre autocommands made the file unreadable (vi s'ouvre je NE vois PAS le contenu du fichier et j'ai le message en bas en rouge)

          ll
          => -rw-r--r-- 1 [monNomUser] root 5 mai 31 17:05 titi

          • [^] # Re: Une autre vérification de base

            Posté par  . Évalué à 2 (+0/-0). Dernière modification le 01/06/20 à 10:21.

            vi titi
            => ko : "titi" [Permission Denied] vi s'ouvre je vois le contenu du fichier mais j'ai le message en bas

            parce que le FTP est un flux,
            tu peux lire le contenu (tu récupères le fichier et tu l'affiches)
            tu peux écrire dedans (tu envoie les données sur le serveur)

            mais tu ne peux pas faire un vi qui demande à garder le fichier ouvert.
            donc en ligne de commande ca ne fonctionne pas.

            pour un cas comme le tiens j'utilise en fait FileZilla et son menu "edit"
            ca telecharge temporairement le fichier, l'ouvre avec l'éditeur prévu, je fais mes modifs, je sauvegarde, FileZilla détecte la fermeture du fichier temporaire et me propose de renvoyer les modifications au serveur.

            • [^] # lftp

              Posté par  . Évalué à 2 (+0/-0).

              pour un cas comme le tiens j'utilise en fait FileZilla et son menu "edit"

              Pour ma part, je travaille sur une copie locale et j’utilise la commande mirror -R de lftp pour mettre à jour la version sur le serveur (le plus simple, se mettre dans le bon répertoire en local et en distant et lancer mirror -v -R . .).

              Frаnсе : 29875, Allеmаgnе : 9003. Масrоn : 20872.

              • [^] # Re: lftp

                Posté par  . Évalué à 1 (+0/-0).

                Je pensais justement que curlftpfs détectait les modifications de fichier et les renvoyait au serveur en ftp de façon transparente.
                Mais si ce n'est pas le cas tampis je vais faire autrement .. soit avec un petit script lftp effectivement soit avec la fonction edit de filezilla (que je ne connaissais pas) pour les petites modifs rapide.

          • [^] # C’est Free, mais c’est pas grave

            Posté par  . Évalué à 2 (+0/-0).

            Il s'agit d'un serveur FTP de free (ftpperso.free.fr)

            Ah…

            Bah si j’essaie là dessus en lançant curlftpfs avec l’option -d, j’obtiens un florilège d’erreurs, entre les opérations non supportées et la limite du nombre de connexions simultanées (le plus génial, ça assure qu’une opération qui réussit à un moment rate à un autre) :

            open flags: 0x28002 /test.txt
            ftpfs: operation ftpfs_open failed because Operation not supported
               unique: 816, error: -95 (Operation not supported), outsize: 16
            
            * Connected to ftpperso.free.fr (212.27.63.3) port 21 (#12)
            < 421 Vous ne pouvez avoir que 2 connexions simultannees
            * We got a 421 - timeout!
            * Closing connection 12
            
            < 530 Sorry, the maximum number of clients (2) for this user are already connected.
            * Access denied: 530
            * Closing connection 0
            

            curlftpfs ne semble pas avoir d’options telles que limiter le nombre de connexions simultanées.

            Bon, de toute façon, de nos jours, un service correct supporterait sftp ou ftps (et https pour l’accès public !), ce qui n’est pas le cas du serveur de pages personnelles de Free.

            Désolé.
            Vous avez Free, c’est tout pourri.
            (Après, les pages perso n’étant pas le service à la dernière mode, je ne suis pas sûr que tous les autres FAI en proposent, et je ne sais pas s’il y en a qui en proposent avec un service correct…)

            Frаnсе : 29875, Allеmаgnе : 9003. Масrоn : 20872.

            • [^] # Re: C’est Free, mais c’est pas grave

              Posté par  . Évalué à 1 (+0/-0).

              Mon Fai, orange propose le même service mais en pire car il ne propose pas de base de donnée et ne supporte pas le PHP… en gros on peut juste faire des pages statique en HTML et JS (coté client) donc la pour le coup on est encore moins à la dernière mode ;-)

              Pour free malgré tous ses défaut il à la grosse qualité d'être gratuit, et pour mon usage c'est suffisant.
              Mais tu as raison on sent que c'est un service de moins en moins à la mode et qu'un jour ou l'autre il va disparaître.

              Merci en tous cas pour votre aide à tous les 3.

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.