Forum Linux.général X-forwarding sur réseau local

Posté par .
Tags : aucun
0
1
août
2012

Bonjour à tous,

Je cherche à afficher le bureau d'une machine distante (Arch) sur ma machine (Debian).
Les deux machines sont connectées à mon réseau local.

Je n'ai pas trouvé beaucoup de doc claire sur la sujet donc je m'en remets à vous.

ssh -X user@IP 

me donne (après une connexion réussie)

X11 forwarding request failed on channel 0

Je n'ai pas bien compris si je pouvais/devais me logguer avec le user actuellement connecté sur le serveur.

Merci de votre aide!

  • # partage de bureau ?

    Posté par (page perso) . Évalué à 2.

    Si tu cherches à faire du partage de bureau, regarde plutôt du côté de vnc.

    ssh -X permet d'utiliser un X disponible sur le serveur distant pour afficher en local, et à moins d'avoir loupé des options de ssh tu pourras pas afficher le bureau (à moins de lancer gnome après ?!)

    En tout cas, essaie sur le serveur de couper tout ce qui est graphique style gdm et réessaye, ça devrait passer. Si c'est ça, il faut utiliser un autre channel (là je sais pas comment faire faut voir la doc)

    • [^] # Re: partage de bureau ?

      Posté par . Évalué à 2.

      Je précise que mon but est d'afficher une application de la machine distante sur le bureau de l'autre machine, mais la machine distante doit en garder le contrôle (et par la même son serveur x actif, en gros rien ne change pour elle).

      J'ai toujours cru que c'était possible assez facilement, mais j'ai peut-être tort.

      Si ce n'est pas possible avec ssh je vais jeter un oeil à vnc, mais ça m'embête un peu quand même.

  • # xauth

    Posté par . Évalué à 3.

    Cela ressemble à un problème lié à Xauth.
    Est-il bien installé des deux cotés ?

    • [^] # Re: xauth

      Posté par . Évalué à 2.

      Je viens de vérifier, la réponse est oui. A noter que lors de la connexion la clé a été correctement ajoutée.

      • [^] # Re: xauth

        Posté par . Évalué à 2.

        tu peux essayer un -Y à la place du -X

        Extrait du man :

        -Y Enables trusted X11 forwarding. Trusted X11 forwardings are not subjected to the X11 SECURITY extension controls.

        Je te conseille de lire le man pour bien voir la differences entre le -X et le -Y. Sur deux machines que tu contrôle a priori tu peux utiliser -Y sans soucis.

        Nota :
        Souvent, même en local, rajouter une couche de compression des flux (-C) est profitable. Le protocole X est particulierement verbeux.

  • # sshd_config

    Posté par . Évalué à 2.

    Bon question de base mais obligé de la poser : l'option "X11Forwarding yes" est elle bien présente dans le /etc/ssh/sshd_config sur la machine serveur ?

    Sinon plus tordu si IPv6 est activé ou même disponible sur ta machine essayes l'option "AddressFamily inet" qui force SSH à utiliser IPv4.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.