Forum Linux.gentoo installation gentoo make.conf

Posté par .
Tags : aucun
0
21
déc.
2005
bonjour,
j'ai essayer d'installer gentoo 2005.1 a partir du stage1 mais un probleme c'est produit lors de l'instalation ( j'ai suivis les instructions du mode d'emploi). Lors de la compilation des fichiers sources une erreure survint aux alentour du fichier 130 ou 131 sur 181, et la compilation s'arrete là ( erreur disant qu'il ne trouve pas l'image du noyau ou le noyau 2.6...., ça ete trop vite , je n'ai pas pu tout lire). Il y a donc a priori un cinquantaine de fichiers qui ne sont pas compilés.
Je vous demande de m'aider donc a regler ce probleme .
J'ai tout de meme deux piste:

- le variable CHOST tout d'abord : initialement sans que j'y touche elle etait initialisé a un truc comme ...i386.. et mon architechture de mon processeur est i686 . Certain site me conseillais de ne pas y toucher, d'autres de changer le i386 par i686. J'ai donc remplacé le i386 par i686 mais sans certitude . En effet je n'ai pas trouvé ce que representait exactement cette variable (architechture du proc ? image de l'installation? ...)

- la variable USE ensuite : j'ai surment mis trop de drapeaux ou peut etre quelque uns etaient incompatible entre eux. De plus j'ai mis des \ a la fin de chaque lignes (mais fallait il le faire?)
Je vais donc vous montrer les flags que j'ai mis :

3dnow X a52 aac aalib acpi alsa arts avi bcmath bzip2 cdparanoia cdr crypt \
cups doc dvd dvdr emacs amacs-w3 encode exif fbcon fortran gif gnome gpg gtk \ hardened hardenedphp ieee1394 java jpeg kde lirc mng mozilla mp3 mplayer \
nas nvidia ogg oggvorbis opengl pcmcia php python quiktime samba shorten \
spell sse ss2 ssl svg theora tiff truetype usb v41 vcd vorbis wifi wmf xface \ xine xmms xosd xvid

Pour info j'ai un portable pavillon zd7000 qui a un an .
voila, marci beaucoup de vous procuper de mon probleme. Toute reponse a mes question m'interesse. Et merci d'avance.

ps : J'ai aussi un probleme avec ma carte son, il ne trouve pas de drivers au demarage de l'installation. Faut il faire une manip a ce moment là ou vaut il mieux la faire une fois que j'aurais un os fonctionnel?
  • # Quelques pistes

    Posté par . Évalué à 1.

    La variable i386 / i586 / i686... désigne bien le type de processeur. i386 est beaucoup plus général et fonctionnera bien sûr si ta machine est i586 ou i686.
    En revanche, pas de compatibilité descendante.

    Dans le pire des cas, si démarrer de la stage1 n'est pas une obligation pour toi, pars d'une stage2 ou stage3. je n'ai jamais réussi à faire une install stage1 mais avec stage2 ou 3, pas de prob. Je ne sais pas si partir de la stage1 change vraiment de façon notable les performances.

    A propos de ta carte son, connais-tu le modèle (ou le chipset le gérant ?). Pour cela réfère toi à la doc de ta carte mère (ou du portable).
    Si c'est AC'97, il faut charger le module snd_intel8x0
    Pour plus d'infos :
    http://www.alsa-project.org/
    • [^] # Re: Quelques pistes

      Posté par . Évalué à 1.

      Merci beaucoup pour t'as reponse . Ma carte son me pose pas mal de probleme . Et je viens de decouvrir que c'est a cause d'elle qu'a chaque fois que j'installais debian ça ne marchais pas (le probleme c'est que debian marquais que l'erreur venait de synaptics) . Je vais donc regarder ça . Merci encore pour ton aide.
      Sinon pour les flags , sont ils a priori corects ou y a t' il un pb?
      • [^] # Re: Quelques pistes

        Posté par . Évalué à 1.

        Je ne suis pas un grand spécialiste des flags mais je ne vois rien d'aberrant dans ta liste ! As-tu essayé en en mettant moins ?
        • [^] # Re: Quelques pistes

          Posté par . Évalué à 1.

          En general il n'est pas conseillé de mettre trop de flag use globaux, ce qui peut alourdire le systeme et le charge de boulot pour l'administrer.

          On prefere en general garder tres peu de flag globaux et les choisir paquet par paquet via le fichier package.use afin d'avoir un controle plus fin.
  • # Heu..

    Posté par (page perso) . Évalué à 2.

    C'est drole parce qu'il me semblait que gentoo ne "supportait" plus les stages 1 et deux (cf http://www.gentoo.org/doc/en/handbook/2005.1/handbook-x86.xm(...) )

    (extrait du 5.b : Make sure you download a stage3 tarball - installations using a stage1 or stage2 tarball are not supported anymore.)

    Pour faire avec ces stages il faut donc se referencer aux doc du 2004.2 pour les parties 5 et 6 (en verifiant en même temps sur le 2005.1 pour rien oublier)

    http://www.gentoo.org/doc/en/handbook/2004.2/handbook-x86.xm(...)

    Bon courrage

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.