Forum Linux.gentoo son nforce

Posté par .
Tags : aucun
0
10
oct.
2005
bonour. j ai un soucis avec la carte son integree dans mon chipset nforce , (kernel 2.6)

liste des modules chargés

snd_intel8x0 30336 1
snd_ac97_codec 72668 1 snd_intel8x0
snd_pcm 81128 2 snd_intel8x0,snd_ac97_codec
snd_timer 22996 1 snd_pcm
snd 49508 6 snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer
snd_page_alloc 9784 2 snd_intel8x0,snd_pcm
i2c_nforce2 6416 0


voila le son marche sous totem (lecteur multimedia )mais pas sous xmms celui ci ne trouve pas /dev/dsp en effet il n existe pas


quelqu un a t il une idee ?
  • # driver alsa pour xmms

    Posté par . Évalué à 2.

    /dev/dsp si je me souvient bien est le device OSS ( obselete soud system ) et c'est ce qui est utilisé par défaut dans xmms, donc pour configurer ton xmms pour qu'il aille se servir d'Alsa, tu clique droit sur le xmms tu fait prédérences, tu vas dans l'onglet le plus a gauche ( je crois que tu dois déjà y etre )

    et tu vas sur les plugins de sortie et a la place de OSS tu sélectionne alsa ^^

    si c'est pas dispo, tu installe le paquetage xmms-alsa ( ou un truc de ce genre )

    l'autre solution est d'activer l'émulation oss, mais n'ayant pas mon linux sous la main je ne peux pas te dire quel module activer ( mais essaye modprob snd-pcm-oss ou un truc de ce genre )

    ps: oui le O de oss ne veut pas dire obselete ou old, mais bon...

    Il ne faut pas décorner les boeufs avant d'avoir semé le vent

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.