Forum Linux.mandriva Impossible de compiler

Posté par .
Tags : aucun
0
3
mar.
2005
Bonjour

J ai installé une Mandrake 10.1 Official.
Celle ci est livré avec Quanta 3.2 et il n existe pas de RPM Mandrake pour la 3.3 : Donc je prends les sources et j installe.

J ai eu pas mal de pb en executant ./configure j en ai resolu la plupart, cependant je bute sur l'erreur suivante : Il manque des librairies X11 notament dans le folder X11R6/include/X11, verifier votre install ou mettez à jour votre path.

En consultant les forums je trouve qu il faut installer les packages X11-devel.
Ok en utilisant l interface graphique je rajoute un serveur FTP sur un mirroir madrake 10.1 official sur main, je cherche les packages et j installe. La j ai un message qui me dit Desole les packages ne peuvent pas etre installés !!! Pourquoi ??? Pas de precision, pas d explication .... Léger sur ce coup là

Alors avec un browser je vais directement sur le serveur FTP je retrouve le package, en cliquant dessus il me propose soit de l enregistrer soit de l installer, je l installe bien entendu, et la il me dit que tout est déja installé ...

Bon alors mes questions sont :

1- Quand l interface graphique me dit qu elle est désolé et qu elle ne peut installer les packages est ce que ca veut dire que tout est déja installer

2- Si tout est installé comme me dit le resultat du second type d install pourquoi je n arrive toujours pas à compiler et qu est ce que j oublie pour pouvoir compiler ?

Merci de vos réponses

XaV
  • # les entetes y sont bien ?

    Posté par . Évalué à 2.

    tu as des fichiers dans /usr/X11R6/include/X11/ ?

    ( d'apres http://rpmfind.net//linux/RPM/mandrake/updates/10.1/main_updates/li(...)

    c'est là dedans que les entetes X11 sont installés.

    Si ils y sont:
    c'est peut etre le configure qui va pas les chercher ou il faut
    ./configure --help pour voir quelle est l'option a passer pour spécifier l'emplacement.

    S'ils n'y sont pas
    urpmi libxorg-x11-devel en root dans un shell
    • [^] # Re: les entetes y sont bien ?

      Posté par . Évalué à 1.

      Ok apres un urpmi ca c est installé correctement

      en fin de compte mon media de package n etait pas bon parceque je n arrivais pas sur la bonne version : Il pourrait le dire quand meme.

      Bon j ai eu un pb avec QT3 aussi, toujours avec le meme probleme pour choisir la bonne version

      On fait comment pour savoir quelle est la version installée ???

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.