Forum Linux.mandriva Ndiswrapper 1.21 : 'Driver neti2220 invalid!'

Posté par .
Tags : aucun
0
7
mar.
2007
Bonjour à tous, j'install ce soir une mandriva sur le portable d'un ami. C'est un acer travelmate 2700 et j'ai un gros problème concernant la configuration du wifi et très peu d'experience n'ayant pas eu à utiliser ndiswrapper sur mon ibook 12'.

Donc un lspci sur sa carte me répond : :02:02:0 Ethernet controller: Linksys, A division of Cisco Systems (AirConn) INPR0COMM IPN 2220 Wireless LAN Adapter (rev 01).

J'ai donc regarder sur le wiki de ndiswrapper et elle parait être utilisable :

Laptop: Acer Aspire 1524 WLMi
Chipset: Linksys, A Division of Cisco Systems [AirConn] INPROCOMM IPN 2220 Wireless LAN Adapter (rev 01)
pciid: 17fe:2220
Driver: Ndiswrapper 1.4-rc2 and driver from planetamd64.com (and the official driver from Acer works, too).
Other: Works correctly with 64bit system with open access, encryption works (with wpa_supplicant) at least for WPAPSK + TKIP. Other methods untested.

J'ai donc récupéré le fichier neti2220.inf sur le net qui est indiqué dans la plupart des tutoriaux.

Ensuite j'ai executé le fameux ndiswrapper -i neti2220.inf il me répond qu'il l'a installé et lorsque je vérifie par la commande ndiswrapper -l il me répond neti2220.inf driver invalid!.

J'ai épluché google et je ne trouve plus rien à essayer donc je me permet de poster içi.

Merci à ceux qui vont lire, moi je vais me coucher !!!
  • # ndiswrapper quel version ?

    Posté par . Évalué à 1.

    car il est bien dit qu'il te faut la version 1.4-rc2

    et aussi que cela devrait marché avec le driver acer (probablement fournit sur le CD ou sur le site du fournisseur) and the official driver from Acer works, too).
    • [^] # Re: ndiswrapper quel version ?

      Posté par . Évalué à 1.

      J'avais bien remarqué ce problème de version mais le problème est que sur sourceforge la version la plus récente de ndiswrapper est la 1.38. Je ne trouve guere d'info sur cette version grâce à google. Dois je donc installer la version cvs ?
  • # Compilation

    Posté par . Évalué à 1.

    Merci j'avais pas vérifié la version ... Je l'ai donc trouvé et décompressé mais j'ai du mal à compiler . Il manquait d'abord make et gcc que j'ai installer via urpmi mais maintenant je bute sur cette ereur lors de la commande make :

    973: error: ‘struct usb_driver’ has no member named ‘owner’

    J'ai ensuite essayé avec la commande make DISABLE_USB=1 et toujours le même résultat .


    Et là je pose le retour complet de la commande à tout hasard.

    make -C driver
    make[1]: entrant dans le répertoire « /home/magid/Documents/ndiswrapper-1.4rc2/ndiswrapper-1.4rc2/driver »
    make -C /lib/modules/2.6.17-5mdvlegacy/build SUBDIRS=/home/magid/Documents/ndiswrapper-1.4rc2/ndiswrapper-1.4rc2/driver \
    DRIVER_VERSION=1.4rc2 \
    UTILS_VERSION=1.2 modules
    make[2]: entrant dans le répertoire « /usr/src/linux-2.6.17-5mdv »

    WARNING: Symbol version dump /usr/src/linux-2.6.17-5mdv/Module.symvers
    is missing; modules will have no dependencies and modversions.

    CC [M] /home/magid/Documents/ndiswrapper-1.4rc2/ndiswrapper-1.4rc2/driver/loader.o
    /home/magid/Documents/ndiswrapper-1.4rc2/ndiswrapper-1.4rc2/driver/loader.c: In function ‘register_devices’:
    /home/magid/Documents/ndiswrapper-1.4rc2/ndiswrapper-1.4rc2/driver/loader.c:973: error: ‘struct usb_driver’ has no member named ‘owner’
    /home/magid/Documents/ndiswrapper-1.4rc2/ndiswrapper-1.4rc2/driver/loader.c: At top level:
    /home/magid/Documents/ndiswrapper-1.4rc2/ndiswrapper-1.4rc2/driver/loader.c:1126: fatal error: opening dependency file /home/magid/Documents/ndiswrapper-1.4rc2/ndiswrapper-1.4rc2/driver/.loader.o.d: Permission non accordée
    compilation terminated.
    make[3]: *** [/home/magid/Documents/ndiswrapper-1.4rc2/ndiswrapper-1.4rc2/driver/loader.o] Erreur 1
    make[2]: *** [_module_/home/magid/Documents/ndiswrapper-1.4rc2/ndiswrapper-1.4rc2/driver] Erreur 2
    make[2]: quittant le répertoire « /usr/src/linux-2.6.17-5mdv »
    make[1]: *** [default] Erreur 2
    make[1]: quittant le répertoire « /home/magid/Documents/ndiswrapper-1.4rc2/ndiswrapper-1.4rc2/driver »
    make: *** [all] Erreur 2
  • # Ndiswrapper de merde...

    Posté par (page perso) . Évalué à 2.

    Pourquoi tu te fait chier avec ndiswrapper ????

    Il existe un driver libre pour cette carte (enfin vu le numéro) :
    ipw2200

    # urpmi ipw2200-firmware
    ...
    # modprobe ipw2200
    ...
    # drakconnect

    Franchement arrêtez avec vos pratiques de recompilation et autre "debianneries" rétrogrades et stupides...

    Mandriva est une distribution pour débutant, ça veux dire que tout est déjà mâché !

    Bon après si tu a fait la CONNERIE d'installer avec la version libre pour le plaisir, ben tu a pas le firmware qui va bien et ça marche pas...

    Faut ajouter les sources plf pour avoir ipw2200-firmware

    Bref, avant d'aller faire le kador et de vouloir tout recompiler comme un pro, utilise les outils a disposition, ils sont neuneu proof...

    ps : je suis un utilisateur avancé capable de tout recompiler, mais franchement j'ai choisi mandriva parce que j'ai pas besoin de me faire chier dès que je dois faire un truc exotique que j'ai jamais fait...
    • [^] # Re: Ndiswrapper de merde...

      Posté par (page perso) . Évalué à 2.

      Coup de gueule passé, maintenant, une simple réflexion t'aurait répondu :
      # modinfo ipw2200
      filename: /lib/modules/2.6.20-tmb-desktop-2mdv/kernel/drivers/net/wireless/ipw2200.ko.gz
      description: Intel(R) PRO/Wireless 2200/2915 Network Driver
      version: 1.2.0kmprq

      A comparer a ton :
      Chipset: Linksys, A Division of Cisco Systems [AirConn] INPROCOMM IPN 2220 Wireless LAN Adapter (rev 01)

      Je précise je j'ai JAMAIS utilisé de wifi de ma vie (ou presque) et je connais de manière basic le noyau et ses modules...

      ps : que utilise un kernel legacy est une CONNERIE !
      (sauf pentium/celeron buggué du PAE)

      # urpmf --fuzzy kernel
      (va te donne la liste de kernel, installe le plus récent, dessous, le dernier en date)
      # urpmi kernel-2.6.17.11mdv kernel-source-stripped-2.6.17.11mdv
      Et reboot dessus...
      • [^] # Re: Ndiswrapper de merde...

        Posté par . Évalué à 1.

        J'ai executé ce que tu m'as dit de faire. Télécharger le firmware avec le modprobe qui va avec sans oublié le changement de noyau précisé dans ton deuxieme commentaire. Sache juste que c'est drakconf qui me propose d'utiliser ndiswrapper (c d'ailleurs le seul choix qu'il me laisse) et rien n'a changé après avoir fait ce que tu m'as conseillé de faire.


        amicalement, yohann
        • [^] # Re: Ndiswrapper de merde...

          Posté par (page perso) . Évalué à 2.

          Essaye d'aller voir en cooker si il y a pas une mise a jour pour le driver de ta carte wifi ?

          Il se peux que le noyau|harddrake ne connaisse pas parfaitement ta carte réseau.

          Essaye si tu peux la version 2007.1 en test2. elle résoudra peut-être tes soucis.

          En tout cas pour du linksys, c'est pas normal d'avoir a utiliser du ndiswrapper, normalement c'est bien supporté comme carte ça...
  • # Live cd

    Posté par . Évalué à 1.

    Est ce que cela peut être du au fait que j'ai installer le systèmeà partir de mandriva one ? Sinon le Harddrake reconnait bien cette carte réseau mais ne trouve pas de module et comme j'ai déja expliqué lorsque je clic sur configurer le module il me propose que de charcher le pilote avec ndiswrapper. Crois tu que ça valent le coup de télécharger ou acheter un dvd/cd mandriva 2007 complet ?

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.