Forum Linux.mandriva Qt4 wt qmake

Posté par .
Tags : aucun
0
26
sept.
2007
J'ai fait l'installation des paquetages de QT4 sur Mandriva 2007 mais j'ai toujours le même message d'erreur à l'installation de qtpfsgui-1.8.12
$ qmake
Project MESSAGE: Detecting Qt version:
Project MESSAGE: error, Qt3 found!
Project MESSAGE: It seems like we are using Qt3, which is wrong!
Project MESSAGE: to install qt4 in ubuntu run:
Project MESSAGE: sudo apt-get install libqt4-dev qt4-dev-tools libqt4-core
Project MESSAGE: to install qt4 in fedora core 6 run (as root):
Project MESSAGE: yum install qt4-devel
Project MESSAGE: Make sure also that you are using the Qt4 versions of the executables qmake, uic and moc.
Project MESSAGE: To do so in Ubuntu you can install galternatives to switch those executable from Qt3 to Qt4, by running:
Project MESSAGE: sudo apt-get install galternatives
Project MESSAGE: and then run galternatives with:
Project MESSAGE: sudo galternatives
Project MESSAGE: In fedora you can simply invoke qmake with its full qt4 path:
Project MESSAGE: /usr/lib/qt4/bin/qmake
Project MESSAGE: In Ubuntu you can invoke Qt4's qmake with:
Project MESSAGE: qmake-qt4
Project MESSAGE: If you, on the other had, think that this message is wrong and indeed you HAVE Qt4, send an email to grota@users.sourceforge.net saying so.
Project ERROR: fatal error, bailing out.

Tout ce que je comprend c'est que Mandriva ne me donne pas de qmake pour qt4.
Comment faire?
Merci
  • # qmake-qt4

    Posté par . Évalué à 2.

    Bonjour,
    il me semble que tu dois avoir maintenant 3 programmes qui commencent par qmake:
    * qmake-qt3 : qui est le qmake de Qt3
    * qmake-qt4: le qmake de Qt4
    * qmake : un lien symobolique qui renvoie actuellement (d'après tes messages d'erreur) vers Qt3.

    Tu as donc deux solutions:
    soit tu t'arranges pour que le lien symbolique qmake renvoie vers qmake-qt4, soit tu t'arranges pour que le programme d'installation de qtpfsgui-1.8.12 utilise la commande qmake-qt4 au lieu de qmake.
    C'est clair?

    Sinon, tu indiques avoir installé Qt4, mais attention, il faut bien installer les paquets "de développement", c'est à dire les paquets qui finissent pas -dev ou -devel.

    Bonne chance, tu y es presque!

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.