Forum Linux.noyau ASPM problem on a Primergy RX 300 S5

Posté par . Licence CC by-sa.
Tags : aucun
-1
5
fév.
2013

Bonjour,

J'ai 3 serveurs sur Ubuntu 12.04.2 LTS.
Il y a 2 Primergy RX 300 S4 et un Primergy RX 300 S5.
Je n'ai jamais eu de problème en mettant à jour les S4 mais le S5 crash au boot avec quelques noyaux que ce soit au dessus du 3.0.0.16 .

Dans le message d'erreur, j'ai remarqué un message semblable à çà:

ACPI _OSC control not granted, disabling ASPM

Quand je boot avec le 3.0.0.16 et que je fait un dmesg | grep aspm

[    0.925726] pci 0000:01:00.0: disabling ASPM on pre-1.1 PCIe device.  You can enable it with 'pcie_aspm=force'
[    0.934665] pci 0000:09:00.0: disabling ASPM on pre-1.1 PCIe device.  You can enable it with 'pcie_aspm=force'

Ensuite j'essaie de voir ce que peuvent bien être ces puces.

lspci -s 0000:01:00.0
01:00.0 RAID bus controller: LSI Logic / Symbios Logic MegaRAID SAS 1078 (rev 04)
lspci -s 0000:09:00.0
09:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G200e [Pilot] ServerEngines (SEP1) (rev 02)

On dirait que ce sont donc le contrôleur raid et vga qui mettent le boxon.

Est ce qu'il y a une stratégie plus intelligente que de mettre

pcie_aspm=off

Si oui laquelle et surtout est ce quelqu'un peut m'éclairer sur les problèmes éventuel que ça pourrait amener ? Hormis une consommation excessive de courant.

Merci

  • # un reglage dans le bios ne suffirait pas ?

    Posté par . Évalué à 2.

    tu ne peux pas desactiver certaines options de l'ACPI dans le bios ?

    • [^] # Re: un reglage dans le bios ne suffirait pas ?

      Posté par . Évalué à 0.

      Effectivement, l'idée était très bonne mais il n'y avait aucun réglage lié à ça dans le bios même de loin.

      Maintenant le problème est p-e lié au matériel pcq qu'on à déplacé les disques dans une autre machine et ça boot sans broncher.

      Merci pour l'idée en tout cas

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.