Forum Linux.redhat FC4 et awstats (SELinux?)

Posté par  .
Étiquettes : aucune
0
22
déc.
2005
Je suis incapable de faire tourner awstats sur FC4. Le soucis ce pose sur l'accès au awstats.pl (access failed dans le error_log).
Si je désactive la partie auth (par fichier htpasswd) dans le vhost utilisant awstats le reste de la configuration fonctionne (les stats sont visibles)

J'ai vérifié les permissions par rapport à une autre machine ou awstats fonctionne tout semble ok. L'utilisateur apache à bien accès en lecture au fichier htpasswd concerné.

Peut être qu cela vient il du SELinux activé sous FC4, j'ai essayer un peut tous les contextes préconisé sur le net et notament sur le site de RedHat mais rien n'y fait.

J'ai activé l'audit sur le selinux mais aucun message ne semble concerné awstats ou apache.

Toute aide/suggestion serait la bien venue.
  • # Désactivé selinux

    Posté par  . Évalué à 1.

    Peut être bête à dire mais désactive selinux pour tester déja.
    Personellement je l'ai désactivé tout cour, parce que ca m'a poser trop de galère.
    Pour le désactiver : vi /etc/selinux/config
    et mettre SELINUX=disabled
  • # Mea culpa

    Posté par  (site Web personnel) . Évalué à 1.

    Oui, ça vient bien de SELinux. Tape "setenforce 0" en root et tu vas voir, ça remarche (ça désactive temporairement SELinux).
    Pour que ça marche avec SELinux il faut que tu tapes les commandes suivantes :
    chcon -t httpd_sys_script_exec_t -R /usr/share/awstats/wwwroot/cgi-bin
    chcon -t httpd_sys_content_t -R /var/lib/awstats/

    C'est moi qui fais le package d'AWStats pour Fedora, et je ne m'étais pas préoccupé de SELinux jusqu'ici. J'avoue, c'est ma faute. Quelqu'un a des réducs sur les orties fraîchement coupées ?
    Je vais voir ce que je peux faire pour la prochaine version du package, mais c'est pas trivial.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.