Forum Linux.redhat Probleme lancement GDM

Posté par .
Tags : aucun
0
1
juin
2007
Bonjour,

J'ai actuellement un soucis sur ma RHEL4 : gdm ne se lance pas correctement. J'ai un message d'erreur dans une fenetre gtk : Cannot start the greeter program, you will not be able to login. This display will be disabled. Try logging in by other means and editing the configuration file

Voici ce qui s'affiche dans mon /var/log/messages : gdm_slave_greeter: Cannot start greeter trying default: /usr/bin/gdmlogin
dans mon /var/log/gdm/:0.log

X Window System Version 6.8.2
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: Linux 2.6.9-34.0.1.ELsmp i686 [ELF]
Current Operating System: Linux localhost.localdomain 2.6.18-8.1.1.el4 #1 SMP Thu May 31 13:24:08 CEST 2007 i686
Build Date: 11 July 2006
Build Host: hs20-bc1-1.build.redhat.com

Before reporting problems, check http://wiki.X.Org
to make sure that you have the latest version.
Module Loader present
OS Kernel: Linux version 2.6.18-8.1.1.el4 (root@localhost.localdomain) (gcc version 3.4.6 20060404 (Red Hat 3.4.6-3)) #1 SMP Thu May 31 13:24:08 CEST 2007
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Jun 1 10:11:48 2007
(==) Using config file: "/etc/X11/xorg.conf"


A quoi cela peut il etre du ?


Voici le contenu de mon xorg.conf :

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection
Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection
Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection
Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr-latin9"
EndSection
Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection
Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Samsung SyncMaster 750(M)b"
DisplaySize 320 240
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 160.0
Option "dpms"
EndSection
Section "Device"
Identifier "Videocard0"
Driver "ati"
VendorName "Videocard vendor"
BoardName "ATI Rage XL"
EndSection
Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 16
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "800x600" "640x480"
EndSubSection
EndSection
Section "DRI"
Group 0
Mode 0666
EndSection


et de mon /etc/X11/gdm.conf

[daemon]
AutomaticLoginEnable=true
AutomaticLogin=root
TimedLoginEnable=false
TimedLogin=
TimedLoginDelay=30
Greeter=/usr/bin/gdmlogin
GtkModulesList=gail:atk-bridge:/usr/lib/gtk-2.0/modules/libdwellmouselistener:/usr/lib/gtk-2.0/modules/libkeymouselistener
DefaultPath=/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin
RootPath=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin
User=gdm
Group=gdm
LogDir=/var/log/gdm
PidFile=/var/run/gdm.pid
PostLoginScriptDir=/etc/X11/gdm/PostLogin/
PreSessionScriptDir=/etc/X11/gdm/PreSession/
PostSessionScriptDir=/etc/X11/gdm/PostSession/
DisplayInitDir=/etc/X11/gdm/Init
XKeepsCrashing=/etc/X11/gdm/XKeepsCrashing
ServAuthDir=/var/gdm
BaseXsession=/etc/X11/xdm/Xsession
DefaultSession=default.desktop
UserAuthDir=
UserAuthFBDir=/tmp
UserAuthFile=.Xauthority
StandardXServer=/usr/X11R6/bin/X
Xnest=/usr/X11R6/bin/Xnest -audit 0 -name Xnest
[security]
AllowRoot=true
AllowRemoteRoot=true
AllowRemoteAutoLogin=false
RelaxPermissions=0
CheckDirOwner=true
[xdmcp]
Enable=false
[gui]
GtkTheme=Bluecurve
[greeter]
TitleBar=false
ConfigAvailable=true
Browser=false
MinimalUID=500
Logo=
BackgroundColor=
ShowGnomeFailsafeSession=false
ShowLastSession=false
GraphicalTheme=Default
GraphicalThemeDir=/usr/share/gdm/themes/
[chooser]
HostImageDir=/usr/share/hosts/
Hosts=
Broadcast=true
Multicast=false
[debug]
Enable=false
[servers]
0=Standard
[server-Standard]
name=Standard server
command=/usr/X11R6/bin/X -audit 0
flexible=true
[server-Terminal]
name=Terminal server
command=/usr/X11R6/bin/X -audit 0 -terminate
flexible=false
handled=false
[server-Chooser]
name=Chooser server
command=/usr/X11R6/bin/X -audit 0
flexible=false
chooser=true


Merci

Sinon, comment puis je rajouter proprement un démarrage de la session gnome en root proprement ? (Pas la peine de critiquer le choix de root, il s'agit d'une machine de tests déconnectée du réseau ;))

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.