Forum Linux.redhat squid analyzer

Posté par . Licence CC by-sa.
Tags : aucun
-2
12
août
2014

Bonjour,

J'ai installé squidanalyzer pour le monitoring du serveur squid et j'ai suivi le tutoriel sur le site de http://squidanalyzer.darold.net/install.html et quand je lance http://hostname/squidreport, il y a rien qui s'affiche sur la page mais si on met IP au lieu de hostname il y l'erreur suivante :

You don't have permission to access /squidreport/ on this server.

Est-ce que quelqu'un pourrait m'aider,

Titi,
Merci

  • # Manque d'informations

    Posté par . Évalué à 3.

    Bonjour,

    Si tu veux avoir des réponses il faudrait au minimum indiquer quelle distribution tu utilises et la version d'Apache. Il serait également pertinent de copier l'extrait des logs d'Apache lorsque tu tentes d’accéder à squidreport. Tu peux aussi préciser si les prérequis sont fonctionnels (Perl et Apache dans ton cas).
    NB: le tutoriel demande de modifier httpd.conf ce qui est peu souhaitable avec Apache2 (on utilise plutôt un hôte virtuel ou un fichier de configuration)

    • [^] # Re: Manque d'informations

      Posté par . Évalué à 1.

      Je suis sur RHEL 6.3 avec Apache/2.2.15, voici la configuration de mon httpd.conf :

       Alias /squidreport /var/www/squidanalyzer
              <Directory /var/www/squidanalyzer>
                   #DirectoryIndex index.html
                   Order allow,deny
                   Allow from all
              </Directory>
      <VirtualHost *:80>
        ServerName RHEL6TEST
        DocumentRoot /var/www/squidanalyzer
      </virtualHost>

      En exécutant manuellement squidanalyzer, ci-après l'output :

      $ /usr/local/bin/squid-analyzer
      FATAL: pid file (/tmp/squid-analyzer.pid) exists, an other squid-analalyzer process may still running.

      Voici le log d'apache :

      [Tue Aug 12 11:52:50 2014] [error] [client 192.168.101.53] Directory index forbidden by Options directive: /var/www/squidanalyzer/

  • # çà marche

    Posté par . Évalué à 1.

    j'ai dejà essayé avec cette conf mais pas de chance,
    j'ai supprimé tout simplement /tmp/squid-analyzer.pid et exécuter manuellement $/usr/local/bin/squid-analyzer et ça a resoud le problème.

    Merci de votre aide,

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.