Forum Linux.slackware chargement module ndiswrapper

Posté par .
Tags : aucun
0
19
nov.
2005
Bonjour à tous!
Je suis sous Slackware, noyau 2.6.14, j'ai installé ndiswrapper et j'ai chargé les pilotes sans problèmes. Mais au chargement du module j'ai une erreur :

FATAL: Error inserting ndiswrapper (/lib/modules/2.6.14/misc/ndiswrapper.ko) : unknow symbol in module, or unknow parameter (see dmesg)


Donc je m'empresse de taper dmesg, je trouve l'erreur :


Unknown symbol wireless_send_event

Quelqu'un peut-il m'aider?
merci
  • # depmod

    Posté par . Évalué à 2.

    si tu tapes depmod -a -e, tu as quoi comme message ?
  • # Probleme de header

    Posté par . Évalué à 1.

    <clavier qwerty>

    Ton souci vient des headers utilises pour la compilation.

    Normalement, pendant la compilation, tu dois voir apparaitre ce truc en warning aussi :
    "Unknown symbol wireless_send_event"

    Il faut que tu recompile ndiswrapper en installant prealablement le paquet de header correct.
    Mr Slackware conseille d'utiliser les memes headers que ceux utilises pour compile la glibc, soit pour les paquets par defaut : celle du noyau 2.4.31. (si tu suis slackware current, c valable pour la 10.2 aussi).

    Donc :
    - enleve les autres paquets de headers que tu as pu installer precedement.
    Pour les rechercher :
    ls /var/log/packages | grep kernel-headers
    ensuite,
    removepkg nomdupaquet

    - Telecharge le paquet.
    wget ftp://ftp.slackware.at/slackware-current/slackware/d/kernel-(...)

    - installe le paquet kernel-headers-2.4.31-i386-1.tgz .
    installpkg kernel-headers-2.4.31-i386-1.tgz

    - Recompile ndiswrapper.

    - Verifie que tu n'as plus aucun warning.

    Si jamais ca marche toujours pas, essai de compiler la version cvs de ndiswrapper.

    Chez moi, la version stable (1.4) ne fonctionne pas.

    </clavier qwerty>
  • # problème d'entêtes

    Posté par . Évalué à 1.

    Je pense que tu utilises slackware 10.2

    Slackware en version 10.2 utilise deux glibc : l'une pour les noyaux 2.4 avec le support de linuxthreads et l'autre pour les noyaux 2.6 avec le support de nptl.

    Installe le noyau 2.6.13 fourni par slackware, désinstalle le paquet d'entêtes du 2.4.31 et installe les entêtes du 2.6.13 (paquet testing/packages/linux-2.6.13/kernel-headers-2.6.13-i386-1.tgz ).

    Normalement, cela devrait fonctionner.

    Personnellement, j'ai recompilé le paquet glibc uniquement avec les entêtes du 2.6.14 et le support de ntpl.
  • # commencer par chercher sur le site

    Posté par (page perso) . Évalué à 1.

    • [^] # Re: commencer par chercher sur le site

      Posté par . Évalué à 1.

      Plus exactement :

      If you get the compilation error Unknown symbol: wireless_send_event you will need to enable the CONFIG_NET_RADIO option and recompile your kernel or find a kernel with this option already enabled. Checking for the /proc/net/wireless file is not a good way of making sure you have this option enabled since it will exist if one or both of CONFIG_NET_RADIO and CONFIG_NET_PCMCIA_RADIO options are enabled.

      Ce qui en gros veut dire : verifie que option CONFIG_NET_RADIO est activé dans la configuration de ton noyau.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.