Wormux 0.7 est maintenant disponible

Posté par . Modéré par Jaimé Ragnagna.
Tags :
0
4
avr.
2006
Jeu
Après un hiver de travail, voilà enfin la version 0.7 de Wormux. Pour rappel Wormux est un jeu multi-joueur (uniquement sur le même ordinateur pour l'instant) en tour par tour ou vous devez massacrer la ou les équipes adverses. C'est avant tout un jeu fun et surtout pas violent.

Depuis la version 0.6, nous avons porté Wormux de Clanlib vers SDL gagnant ainsi en stabilité et en facilité d'installation. Le jeu fonctionne maintenant SANS pilote graphique accéléré, et dans beaucoup plus de langues grâce au support des polices de caractères TTF et de l'UTF8. Ainsi, nous avons déjà une traduction en russe.

Côté graphisme, l'amélioration est sensible avec de nouveaux personnages inspirés des mascottes du monde du Libre, de nouvelles cartes mais également de plus belles explosions (amélioré depuis la 0.7beta3).

Les autres améliorations concernent l'organisation des menus, la présence de nouvelles armes (balle rebondissante), et bien sûr des corrections de bugs. Par rapport à la 0.7beta 3, le code a beaucoup changé, surtout au niveau des armes car quelques petits bugs nous ont obligés à le remanier en profondeur pour le rendre plus lisible. À noter que la numérotation des versions est un peu étrange, car la version 0.7 n'est clairement pas la version 0.7beta 3 débugguée mais bénéficie de nouvelles fonctionnalités. Pourquoi ? parce que nous ne sommes pas assez nombreux pour maintenir deux branches (une branche de développement et une branche stable) et que plusieurs d'entre nous ne souhaitaient pas passer par une période de "features freeze" pendant laquelle le développement n'aurait pas évolué du tout.

Merci à Jean-Christophe Duberga pour le portage SDL, à Anthony Carré pour ses jolis personnages, à Olivier Boyer pour les images des menus, et bien sûr à tous les mainteneurs de paquets et traducteurs!

Aller plus loin

  • # Page de téléchargement

    Posté par . Évalué à 5.

    Le lien vers la page de téléchargement :
    http://www.wormux.org/wiki/en/download.php

    Les paquets pour les différentes distributions ne sont pas encore sur la page mais devrait arriver petit à petit!

    D'autres packageurs sont les bienvenus pour les architectures non x84 (ppc par exemple) ou pour les distributions pour lesquels nous n'en avons pas (Suse par exemple)

    PS: Le wiki est encore en cours d'édition pour la sortie de la version 0.7 ;-)
    • [^] # Paquet Mandriva

      Posté par . Évalué à 4.

      Les paquets pour Mandriva sont prêts !!

      Pour ceux qui utilisent Cooker, la version de développement, urpmi devrait suffire.

      Pour les autres, pour Mandriva 2006, le paquet est provisoirement ici :
      http://download.gna.org/wormux/wormux-0.7-0.1.20060mdk.i586.(...)

      en attendant la mise à jour de la page de téléchargement!

      Attention, le paquet Mandriva 2006 n'a pas été testé, merci donc de nous prévenir si ça marche ou non :-)
      • [^] # Re: Paquet Mandriva

        Posté par . Évalué à 0.

        arf, j'ai oublié de le tester hier soir sur ma mdv 2006 ...

        promis je le fais ce soir et je viens au rapport.. j'harcelerai le packageur si ça fonctionne pas :)
      • [^] # Re: Paquet Mandriva

        Posté par . Évalué à 2.

        Merci pour le boulot ! Mais hélas j'ai quelques soucis:
        === Wormux version 0.7
        === Authors: Lawrence AZZOUG, Laurent DEFERT SIMONNEAU, Jean-Christophe DUBERGA, Matthieu FERTRE, Renaud LOTTIAUX, Victor STINNER
        === Website: http://www.wormux.org

        Wormux version 0.7, Copyright (C) 2001-2004 Lawrence Azzoug
        Wormux comes with ABSOLUTELY NO WARRANTY.
        This is free software, and you are welcome to redistribute it
        under certain conditions.

        Read COPYING file for details.

        [ Run game ]
        ! Error in tool/resource_manager.cpp:94: ResourceManager: can't load profile /usr/share/games/wormux/weapons.xml

        C++ exception caught:
        ResourceManager: can't load profile /usr/share/games/wormux/weapons.xml
        • [^] # Re: Paquet Mandriva

          Posté par . Évalué à 1.

          Argh! Tu peux regarder la liste des fichiers que le paquet a installé ? Normalement, les données devraient être dans /usr/share/games/wormux et ils devraient donc y avoir le fameux fichier /usr/share/games/wormux/weapons.xml
          • [^] # Re: Paquet Mandriva... Ouf tout va bien !

            Posté par . Évalué à 3.

            Hôte en Pourmois* l'erreur vient bêtement de moi !
            voyant qu'un urpmf wormux listait bien:
            (...)
            wormux:/usr/share/games/wormux/weapon/teleport_ico.png
            wormux:/usr/share/games/wormux/weapon/teleportation.png
            wormux:/usr/share/games/wormux/weapons.xml
            wormux:/usr/share/icons/large/wormux.png
            wormux:/usr/share/icons/mini/wormux.png...
            et que le fichier n'existait pas j'ai voulu désinstaller le paquet et là... rpm ne considérait pas qu'il l'était (installé)...
            Je réessaie de l'installer et l'install échoue (je ne sais pas pourquoi je ne l'avais pas vu la première fois). Après un nouveau téléchargement du paquet tout va bien...

            Désolé de t'avoir alarmé pour rien ! Tout fonctionne finalement !

            *http://linuxfr.org/comments/672410.html#672410 (une référence !)
    • [^] # Paquet Ubuntu/Debian

      Posté par . Évalué à 2.

      Les paquets ubuntu (et debian ?) sont prêts et mis sur le serveur. Par contre, la mise à jour (apt-get upgrade) ne suffit pas apparement à cause de la numérotation de l'ancien paquet de la beta 3.
      • [^] # Re: Paquet Ubuntu/Debian

        Posté par (page perso) . Évalué à 3.

        Les paquets Ubuntu et Debian sont prêts effectivement. Pour l'histoire des versions, plus précisément, la version d'avant s'appelait 0.7beta3+svnXXXXX-1 (XXX =je sais plus quel jour) et la version stable s'appelle 0.7-1 (pour première release de la version 0.7)
        Pour je ne sais quelle convention de nommage, dpkg (apt ?) considère la première version plus récente que la dernière.

        La solution est donc de forcer la version. Désolé c'est pas pratique... mais les versions suivantes ne devraient plus poser de problème :-)

        La manip est donc :

        apt-get update
        apt-get install wormux=0.7-1 wormux-data=0.7-1


        Bien sûr, si vous n'avez pas installé la version précédente, vous n'avez pas ce problème.

        Jean
        • [^] # Re: Paquet Ubuntu/Debian

          Posté par . Évalué à 3.

          Bien sûr, le mieux est de ne pas faire ce genre d'erreur de numérotation. Mais bon, personne n'est infaillible, est il est donc normal de rater son coup (surtout si c'est un de ses premier paquets).

          Justement, il existe un mécanisme qui a été mis en place pour permettre de contourner le problème : dans le numéro de version, il y a au début un entier optionnel séparé par un ":". Dans la documentation Debian, il s'agit de l'"epoch". Ce numéro a donc la priorité la plus haute dans le numéro de version, et donc il sera nécessaire de le garder dans les versions ultérieures du paquet.

          Pour tous les détails concernant cela, la documentation officielle est par là (Debian Policy Manual) : http://www.debian.org/doc/debian-policy/ch-controlfields.htm(...)

          Note : je ne suis pas DD (Debian Developer). Il est donc possible que mon explication soit fausse ou inexacte. Dans tous les cas, la lecture du document sus-cité dans son ensemble est intéressante pour tout utilisateur de Debian qui souhaiterait en savoir un peu plus sur ce qui se passe sous le capot.
  • # Et le lézard ?

    Posté par . Évalué à 1.

    Quelqu'un motivé pour créer les packages Suse ?
  • # hm

    Posté par . Évalué à 0.

    quelques petits bugs nous ont obligés.

    Pour une fois que je peux aider en orthographe.
    • [^] # Re: hm

      Posté par (page perso) . Évalué à 7.

      J'ai comme un doute, le COD (nous) étant placé devant, je crois que cette phrase était bonne. Le primaire est loin...

      Sinon, je ne vous remercie pas pour le jeu, encore un complot contre ma productivité, à cause de vous, je vais travailler moins, faire couler ma boite, me retrouver au chomage et finir alcoolique ou pire, me mettre à Mono.
      • [^] # Re: hm

        Posté par . Évalué à 3.

        je vais ... me mettre à Mono.


        Comment ça te mettre à Mono?!?
        Wormux est codé en C++, tu sais ce qu'il te reste à faire pour nous aider ;-)
  • # Fenêtre transparente...

    Posté par . Évalué à 0.

    Cela et sûrement dû au couple Compiz/XGl mais lorsque je lance Wormux, la fenêtre, enfin le jeu est transparent il me faut donc pour remédier à ça mettre un fond noir sur mon bureau (et déplacer les icônes aussi :-)
  • # Problème de consommation mémoire.

    Posté par . Évalué à 1.

    Bonjour,
    Mon fiston de 6 ans trouve Wormux génial.
    Par contre au bout d'une heure la machine ralenti et va jusqu'à se figer.
    Wormux se mets à utiliser toute la RAM et le SWAP (512Mo + 1Go).
    Ca m'a tout l'air d'une grosse fuite mémoire (de Wormux ou d'une librairie).
    Ma conf: Ubuntu Dapper + GeForce4.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.