Journal Test Gentoo

Posté par (page perso) .
Tags : aucun
0
30
sept.
2003
Bon bah pour resumer le truc ca fait 4 ans que j'utilise quasi exclusivement
la meme Debian chez moi (avec un peu de Hurd de temps a autre) et je me
suis dit voyons ce que proposent les autres.

Bon Mandrake je l'ai deja installer pour deux potes c pas la peine j'essayerai meme pas.
Redhat bein j'avais ca avant, bof bof aime pas trop (un peu comme Mandrake quoi :))

Alors je me suis dit pourquoi pas essayer une gentoo...

Apres m'etre casse la tete parce que je n'avais pas recuperer le bon LiveCD (et apres m'etre rendu compte que j'aurais pu tout betement bootstrapper la gentoo depuis ma debian tout bien configurée :() nous y voila.
Bon l'install ... c pas vraiment ce que j'appelerai une install mais c rigolo, c vachement proche de la LFS d'ailleurs.
D'ailleurs deux petites remarques a faire a emerge:
1 quand la ligne est lente une parallelisation de la compilation et du download serait appréciable, et
2 dans le pire des cas une gestion de verouillage sur certaines opérations (comme le DL) serait interessante pour pouvoir justement paralléliser les choses. Genre pour eviter que le emerge system et le emerge -f system downloadent le meme fichier au meme endroit et en meme temps ce qui ne fonctionne pas tres bien.
(oui oui je sais fait un patch, mais IIRC Daniel Robbins a un historique desagreable)

Bon c bien tout ca mais faut quelques applis. J'ai voulu profiter de cette install pour
1 tester le framebuffer avec ma Radeon 8500
2 tester le nouveau driver ATI pour XFree

et la les pb on commencés (si quelqu'un a une solution...)
Avec le framebuffer: selection du mode au boot avec video=radeon:1024x768-(32|16)@85 pas de probleme (en 24 par contre ca marche pas terrible).
utilisation de fbv: gros soucis de palette sur les images que je lui ai fournies mais il essaye d'afficher quelque chose
installation/utilisation dfbsee: impossible il tente une commutation de mode (apparement) et l'ecran passe en veille, Q ou echap permettent de revenir.
je me dit que c un probleme de /etc/fb.modes, alors je le vide et je met debans la sortie de fbset sans la ligne rgba
ca ne change rien.
et la je tente le fbset "1024x768-85" (donc normalement le meme mode que precedement, ave les memes timing que dans modedb.c) et pareil l'ecran devient noir.
Faudrait que je test un des modes du fb.modes fournit avec DirectFB, pas eu le temps.

Avec le driver ati fglrx:
Demarrage X ok,
tests fgl_glxgears ok: 70 images/s (doit etre normal vu que j'ai active le vsync)
tests quake3/wold3d: completement foireux, l'image est decoupée en petits blocs de 50x10 pixels (a peu pres) qui sont décalés a chaque ligne (oui je sait
c pas clair mais bon c pas simple a decrire non plus) en texte ca donnerai un truc dans le genre:
(avec A les bloc qui ne devrait pas faire parti du jeu (ie des bouts de xterm, ...)
et N les bloc normaux) ca ne rend pas bien mais c a peu pres ca:
NNNNNNNNNNAA
ANNNNNNNNNNA
AANNNNNNNNNN
.... (sur la moitie de l'ecran le reste etant pri par des bloc 'A' disposés n'importe comment).


Je precise que avec le driver radeon et en mode software rendering le jeu est normal, injouable mais les menus sont normaux ainsi que l'intro. Par contre le jeu en lui meme est tres mal rendu mais ca doit etre normal.

Des idées ?
ps: si quelqu'un a aussi une solution pour eviter en mode console/framebuffer
que le changement de console virtuelle avec Alt-Fx declanche une commutation inutile de mode graphique (vu que de toute façons toutes les consoles sont dans le meme mode ..) ca m'interesse aussi
  • # apt-fu

    Posté par . Évalué à 1.

    ca me fait penser que une nouvelle version de apt-fu vient de sortir
    en gros c'est un apt-build encore + paramétrable et qui offre de nombreuses features (conservation des paramètres et des modifications du source perso lors d'une upgrade du paquet source)

    faut peut-être faire une news ...
    http://www.yhbt.net/normalperson/debian/html/(...)
  • # Re: Test Gentoo

    Posté par (page perso) . Évalué à 1.

    Pour les drivers, tu les as installés comment ?
    Normalement t'es sensé faire emerge ati-drivers suivi de opengl-update ati

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.