Journal sarge décision

Posté par .
Tags : aucun
0
21
mar.
2003
C'est le branle bas de combat sur Debian Sarge en ce moment. Les grands gourous recompilent tout comme des sauvages parce que la glibc est mise à jour. On dirait Mandrake.

Bilan : ca fait une semaine que php4 est en rideau à cause d'un infame dependency broken. Nom d'une nouille!

C'est ma faute à vrai dire, j'ai été distrait. A un moment il faut tapoter "Y" et *SURTOUT PAS* "N". Ou bien c'est le contraire, je sais plus.

Mais voila, I am the mailleur : j'ai fini par trouver la parade. Il convient d'aller éditer soi même ses dépendances dans /var/lib/dpkg/truc et ca remarche comme sur des roulettes.

Vos dépendances s'arrètent devant mon talent. Si vous êtes un décideur, téléphonez moi. Je vous expliquerai. :)
  • # Re: sarge décision

    Posté par (page perso) . Évalué à 2.

    Slackware c'est plus mieux et plus sa(r)ge : y'a pô d'dépendances ^^
    • [^] # Re: sarge décision

      Posté par . Évalué à 6.

      Avec rpm et surement deb, tu peux aussi tourner en mode Slackware. Tu ajoutes le mode dégradé (--nodeps sous rpm) fully Slack compatible et ça roule. Remarque que redhat propose une mise à jour de glibc 2.2 vers 2.3 qui ne pose aucun problème. Debian a peut-être fait une erreur. Ça arrive à tout le monde. Sinon si tu n'aimes pas les systèmes de contrôle qui t'évitent de faire des conneries, bosses sous root ou installe une Lindows.
  • # Re: sarge décision

    Posté par . Évalué à 2.

    Figure-toi qu'avec la Gentoo, tu peux utiliser des mises à jour sans devoir attendre le 22è siècle ! Et en une seule ligne de commande...N'est-ce pas fabuleux ? Certains ignorent-ils encore cette distribution geekesque ?
    • [^] # Re: sarge décision

      Posté par . Évalué à 1.

      Sans attendre le 22è siècle? Si, le temps de compiler tout ça sur ma vieille machine, faudra bien ça : p
  • # Re: sarge décision

    Posté par . Évalué à 3.

    tu as aussi le paquet equivs qui te permet d'installer des dépendances fictives sinon tu peux aussi installer des paquets de unstable ou utiliser apt-build http://free2.org/d/

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.