Journal Kde 3.5.2

Posté par (page perso) .
Tags : aucun
0
22
mar.
2006
L'annonce officielle est en préparation, mais les paquets pour kubuntu sont déjà là pour dapper [1] et devraient bientôt arriver pour breezy [2].

La note des changements [3] (nouvelle tentative de traduction de changelog) fait état des principales nouveautés.
L'amélioration que j'apprécie le plus est :
KHTML : Implement selectionStart, selectionEnd, setSelectionRange on textarea and text input tags. They are used by editting buttons in phpBB, various wikis, and by autocompletion packages like Google suggest. Also fix some bugs in synchronization between rendering tree and the DOM for textareas.

Comprendre que en particulier quand on sélectionne du texte dans un formulaire sur un forum de discussion, et que l'on clique sur un bouton de mise en forme, genre mettre en gras, les balises vont effectivement se mettre autour de la sélection, et non pas à la fin du champ de saisie. L'absence de cette fonctionnalité faisait effectivement tâche face à firefox qui le faisait depuis belle lurette (même avant qu'il porte ce nom).

Sinon apparemment pas mal de boulot sur umbrello et quanta.
Et bien sûr, les habituelles améliorations ...

[1] http://kde.org/announcements/changelogs/changelog3_5_1to3_5_(...)
[2] deb http://www.kubuntu.org/packages/kde352 dapper main
[3] deb http://www.kubuntu.org/packages/kde352 breezy main
  • # Enfin!!!

    Posté par . Évalué à 4.

    KHTML : Implement selectionStart, selectionEnd, setSelectionRange on textarea and text input tags.

    une des raisons qui a exclu konqueror d'une utilisation quotidienne chez moi.
    Reste plus qu'a attendre qu'apple l'integre dans webcore maintenant. Ca risque de prendre du temps. :-(
  • # xmms is back :(

    Posté par . Évalué à 2.

    kicker-applets ne dépandait plus de xmms et voici que les nouveaux paquets Ubuntu reprennent cette dépendance :'(
    • [^] # Re: xmms is back :(

      Posté par (page perso) . Évalué à 1.

      De quoi parles tu ?
      Je n'ai pas du tout ce problème ... point de xmms dans les deps !
      Ce doit être autre chose
      • [^] # Re: xmms is back :(

        Posté par (page perso) . Évalué à 2.

        Bah c'est chez toi que y'a un probleme alors :p

        kicker-applets 3.5.2 dépend de xmms.
        • [^] # Re: xmms is back :(

          Posté par (page perso) . Évalué à 2.

          Effectivement, après un nouvel apt-get update j'ai la même chose.
          Soit les listes de packages étaient en cours de MAJ, soit la vérité est ailleurs ...

          Toujours est-il que c'est dommage cette dépendance ...
          • [^] # Re: xmms is back :(

            Posté par (page perso) . Évalué à 2.

            C'est l'applet multimedia qui dépend de xmms ...

            gnumdk@flanders:~$ ldd /usr/lib/kde3/mediacontrol_panelapplet.so |grep xmms
            libxmms.so.1 => /usr/lib/libxmms.so.1 (0xb7ec2000)
    • [^] # Re: xmms is back :( ...

      Posté par (page perso) . Évalué à 3.

      ... sur ubuntu uniquement
  • # Good

    Posté par . Évalué à 2.

    À propos de KHTML, C'est un pas vers l'adoption de l'éditeur en ligne que l'on peut trouver sur IE ou Firefox et qui est de plus en plus utilisé. C'est pas un truc très standard mais c'est utilisé notamment dans des gros CMS comme joomla :

    http://dosimple.ch/articles/Rte-Light/
  • # Beaucoup d'autres choses interessantes...

    Posté par . Évalué à 3.

    Parmis celles-ci, quelques unes qui m'ont interpellées :

    KHTML
    Get iframes, objects and some other overlaid widgets to obey their stacking context at last (a.k.a, keep flash and iframes *under* dhtml menus).
    Beaucoup de sites pourrons enfin "marcher".

    Properly reload iframe when source re-set.
    Idem pour certains sites ajaxisés par exemple.

    Klipper
    XFixes support (especially helps with broken clipboard implementations of some non-KDE applications)
    Klipper deviens enfin utilisable pour quelqu'un se servant d'openoffice ...
  • # Bonne nouvelle pour les utilisateurs de Gentoo

    Posté par (page perso) . Évalué à 6.

    A priori cette version 3.5.2 était attendue pour passer KDE 3.5 dans la branche "stable" (il restait trop de bugs dans Akregator, KMail, Kicker et KPDF avec les patchs pour remplacer xpdf par poppler).

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.