Journal Fin d'un troll?

Posté par (page perso) .
Tags : aucun
0
7
nov.
2006
Serai-ce la fin du troll Flashcapucpalibre?

Adobe et Mozilla main dans la main dans un projet opens source, appelé Tamarin, qui vise à ouvrir le code d'ActionScript.
Bien sur le code de Flash Player reste fermé donc on peux toujours dire Flashcapucpalibre mais cela risque de faciliter le travail du projet Gnash.

Bientôt un Flash sur toutes sort d'architectures !!!!

Quelques liens pour la lecture :
http://www.adobe.com/aboutadobe/pressroom/pressreleases/2006(...)

http://blogs.adobe.com/penguin.swf/

http://www.mozilla.org/projects/tamarin/
  • # Actionscript ou Ecmascript?

    Posté par . Évalué à 3.

    Je cite:
    The goal of the "Tamarin" project is to implement a high-performance, open source implementation of the ECMAScript 4th edition (ES4) language specification.

    Je ne crois pas qu'on puisse dire que ce projet vise à ouvrir le code d'ActionScript, il s'agirait plutôt d'aider Mozilla à implémenter EcmaScript 4 pour en améliorer la diffusion et l'adoption.

    Pour le Flash sur d'autres architectures, vivement que les poules aient des dents!
    • [^] # Re: Actionscript ou Ecmascript?

      Posté par (page perso) . Évalué à 3.

      Pourtant dans le communiqué d'Abode on vois :
      today announced that Adobe has contributed source code for the ActionScript™ Virtual Machine, the powerful standards-based scripting language engine in Adobe® Flash® Player, to the Mozilla Foundation

      Donc pour moi c'est bien le code d'ActionScript.

      Et sur le site de mozilla on vois dans la RoadMap :
      3 Porting the just-in-time compiler to new hardware platforms

      Donc l'ère des poules avec des dents se rapproche dangereusement ;)

      S'il y a un problème, il y a une solution; s'il n'y a pas de solution, c'est qu'il n'y a pas de problème.

    • [^] # Re: Actionscript ou Ecmascript?

      Posté par (page perso) . Évalué à 9.

      ActionScript est basé sur le standard Ecmascript.

      La machine virtuelle utilisée pour exécuter de l'ActionScript 3 dans Flash 9 est libéré, sous les trois licences MPL, GPL, LGPL, et est d'hors et déjà disponible dans le trunk de Mozilla

      http://lxr.mozilla.org/mozilla/source/js/tamarin/

      Voir

      http://xulfr.org/news/2006/11/07/187-projet-tamarin-adobe-co(...)

      en attendant que la news que j'ai proposée soit libérée elle aussi sur dlfp ;-)


      Par contre, cela ne veut pas dire que flash est libéré. ActionScript n'est qu'une brique dans Flash. (Tout comme JS l'est dans une page web).
      • [^] # Re: Actionscript ou Ecmascript?

        Posté par . Évalué à 4.

        Je ne connais pas flash, ou très peu, mais je me demande s'il ne serais pas possible d'utiliser un script ActionScript tiré d'une animation flash sur du SVG ?

        On pourrais voir apparaître des convertisseurs flash => svg ? Au lieu de faire un player flash libre, ça pourrais être pas mal un plugin qui convertis automatiquement les animations flash en SVG :)
  • # Il faut être très vigilant

    Posté par (page perso) . Évalué à -8.

    Il faut être vigilant chaque fois qu'on s'éloigne d'une technologie libre, surtout quand la technologie risque de se "répendre".

    Comme RMS, je pronne l'intransigeance pour les technologies propriétaires. Il ne faut pas les utiliser en pensant que ça vas les aider. Au contraire, il faut les boycoter comme Qt au départ.

    Je n'utilise pas gnome mais le projet à atteind un objectifs stratégique très tot : faire libérer Qt.
    • [^] # Re: Il faut être très vigilant

      Posté par (page perso) . Évalué à 4.

      >Il faut être vigilant chaque fois qu'on s'éloigne d'une technologie libre, surtout quand la technologie risque de se "répendre".


      Trop tard !! (pffff le fud...)

      Je répète : ActionScript = Ecmascript

      Ecmascript = version standardisée de Javascript (Par l'organisme ECMA, Ecmascript étant conçu au départ par Brendan Eich, monsieur chef technologies chez Mozilla, et le groupe de travail actuel de Ecmascript est composé entre autre de Adobe et Mozilla)

      Javascript = utilisé par tous les navigateurs...

      CQFD..

      Rappel : IL NE S'AGIT PAS DE FLASH ICI
    • [^] # Re: Il faut être très vigilant

      Posté par . Évalué à 6.

      Gni ??? Tu veux être vigilent sur quoi là ? Adobe libère sous MPL/GPL/LGPL la "machine virtuelle à ActionScript" qui, quoi qu'elle fasse exactement, pourra être repris dans Gnash. Et Gnash est libre.

      Gnash sera plus proche de ce qu'offre le lecteur Flash officiel, youpi tu devrais être content.
    • [^] # Re: Il faut être très vigilant

      Posté par . Évalué à 10.

      Alors sois vigilant, et contribue à répandre la version standardisée et libre de la langue française, prône le parlé correct, car ça va_ l'aider grandement, et toi aussi boycotte les fautes de français, pour pouvoir dire « J'ai atteint un objectif_ stratégique très tôt : améliorer le dialogue entre les hommes. »


      Yth, pour le respect des standards ouverts...
      • [^] # Re: Il faut être très vigilant

        Posté par (page perso) . Évalué à 8.

        Le Français n'est qu'un standard de fait, vaguement documenté et qui, selon les zones géographiques, n'est pas toujours compatible. Quand on est pour le libre, on est pour le libre. J'ai fait un fork.
        • [^] # Re: Il faut être très vigilant

          Posté par (page perso) . Évalué à 10.

          C'est pas en refusant les patches de contributeurs que ton fork va bien fonctionner.
        • [^] # Re: Il faut être très vigilant

          Posté par . Évalué à 7.

          T'en parleras à l'académie française du « vaguement documenté ».
          Au passage tu pourrais même t'offrir un bescherelle de conjugaison et un de grammaire, avec un dictionnaire en prime, tu verras si c'est pas documenté, et même standardisé...

          Alors oui, les évolutions futures sont testées tout les jours par un peu tout le monde sous forme d'expressions, de néologismes, voire de barbarisme, ou de mots étrangers, et même de fautes communes, et c'est peu documenté, il faut connaitre, ou comprendre, et toutes ces « propositions d'évolution » ne seront pas intégrées.

          Mais tu n'étais pas dans ce cas là, tu étais en plein de le noyau dur, dans la partie sûre, claire et extrêmement bien documentée justement...


          Yth......
      • [^] # Re: Il faut être très vigilant

        Posté par . Évalué à 3.

        prône le parléer correct,


        :)
    • [^] # Re: Il faut être très vigilant

      Posté par (page perso) . Évalué à 2.


      Comme XXXXXX, je pronne l'intransigeance pour les YYYYY. Il ne faut pas les utiliser en pensant que ça vas les aider. Au contraire, il faut les boycoter comme ZZZZ qui est un YYYYYY au départ.


      heu ... alors :
      XXXX = bill gates
      YYYY = logiciels libre
      ZZZZ = Linux

      oué ...
      XXXX = GW Bush
      YYYY = anti americain
      ZZZZ = la france

      oué ... ca fait toujours aussi certificat d'absence de reflexion propre ... tout ca en evitant le GodWin :p

      donc, tu sais, ce n'est pas parce qu'est sorti de la bouche de RMS quelques bonnes idées, que tout ce qui sort de sa bouche est une bonne idée.

      Sinon, je peux te vendre un pot en verre contenant un rot de RMS pour pas cher :p

      Plus serieusement, la vie est bellen faut pas la noircir comme ca avec plein d'integrisme et de sectarisme plus liberticide qu'autre chose.

      ... tiens, fais une partie de pendu ou de boggle des bsdgames, ca te fera du bien, ca doit etre largement plus divertissant qu'une partie de Dofus qui est proprio et qui tourne sous linux avec du flash-qui-pue.
      • [^] # Re: Il faut être très vigilant

        Posté par (page perso) . Évalué à -2.

        Personnellement, je trouve que tout ce que dit RMS est bien plus intelligent que ce que dit billou, qui d'ailleurs ne dit plus rien depuis pas mal de temps. Par ailleurs, je voudrais rebondir sur la GPL v3. Si tout le monde n'était pas remonté après RMS, ça ne ferait pas autant de foin.

        En plus, RMS, avec ses cheveux et sa barbe, il est trop choux alors que billou ressemble à un épouventail empaillé.
      • [^] # Re: Il faut être très vigilant

        Posté par (page perso) . Évalué à 9.

        Sauf que FLASHCAPUECATOURNEPASSOUSLINUXBORDEL (a la limite sa tourne sous linux-x86, mais pas linux-ppc ni linux-amd64...)

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.