Journal kernel 2.6.* et clavier

Posté par (page perso) .
Tags : aucun
0
26
fév.
2004
Ca fait plusieurs fois que je me dis que je vais passer au noyau 2.6.
Avec tout le bien qu'on en entend, il doit quand même être sympa...

Mais à chaque fois que j'ai essayé, je suis tombé sur un problème assez génant : je n'ai pas de clavier.

Les autres fois, par manque de temps je n'ai pas cherché plus loin et je suis retourné sous mon noyau courant qui ne pose aucun problème.

Cette fois, je m'interroge un peu plus, surtout qu'apparemment il n'y que ça qui ne marche pas (en boottant sur le nouveau noyau, j'arrive à l'écran de login de gdm et la souris marche, mais pas le clavier).
Je me suis tout d'abord dit "quel con, j'ai oublié le support du clavier dans Input Core Support". Mais je ne vois nul par cette option dans le 2.6.
Apparemment, tout ce qui touche aux périphériques de saisies est maintenant regroupé dans "Devices Drivers -> Input device support". Mais ici, je n'ai rien qui ressemble à "Input Core Support". Et l'options relative au support du clavier (Input Device Drivers -> Keyboards) n'est pas modifiable.

Pour info, je suis sous debian/testing, mon clavier fait parti d'un pack souris/clavier logitech sans fil (cordless pro quelquechose je crois).
Je l'utilise en PS/2, mais il peut fonctionner en USB aussi, ce que j'ai tenté. Mais alors, sans modifier la connexion de la souris (donc toujours en PS/2), celle-ci ne marche pas. Et je n'ai toujours pas de clavier (en ayant pris soin d'activer le support full HID dans USB).

Cher journal, je t'en supplie, apporte moi tes lumières que je puisse jouer avec le joli noyau 2.6...
  • # Re: kernel 2.6.* et clavier

    Posté par (page perso) . Évalué à 0.

    modprobe usbkbd ?
    • [^] # Re: kernel 2.6.* et clavier

      Posté par . Évalué à 8.

      euh il fait comment pour le taper ?
      • [^] # Re: kernel 2.6.* et clavier

        Posté par (page perso) . Évalué à 1.

        Avec la souris, en copiant/collant caractères par caractères !
        Plus sérieusement, il boote sur son vieux noyau et rajoute usbkbd à sa liste de modules chargés au boot.
        Mais je ne pense pas que ça change grand chose vu qu'il ne marche pas en PS/2 non plus...
    • [^] # Re: kernel 2.6.* et clavier

      Posté par (page perso) . Évalué à 1.

      En fait, j'aimerais bien savoir pourquoi mon clavier marche parfaitement en PS/2 sur un 2.4.24 et pas sur un 2.6.*.
  • # Re: kernel 2.6.* et clavier

    Posté par (page perso) . Évalué à 1.

    Qu'est ce que ça veut dire quand une option est précédée de "---" au lieu des traditionnels crochets dans menuconfig ?
    Qu'elle n'est pas accessible à cause d'un autre choix non-selectionné ou bien qu'elle est toujours activée ?
    Parce qu'en fait j'ai ça devant "Input devices support -> keybords", alors si ça veut dire que je ne peux pas le choisir, le problème vient clairement de là. Mais dans ce cas, je voudrais savoir qu'elle est l'option à activer pour que "Keybords" soit disponible...
    • [^] # Re: kernel 2.6.* et clavier

      Posté par (page perso) . Évalué à 1.

      Sauf erreur de ma part, ce ne sont pas des options mais des divisions comme un titre quoi.
      • [^] # Re: kernel 2.6.* et clavier

        Posté par (page perso) . Évalué à 1.

        Oui, il me semble. Enfin, c'est ce que j'ai toujours crû, mais dans le doute, je me suis dit que ça serait bête si c'était juste ça...

        Et pourquoi ma souris marche et pas le clavier ??? On peut rien faire avec juste une souris, ça serait mieux l'inverse...
  • # Re: kernel 2.6.* et clavier

    Posté par (page perso) . Évalué à 1.

    C'est uniquement sous X que tu n'as pas le clavier ou en console aussi ?
    (boot en runlevel pour voir)

    Et que dit dmesg ?

    Pour ma part, en bootant sur le 2.6 je n'avais plus de clavier (qui est PS/2) sous X. J'ai pas trop compris pourquoi. Peut-être parce que je n'avais pas mis le module HID pour ma souris USB...

    Sinon dans le noyau j'ai uniquement :
    CONFIG_INPUT_KEYBOARD=y
    CONFIG_KEYBOARD_ATKBD=y
    • [^] # Re: kernel 2.6.* et clavier

      Posté par (page perso) . Évalué à 1.

      heu... c'est bête mais je n'arrive pas à booter en runlevel 2... Normalement il ne suffit pas de passer "2" comme argument au boot de lilo ?

      Sinon, j'ai réussi à avoir le clavier sous le 2.6.3, amis d'une manière étrange : lors du boot, j'ai appuyé sur pleins de touches, et au final j'avais le clavier...
      Voici ce que m'a dit dmesg alors :

      [blablabla...]

      Console: switching to colour frame buffer device 128x48
      drivers/usb/core/usb.c: registered new driver hiddev
      drivers/usb/core/usb.c: registered new driver hid
      drivers/usb/input/hid-core.c: v2.0:USB HID core driver
      mice: PS/2 mouse device common for all mice
      serio: i8042 AUX port at 0x60,0x64 irq 12
      input: ImExPS/2 Logitech Explorer Mouse on isa0060/serio1
      serio: i8042 KBD port at 0x60,0x64 irq 1
      atkbd.c: Unknown key released (translated set 0, code 0x2e on isa0060/serio0).
      [...pleins de fois ça..]
      atkbd.c: Use 'setkeycodes 2e ' to make it known.
      atkbd.c: Unknown key pressed (translated set 0, code 0x2e on isa0060/serio0).
      atkbd.c: Use 'setkeycodes 2e ' to make it known.
      input: AT Translated Set 2 keyboard on isa0060/serio0
      [...blabla d'autres truc...]

      atkbd.c: Unknown key released (translated set 2, code 0x7a on isa0060/serio0).
      atkbd.c: This is an XFree86 bug. It shouldn't access hardware directly.
      atkbd.c: Unknown key released (translated set 2, code 0x7a on isa0060/serio0).
      atkbd.c: This is an XFree86 bug. It shouldn't access hardware directly.

      Donc apparemment, c'est bien un problème avec X. D'autant plus que ma souris ne marchait pas terrible (je n'avais que 2 boutons sur les 6...)

      Comment tu as fait pour résoudre ton problème ??
      • [^] # Re: kernel 2.6.* et clavier

        Posté par . Évalué à 1.

        J'ai eu un problème identique avec ma Debian Sid et XFree 4.3. Le démarrage en mode texte ne posait pas de problème mais lors du passage sous X le clavier ne répondait plus.
        Si ma mémoire est bonne les problème venait de la config des périphériques d'entrée, en particulier de la souris.

        Donc bug de X ou effets de bord mistérieux, je te laisse chercher :P

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.