Journal Disgnostic de crash sous Linux?

Posté par  (site Web personnel) .
Étiquettes : aucune
0
22
nov.
2003
J'ai un assez gros problème avec ma nouvelle machine que j'ai acheté recemment: elle a tendance à planter. Plantages totalement aléatoires, sans prévenir, après 1h ou une journée entière de fonctionnement, pas un seul message laissé dans les logs systèmes qui permettrait de savoir d'où vient le problème.

Je suis loin d'être un pro de ce genre de problèmes, donc je cherche des outils de diagnostic sous Linux: test de la mémoire, etc. Ou toute autre info qui pourrait me permettre de découvrir ce qui ne va pas.

Voici ma config, au cas où certains en auraient une similaire:

- Shuttle sn41g2 (chipset nforce2, vidéo geforce4)
- Athlon XP Barton 2500+
- 512 Mo Corsair PC 3200 CMX Cas 2
- DD Seagate 80Go
- Mandrake 9.2

J'ai essayé de supprimer les drivers proprios nvidia et divers périphériques, ça continue à planter. Apparamment, quand je passe en failsafe et que je monte le FSB à 133 (1900+), tout est stable. Mais il suffit que je remonte un peu les perfs pour que les plantages recommencent. Je doute qu'il y ait un problème de température - après plusieurs heures de chauffage de CPU, je dépasse rarement les 40°C.

Quelqu'un aurait-il un conseil à me donner, sur une suite de diagnostic, un test de stabilité d'une machine, ou un problème connu avec cette config? Ou un témoignage d'un autre utilisateur de shuttle?

Merci d'avance!
  • # Re: Disgnostic de crash sous Linux?

    Posté par  . Évalué à 5.

    Tu peux deja tester la memoire en utilisant memtest86 :
    http://www.memtest86.com/(...)
    • [^] # Re: Disgnostic de crash sous Linux?

      Posté par  . Évalué à 4.

      Ouais ça ressemble pas mal à un problème de mémoire. Elle est certifiée pour fonctionner avec ton proc à la fréquence max la tienne? Si ça fonctionne à 1900+ et que ça chie à 2500+, je parierais qu'il te faudras une mémoire de meilleure qualité. J'ai eu le même problème avec un Athlon.
      • [^] # Re: Disgnostic de crash sous Linux?

        Posté par  (site Web personnel) . Évalué à 1.

        Ben, étant de la PC3200, la mémoire est sensée supporter jusqu'à 200Mhz... Or que ce soit en 1900+ ou en 2500+ elle tourne à 133 - je ne pense donc pas que le problème vienne de là, mais c'est memtest86 qui le dira...
      • [^] # Re: Disgnostic de crash sous Linux?

        Posté par  (site Web personnel) . Évalué à 1.

        Memtest ne détecte aucune erreur, apparamment ce n'est pas un problème de mémoire (ou alors il est bien caché).

        Je me suis assuré que la fréquence mémoire est bien synchro avec le FSB processeur - je laisse tourner, on va voir ce que ça donne... :P
  • # Chaud ? C'est peut-être ça quand même !

    Posté par  . Évalué à 5.

    Bien que tu penses que cela ne vienne pas de la température, je te suggère d'essayer nvclock, un outil qui permet d'«over/downclocker» les GeForce.
    Xfree est très sensible aux surchauffes des GeForce (d'où vient cette extraordinaire sensibilité: mystère !). Pour ma part, j'ai une GeForce 2 Et mon système a le même type d'instabilités tant que ma Geforce (Normalement la mémoire est «clockée» à 350 Mhz, c'est une GeForce 2 Pro) n'est pas à moins de 260 Mhz (avant de démanger, c'était 300, mais ici il fait plus chaud !!!).
    Essaie nvclock ! (urpmi nvclock... sur une 9.1 il est dans les sources contrib' si je me souviens bien).
    • [^] # Re: Chaud ? C'est peut-être ça quand même !

      Posté par  (site Web personnel) . Évalué à 2.

      Un petit coucou à Gnurou, que je vais retrouver au boulot lundi.

      Si tu te souviens j'ai les mêmes problèmes avec l'APM et l'ACPI avec le portable. Tu peux déjà les désactiver au niveau du bios "pour voir".

      Ensuite y'a pas de secrets: downgrader toutes les options du bios et éviter de démarrer des trucs sensibles au niveau du kernel. Puis réactiver un par un ces gentils monsieurs pour voir qui est le traître.

      Oui, je sais, ça risque d'être long, mais si tu as mieux...
      • [^] # Re: Chaud ? C'est peut-être ça quand même !

        Posté par  (site Web personnel) . Évalué à 3.

        L'ACPI me fait déjà iech par le fait qu'il s'active y compris quand je suis sur le PC... Ca n'a pas l'air d'être très bien géré par le 2.4. Et impossible de le désactiver dans le BIOS, au mieux on a juste quelques options.

        Un p'tit kernel 2.6? Mmmm ça pourrait peut-être le faire? Je m'y résoudrais si je ne trouve pas mieux... :)
  • # Re: Disgnostic de crash sous Linux?

    Posté par  (site Web personnel) . Évalué à 4.

    Salut
    j'avais un problème avec un barbone, lui il plantait chaque fois que
    j'allais sur internet (sous linux) via un modem ou le réseau.
    Sous win pas de problème,
    la solution ? Mise a jour du bios et c'est repartis sans plus jamais planté.
  • # Re: Disgnostic de crash sous Linux?

    Posté par  . Évalué à 3.

    Salut
    J'a un pote qui a eu le même problème et enfait ca venai d'une sous tension alors vérifie aussi ton alim (même si elle est neuve), et regarde dans tes option BIOS.
    • [^] # Re: Disgnostic de crash sous Linux?

      Posté par  (site Web personnel) . Évalué à 1.

      Question bête, mais comment vérifier une alim? Un voltmètre?

      Le BIOS de ma machine ne permet pas de changer le voltage, malheureusement. J'imagine que de ce côté là ça doit être ok.
      • [^] # Re: Disgnostic de crash sous Linux?

        Posté par  . Évalué à 1.

        Bah je dirais en évaluant la puissance que tu utilises. Si t'as beaucoup de périphériques (lecteurs CD, DVD, disques durs...) en plus du AMD qui chauffe, p'tet que ton alim et trop faible. Soit tu cherches ce que consomment tes périphs (ça risque d'être lourd, à moins d'avoir toutes tes docs), soit tu débranches quelques trucs (lecteurs et disques) et tu vois si ça arrête de planter.
        Ça pourrait expliquer pourquoi quand tu montes les perfs ça foire, le proc doit consommer plus (?) si la fréquence augmente.
  • # Re: Disgnostic de crash sous Linux?

    Posté par  . Évalué à 2.

    Moi aussi ma machine plantait sans prévenir de temps en temps avec la Mdk 9.2, depuis la mise à jour de noyau 2.4.22-10 vers le 2.4.22-21 ça ne le fait plus.
    • [^] # Re: Disgnostic de crash sous Linux?

      Posté par  (site Web personnel) . Évalué à 2.

      J'avais essayé de passer à un 2.4.22-24 de cooker, sans succès hélas - mais je crois que je vais faire la MAJ quand même...
      • [^] # Re: Disgnostic de crash sous Linux?

        Posté par  . Évalué à 1.

        Pour info, il ne faut pas mettre à jour vers le 2.4.22-21 à partir de l'outil de mise à jour de mandrake sans quoi tu auras le droit à un beau "kernel panic" au démarrage, il faut installer le RPM et là ça marche.
        • [^] # Re: Disgnostic de crash sous Linux?

          Posté par  . Évalué à 1.

          Mais peut -on le faire avec l'outil installeur de RPM dans la KDE
          3.1.4 je parle de changer le rpm du Kernel 2.4.22-24 ??
          • [^] # Re: Disgnostic de crash sous Linux?

            Posté par  . Évalué à 1.

            Oui, bien sûr, installes le comme tu as l'habitude de le faire, ce qu'il ne faut pas faire c'est de le télécharger et de l'installer à partire de l'outil de maj mandrake.
        • [^] # Re: Disgnostic de crash sous Linux?

          Posté par  . Évalué à 1.

          Je l'ai installé via urpmi et je n'ai pas eu de problème. MandrakeUpdate ne met pas à jour mais installe les noyaux (il le dit dans la console) comme nouveaux paquets. Donc je ne vois pas ou est le problème.
  • # Re: Disgnostic de crash sous Linux?

    Posté par  . Évalué à 3.

    Alors les prossesseurs de ce type chauffent " la mort qui tue"
    tu vas dans le bios et tu actives uniquement les tempêratures
    et tu mets une alarme (ils le permettent tous maintenant )
    tu devrais être surpris. Si tel n'est pas le cas et que tu n'as pas
    de surchauffe, places le détecteur de processus fou à 95% et
    s'il sort un processus en cours, c'est que ce logiciel est p-e la
    cause sinon c'est carement hardware et là aie ! carte graphique
    mal enfichée très sensible en AGP x 4 ou 8 sortir et replacer
    PC ETEINT bonne chance
  • # Re: Disgnostic de crash sous Linux?

    Posté par  . Évalué à 2.

    J'ai le meme genre de symptomes sur mon shuttle SN45G (nForce 2) avec GForce FX 5200.
    J'etait en mandrake 9.2 et je n'allais jamais au dela de 2 jours d'uptime.

    J'ai pensé un moment que ca pouvais venr de la carte graphique qui est très chaude (brulante) avec les drivers nv, même quand je ne fais rien (c'est plus raisonnable avec les drivers nvidia).
    en la downclocqant violamment (40%) la temperature reste a peu pres la meme ...

    En rajoutant un ventilo qui souffle dessus, ca a l'air d'ameliorer a peine l'uptime max (effet placebo ?)

    J'ai viré l'acpi (option acpi=off au boot), ca n'a rien changé.

    J'ai essayé de passer en 2.6-test9, mais c'etait encore pire (max 2 heures)

    La je suis avec une Knoppix 3.3 et j'en suis à presque 5 jours d'uptime.

    J'aimerais vraiment trouver ce qui fait planter comme ca ...
    • [^] # Re: Disgnostic de crash sous Linux?

      Posté par  . Évalué à 1.

      Au fait j'y pense autre chose qui n'a rien a voir mais peut-etre que si:

      Sous mandrake, mon horloge se dealait lentement mais surement (~1 minute d'avance par jour), alors que sous Knoppix, c'est tout bon, elle reste a l'heure ...
  • # Re: Disgnostic de crash sous Linux?

    Posté par  . Évalué à 1.

    J'ai un SN41G2 XP2600+ avec une ML9.2

    J'ai le même genre de symptome :
    au bout d'un certain temps, d'utilisation (aléatoire) l'ecran s'eteint puis se rallume sur l'écran de login de KDE ???

    Est ce le même pb ?
  • # Re: Disgnostic de crash sous Linux?

    Posté par  . Évalué à 1.

    J'ai eu ces freeze du systeme avec chipset nforce2; le probleme a été completement resolu en metant les options de boot:

    --> acpi=ht nolapic pci=noacpi

    ps: je conseille egalement de desactiver l'apic dans le bios; par contre, ça risque d'empecher windows de demarrer ...
    • [^] # Re: Disgnostic de crash sous Linux?

      Posté par  (site Web personnel) . Évalué à 1.

      bonjour, pareil
      j'ai une ASUS A7N8X Deluxe (nforce2) et un Geforce 2 mx 64 mo
      avec la MDK 9.2 , ca freeze entre 5 min et 1H30 voir un peu plus
      J'ai mis une knoppix 3.2 , et cela tourne bien de 13H30 à 18h30 le lendemain. !!!!

      J'ai fait noacpi / lilo et dans le bios désactivé aussi rien toujours pareil

      sous win xp j'ai RAS !! (c'est horrible)

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.