Journal Lilo et splashscreen.

Posté par .
Tags : aucun
0
17
mar.
2004
Bonjour journal,

Hier, je me disais qu'un petit écran d'accueil sur mon lilo ça ferait vachement bien. Mais je me suis heuté à un petit problème.

J'ai préparé une image de boot en BMP (640x480x256). Je la prepare avec lilo -E image.bmp, je modifie mon lilo.conf (boot-bmp.b et chemin de l'image).

Je lance lilo et je redémarre.....Et là, je me retrouve avec mon écran d'accueil affiché mais l'image était décalée : je retrouvais la partie droite de l'image à ma gauche comme si j'avais mis une mosaique et que je me retrouvais à cheval sur deux images.

Tout de suite, ça fait pas trop "eye-candy".

Aurais-tu quelques pistes d'investigation pour résoudre mon problème ?

(Je suis sur debian testing/unstable)

Merci.
  • # Re: Lilo et splashscreen.

    Posté par . Évalué à 0.

    A propos quelqu'un sait ou l'on pourrait trouver des galeries de SplashScreen Lilo, et au passage des SplashScreen de démarrage Linux (BootSplash).
    • [^] # Re: Lilo et splashscreen.

      Posté par . Évalué à 2.

      Le classique http://www.73lab.com(...) propose pas mal de fonds d'ecran, de lilo et kde splash. Je les trouve très bien, mais c'est évidemment affaire de gout :)
      • [^] # Re: Lilo et splashscreen.

        Posté par (page perso) . Évalué à 1.

        Et comment qu'on fait pour mettre une des images marrantes qui sont sur le site en splash de lilo au boot ?
        • [^] # Re: Lilo et splashscreen.

          Posté par . Évalué à 1.

          Ca dépend de la distribution, pour Mandrake tout est dans le .tgz.

          Pour Debian (testing/unstable), faut modifier la taille de l'image en 640x480x256, enregistrer l'image en .bmp dans /boot/"nom_image.bmp", faire un petit lilo -E /boot/"nom_image.bmp" pour parametrer tout ce qui va bien (emplacement des entrées du menu, emplacement du timer, couleurs, etc....).

          Après il faut modifier le lilo.conf pour changer install=boot-menu.b en install=boot-bmp.b (commenter, c'est mieux). et ajouter une entrée bitmap=/boot/"nom_image.bmp".

          Ne pas oublier un petit /sbin/lilo et rebooter.

          Sinon, si c'est pour avoir les fichiers bmp des splash sur le site de ayo, tu peux télécharger une archive contenant les images bmp (par contre, je me rapelle plus où, ça doit être dans la section divers).
  • # Re: Lilo et splashscreen.

    Posté par . Évalué à 1.

    au pif (j'ai pas de lilo sous la main ni de man, et pas le tps de chercher), est-ce que lilo il voudrait pas une image au format raw plutot qu'avec l'entete presente dans un .bmp ?
    • [^] # Re: Lilo et splashscreen.

      Posté par . Évalué à 1.

      Nan, c'est bien du bitmap. Encodé en RLE si possible, ça prend moins de place (dixit la doc de lilo).

      Pour mon cas (Mandrake 9.1), je n'ai pas utilisé l'option -E. J'ai placé toutes les options dans le lilo.conf et pas dans le header de l'image. lilo -v, reboot, deux/trois ajustements plus tard, c'était bon.
  • # Re: Lilo et splashscreen.

    Posté par . Évalué à 1.

    Moi j'ai mis ce que j'avais trouvé sur le site de debian a l'époque, a savoir dans le lilo.conf :

    bitmap=/boot/sarge.bmp
    bmp-colors=1,,0,2,,0
    bmp-table=120p,173p,1,15,17
    bmp-timer=254p,432p,1,0,0



    Voilou

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.