Journal n'achetez pas decarte pci udma a base de w-8212

Posté par  .
Étiquettes : aucune
0
11
sept.
2003
En effet :
*les disque ide sont emuller en scsi

*ils violent la gpl : pour acceder au source du driver il faut signer un NDA ( http://www.ite.com.tw/productInfo/pc_ula.asp?DownFile=Linux_DrvSrc_(...) )alors que leur driver comporte l'entete gpl ( http://www.ite.com.tw/pc/Linux_DrvSrc_092029-02.zip(...) pour ne pas signer le nda )
en plus quand on voit dans le code

#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,4,10)
MODULE_LICENSE("GPL");
#endif
on voit clairement qu'il se foute de la gpl

*et enfin le driver gele le kernel pendant 15 seconde lors du chargement et le detecte aucun disque.....

Bref je vais retourner demain cette carte....
  • # Re: n'achetez pas decarte pci udma a base de w-8212

    Posté par  (site Web personnel) . Évalué à 2.

    Si tu es sur de ce que tu avances, je pense que tu devrais signaler cela sur la liste de discussion du noyau Linux.
    • [^] # Re: n'achetez pas decarte pci udma a base de w-8212

      Posté par  . Évalué à 5.

      Ca me parait une tres mauvaise idee. Je frequente cette liste depuis un moment et c'est pas vraiment le genre de choses qu'ils aimnet voir debarquer. La liste est reserve a l'usage des developpeurs.

      Pour ce genre de probleme il vaut mieux aller la :

      http://www.gnu.org/licenses/gpl-violation.html(...)

      Ca permet de verifier que les conditions sont remplies et derriere on envoit a mail a license-violation ou au detenteur du copyright (la en l'occurence je ne sais pas qui se sera). Mais il vaut mieux envoyer un Mail a Linux lui-meme que de creer un troll sur la deja enorme kernel-mailing liste.
      .

      Kha
  • # Re: n'achetez pas decarte pci udma a base de w-8212

    Posté par  . Évalué à 0.

    c est quoi le probleme ???

    dans le fichier.c j ai ca
    /*
    * linux/drivers/scsi/iteraid.c
    *
    * (C) Copyright 2002-2003 Integrated Technology Express, inc.
    *
    * Nov 11, 2002 Mark Lu file created.
    *
    * ITE IT8212 RAID controller device driver for Linux.
    *
    * This program is free software; you can redistribute it and/or modify it
    * under the terms of the GNU General Public License as published by the
    * Free Software Foundation; either version 2, or (at your option) any
    * later version
    *
    * This program is distributed in the hope that it will be useful, but
    * WITHOUT ANY WARRANTY; without even the implied warranty of
    * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
    * General Public License for more details.
    ....
  • # Re: n'achetez pas decarte pci udma a base de w-8212

    Posté par  . Évalué à 1.

    Salut,
    Excusez moi par avance de mon ignorance, mais j'ai un pitit pb.
    J'ai cette même carte, mais je voudrais installer Linux sur une partition d'un des disques de cette carte. Hors à l'installe (de la Mandrake 9.0 9.1 9.2), aucun des drivers de carte contrôleur ne passe.. d'où mon pb. Sur la 9.2, l'install ne propose même pas le chargment de drivers....

    Donc, si qq peut m'aider, ca serait vraiment cool

    Merci d'avance

    tuxlr@hotmail.com
    • [^] # Re: n'achetez pas decarte pci udma a base de w-8212

      Posté par  . Évalué à 1.

      Salut même problème pour moi, impossible d'installer sur le RAID, car le pilote est sur le CD et en plus il doit falloir recompiler le noyau car impossible de l'installer comme ça. Bref comme cette carte est neuve je vais en changer pour une vrai... et une reconnu nativement tant qu'à faire. C'est vrai que quand on regarde le code source on croit réver... Quelqu'un connait une bonne carte comme ça de nom ?

      Merci @+
      • [^] # Re: n'achetez pas decarte pci udma a base de w-8212

        Posté par  (site Web personnel) . Évalué à 1.

        le vrai chemin pour le driver pour le kernel 2.6.x

        http://www.ite.com.tw/pc/LinuxSrc_it8212_092007-05_26x.zip(...)

        je vais essayer de le mettre dans mon kernel perso pour mandrake 10.0 (le src.rpm sera dispo sur mon ftp pour les autres system/version de mandrake)....

        Mon ftp : ftp://ftp.pcds.ch/pub/people/rapsys/(...)

        Si vous voullez recup mon patch il sera dispo sous un nom commençant par PHXX_...
        ou XX un nombre...


        Si sa marche pas chez moi je mettrais un nouveau message comme quoi elle marche pas sous nunux...
        • [^] # Re: n'achetez pas decarte pci udma a base de w-8212

          Posté par  (site Web personnel) . Évalué à 1.

          le driver marche, il faut ajouter 'iteraid' a /etc/modprobe.preload
          et avoir installé le kernel 2.6.4-5tmb ou le kernel 2.6.4-4phoenix, basé su le premier avbec quelque truc en plus...

          le mien est dispo sur le ftp cité plus haut, pour la mandrake 9.2 ou le kernel 2.4 désolé je peut rien pour vous...

          enfin vu la galère pour install cette carte évitez de l'achetter avant la sortie de la mandrake 10.1 qui prendra peut-être en charge ce driver...

          Je ne sais pas sinon ce que sa donne au niveau perf le fait qu'il émule des dd scsi... peut-être un temps de latence plus long???

          Si vous avez un soucis et besoin d'aide : rapsys PATCH free LOL fr
          PATCH=@
          LOL=.

          Bonne chance et que la force du libre soit avec vous...

          j'ai miroré le driver pour le kernel 2.6 sur mon ftp si sa peut rendre service a des gens, vu que le site a l'air de tomber en lambeau je préfère en garder une copie au cas ou...

          Quand à ce qui est des drivers sur le cd c'est pour mandrake 9.0!!!
          donc sauf si vous utilisez encore le kernel de la mandrake 9.0 il sert absolument a rien!!!
          • [^] # Re: n'achetez pas decarte pci udma a base de w-8212

            Posté par  . Évalué à 1.

            Bonjour,
            j'ai un kernel 2.6.3 de mandrake 10 community, j'ai compilé le dernier drive ITE dispo sur le site (1.44 à ce jour), il détecte bien mes périphériques, mais dès que j'y ai accès c'est extrêmement lent et j'ai le message suivant en boucle dans dmesg:

            AtapiInterrupt error
            MapError: error register is 20
            ATAPI: device not ready
            AtapiInterrupt: 32 words requested; 11 words xferred

            A noter que j'ai le même pb avec le kernel 2.4.25 de cette même mandrake. Je n'utilise pas du tout de raid mais juste des fonctions ATA de base de la carte.
            Comment résoudre ce pb ?
            • [^] # Re: n'achetez pas decarte pci udma a base de w-8212

              Posté par  . Évalué à 1.

              Je viens d acheter cette carte et je voudrais savoir si c est possible d'empecher l'ide scan du boot au début car c est long, c'est long !!
              merci
              • [^] # Re: n'achetez pas decarte pci udma a base de w-8212

                Posté par  (site Web personnel) . Évalué à 1.

                en fait la installez le kernel 2.6.6-4phoenix ou la ssérie des tmb > 2.6.5 il n'y a pas de time out dessus que j'ai vu si le module est mis dans /etc/modprobe.preload

                le driver a été modifié par tomas (tmb) pour enlever ce time out a la con...

                Sinon il semble que la version 2.6.3-9mdk du kernel mandrake dispo sous mandrake 10.0 official en dl sur les mirroirs prenne en charge ce périphérique a condition de rajouter iteraid dans /etc/modprobe.preload
  • # Re: n'achetez pas decarte pci udma a base de w-8212

    Posté par  . Évalué à 1.

    Je viens d acheter cette carte et je voudrais savoir si c est possible d'empecher l'ide scan du boot au début car c est long, c'est long !!
    merci

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.