Journal Un bug avec Mozilla

Posté par  (site Web personnel) .
Étiquettes : aucune
0
7
juin
2004
La honte suprême, j'ai un bug qui n'apparaît pas sous IE et qui apparaît avec Mozilla (j'utilise la version 1.6) sur mon site perso.

http://dominique.hoffmann.free.fr/source/news_toutes.php(...)

Le bas de la "longue" page est tout "esquinté" (le texte apparaît bizarrement), or si je vérifie le code, il est bien valide XHTML 1.0 strict, la source est correcte, pire le tout s'affiche sous IE parfaitement (et pas sur mon Mozilla préféré !).

Est-ce que vous avez le problème aussi ?

Merci à ceux qui répondront.
a+
  • # hu

    Posté par  . Évalué à 1.

    Mozilla 1.6
    Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.6) Gecko/20040115

    j'ai rien noté de déformé...
  • # ?

    Posté par  (site Web personnel) . Évalué à 1.

    chezmoisainormal.org

    sous firefox 0.8
    • [^] # Re: ?

      Posté par  . Évalué à 0.

      chezmoisainormal.org

      $ ping chezmoisainormal.org
      ping: cannot resolve chezmoisainormal.org: Unknown host

      ok, je --> []
  • # Quel problème ?

    Posté par  . Évalué à 4.

    J'ai visité ton site et n'y ai constaté aucun problème d'affichage, tout s'affiche correctement, où du moins, je n'y vois rien d'anormal, du début à la fin. Pou information, j'utilise Mozilla 1.4.1.

    « Je vous présente les moines Shaolin : ils recherchent la Tranquillité de l'Esprit et la Paix de l'Âme à travers le Meurtre à Main Nue »

  • # cassé

    Posté par  . Évalué à 1.

    je confirme que ca passe pas partout

    firefox 0.8 + windozeXP (honte a moi), et j'ai une ligne en bas de page qui est coupée horizontalement...
    • [^] # Re: cassé

      Posté par  (site Web personnel) . Évalué à 1.

    • [^] # Re: cassé

      Posté par  . Évalué à 1.

      Je suis dans la même configuration que nicodache, et j'ai un peu le même problème, plus exactement :
      - si je vais directement à la fin de la page par un +, il m'en manque un bout
      - si je vais à la fin de la page en utilisant l'ascenceur, il m'en manque aussi un bout, mais pas le même, et ça varie selon que je descend vite ou non
      - avec la molette, c'est la panique, chevauchements comme dans le scrinechote.

      En y regardant de plus près, et après avoir switché entre Firefox et d'autres fenêtes, il me semble qu'il y a un pb pour afficher la toute fin du texte (après "c'est-à-dire dans une") : l'espace réservé correspond bien à ce qu'il faut pour afficher le texte restant, mais il met par-dessus un peu n'importe quoi, comme une sorte de pb de rafraichissement ou autre...

      Et sous IE, effectivement, pas de pb.
      • [^] # Re: cassé

        Posté par  (site Web personnel) . Évalué à 1.

        Donc apparemment, le problème viendrait bien de Mozilla/Win Xp, car j'ai le même pépin (Mozilla 1.6 avec Win XP).
        La description que tu as faite ressemble vraiment au bug que j'ai.

        Et le problème ne se présente pas sous Linux.
        • [^] # Re: cassé

          Posté par  . Évalué à 1.

          Même souci avec Moz 1.7b / Win2ksp4 : la dernière news est hachée.
  • # Au rapport !

    Posté par  . Évalué à 1.

    RAS avec Mozilla 1.6 sous Linux.
  • # Petits défauts de Firefox

    Posté par  . Évalué à 2.

    Pas de problème avec Firefox 0.8 sous Linux.

    Mais je rencontre régulièrement des problèmes de rafraîchissement de ce genre sur d'autres sites, comme ici avec la toolbar DLFP.

    Un autre petit détail gênant qui se présente sur ton site et sur beaucoup d'autres : on ne peut pas utiliser la molette pour faire défiler la page quand le curseur est sur le cadre central (en fait ça marche un peu quand on est tout en haut).
    Je ne sais pas à quoi c'est dû, peut-être aux propriétés CSS d'une des div...

    P.S. : Ah si, peut-être un petit problème sur ton site : il manque parfois la bordure supérieure noire de 1 pixel du cadre gris en bas des news. Et en regardant bien, sur d'autres news cette bordure est 1 pixel trop haut, il y a donc un trou entre elle et le cadre gris.
    • [^] # Re: Petits défauts de Firefox

      Posté par  (site Web personnel) . Évalué à 2.

      Tu peux detailler tes problemes de rafraichissement ?
      • [^] # Re: Petits défauts de Firefox

        Posté par  . Évalué à 2.

        Oui. :)

        Merci de m'avoir posé la question, j'ai fait quelques petits tests et identifié plus précisément le bug.

        C'est lié à l'option "défilement doux" (smooth scrolling in english je crois). Avec la toolbar qui est fixe et qui recouvre le reste, quand on fait défiler à la molette (seul moyen de reproduire le bug chez moi) on voit temporairement des textes/cadres/autres qui bavent et qui sont rafraichis après un petit instant.
        En faisant rapidement un défilement vers le haut puis vers le bas le rafraichissement n'est pas fait, et c'est tout dégueu.
      • [^] # Re: Petits défauts de Firefox

        Posté par  . Évalué à 2.

        Correction : ça marche aussi très bien (façon de parler) avec PgUp/PgDown ou les flèches Haut/Bas, il suffit d'être rapide.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.