Journal Google Desktop Gadget for Linux

Posté par (page perso) .
Tags : aucun
0
5
juin
2008
Google vient de publier Google Gadget for Linux. Il n'est pas (encore?) intégré à Google Desktop, il est compatible avec les widgets Windows, et surtout, il est libre. Il utilise Webkit pour le rendu, a croire que Google affectionne ce nouveau moteur(utilisé également pour Android, l'OS pour téléphone portable made in Google).

Je ne l'ai pas (encore?) testé, mais si certains ont des retours.

Les annonces :
http://feeds.feedburner.com/~r/GoogleOpenSourceBlog/~3/30380(...)
http://feeds.feedburner.com/~r/GoogleDesktopApis/~3/30422753(...)

Le projet :
http://code.google.com/p/google-gadgets-for-linux/

Téléchargement de l'archive :
http://google-gadgets-for-linux.googlecode.com/files/google-(...)
  • # Cool

    Posté par . Évalué à 3.

    Je vais enfin pouvoir mettre l'horloge style Vista sur mon bureau...

    Pour ceux qui ont la flemme (et de l'humour ?) :

    "Google Gadgets pour Linux fournit une plateforme pour faire courir les gadgets de bureau sous Linux en servant les uniques besoins des Linux utilisateurs. Nous (?!) sommes compatibles avec les gadgets écrits pour Google Desktop pour Windows aussi bien que les Universal Gadgets sur iGoogle. Suivant les Linux normes, ce projet sera open-sourcé, sous l'Apache licence.

    Les Windows et Mac versions de Google Desktop ont fournit des gadgets hébergement fonctionnalités, sur Windows et Mac pour un moment maintenant et la Linux version de Google Gadget sera étendue à cette plateforme pour ces utilisateurs. En rendant possible les traversants-plateformes gadgets, une large librairie d'existants gadgets sont immédiatement disponibles pour les Linux utilisateurs. En addition, les gadgets développeurs bénéficieront d'une bien plus large potentiels utilisateurs base sans avoir à apprendre un nouvel API.

    Il y a deux principaux composants à l'application : un est une commune gadget librairie responsable pour faire courir et présenter un gadget, et l'autre est un hébergeur programme qui permet à l'utilisateur de choisir les gadgets et de les faire courir sur le bureau. En ce moment nous avons des hébergeurs écrits pour GTK+ et QT, avec le GTK+ hébergeur offrant une côtébarre similaire à celle de Google Desktop pour Windows.
    • [^] # Re: Cool

      Posté par . Évalué à 5.

      ça sent le google translate a plein nez.
      • [^] # Re: Cool

        Posté par (page perso) . Évalué à 10.

        Il a peut-être utilisé un gadget traducteur !
      • [^] # Re: Cool

        Posté par . Évalué à 10.

        >ça sent le google translate a plein nez.

        Non. J'ai juste adoré Astérix chez les Bretons quand j'étais petit.
  • # enfin webkit ...

    Posté par (page perso) . Évalué à 1.

    si tu lis le HowtoBuild, xulrunner est requis pour tout le monde, et si tu es en QT il te faudra aussi en plus QtWebkit.

    Après je ne sais pas si le howto est bien fait ou pas, je ne sais pas à quel niveau est utilisé xulrunner et à quel niveau est utilisé QtWebkit.

    http://code.google.com/p/google-gadgets-for-linux/wiki/HowTo(...)
  • # Trop bien !

    Posté par (page perso) . Évalué à 5.

    Génial ! J'ai plein de truc sur mon bureau qui servent à rien !! Vista n'a qu'a bien se tenir !
  • # configure error !!!

    Posté par . Évalué à 1.

    configure: error: No type size_t, but google Gadgets for Linux needs it!

    je me fais ch**r vec un truc que je vais viré apres 1mn d'utilisation, mais bon pour le fun...
    Et je fais comment pour continuer ?

    ps : j'ai installé toutes les lib requises par defaut et pour ubuntu 8.04 => http://groups.google.com/group/google-gadgets-for-linux-user(...) (j'ai d'ailleurs du desinstaller Kompozer pour continuer) et Google n'est pas mon ami, puisqu'il ne pas apporté de reponse precises a mon probléme.

    merci d'avance ;)
    • [^] # Re: configure error !!!

      Posté par (page perso) . Évalué à 2.

      Tu attends que quelqu'un le package pour ton édition? D'ailleur je ne serais pas surpris qu'il soit fournit par défaut avec certaines éditions, dont Ubuntu.

      D'ailleur, il ne s'agit que d'une première version, qui dépend de 36 moteurs HTML. On peut imaginer que tout cela s'arrange avec les versions.

      Je dirais qu'il y a des ch
      • [^] # Re: configure error !!!

        Posté par . Évalué à 1.

        Non pas du tout ... j'ai même pas cherché dans les depots d'ubuntu; a priori ces gadgets ne m'interresse pas plus que ça , c'était juste pour le fun comme dit plus haut.
        Maintenant , ce qui m'aurait interresser c'etait de comprendre cette erreur qui n'a rien d'exceptionnelle => http://www.google.fr/search?num=20&hl=fr&safe=off&am(...)
        Sur debian sid j'ai pas eu d'erreur...

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.