Journal Aller-retour chez SuSe

Posté par  .
Étiquettes : aucune
0
21
août
2004
Bonjour journal

Je vais te narrer une bien navrante histoire...
Il était une fois un ordinateur qui tournait sur mandrake cooker. Un jour, KDE 3.3 naquit. Et ô rage, ô désespoir, il n'est pas disponible pour cooker, malgré que son objectif nécessite son inclusion... Ces bougres de chez mandrake préfèrent conserver un KDE 3.2.3, qui est toujours bien buggué (cf http://qa.mandrakesoft.com/show_bug.cgi?id=10256(...) )
Profitant d'un Kit Novell, installation de Suse à côté de la suscitée mandrake. Tout marche à peu près. MAIS diantre, n'y a-t-il point de gestionnaire de paquets correct ? Point de urpmi --auto-select ou apt-get update ? Après une tentative d'installer KDE 3.3, plus de KDE fonctionnel. Il se faisait tard, nous éteignîmes la machine et partîmes au lit.
Après le chant du coq, allumage de la machine : point de X ??? point de Wifi ???
Plus de drivers directement !
Colère aidant, nous partîmes dans les bras de cooker : gels de X ? Diantre, voilà chose surprenante. lynx aidant, nous téléchargâmes un nouveau driver NVidia : plus de problèmes. Mais toujours point de KDE 3.3...
Que le grand cric me croque, nous ne me laisserions point faire ! Debian, me voici !
  • # Et un de moins

    Posté par  (site Web personnel) . Évalué à 3.

    > Et ô rage, ô désespoir, il n'est pas disponible pour cooker, malgré que son
    > objectif nécessite son inclusion...

    Superbe fud. Sortir un bug, qui de toute évidence n'est pas si simple à fixer, cf les rapports de bugs, pour dire que kde3.2.3 est horriblement buggé, c'est fort.
    Comme deja dit sur justement la liste cooker, il y a les fixes de kde3.3 les plus importants.

    > MAIS diantre, n'y a-t-il point de gestionnaire de paquets correct ? Point de
    > urpmi --auto-select ou apt-get update ?

    Il devait aussi pas y avoir mozilla et google sur ta suse, car apt-rpm existe aussi sur cette distro...

    > Que le grand cric me croque, nous ne me laisserions point faire ! Debian, me
    > voici !

    Bon débarras.
    • [^] # Re: Et un de moins

      Posté par  . Évalué à -4.

      Superbe fud. Sortir un bug, qui de toute évidence n'est pas si simple à fixer, cf les rapports de bugs, pour dire que kde3.2.3 est horriblement buggé, c'est fort.
      Comme deja dit sur justement la liste cooker, il y a les fixes de kde3.3 les plus importants.

      Si il n'y avait que ce bug. Et puis le bug il est apparu du jour au lendemain ? Non, entre 2 mises à jour de kdebase il est apparu donc normalement il devrait y avoir moyen de trouver le patch qui en est la cause...
      C'est un exemple...
      Il devait aussi pas y avoir mozilla et google sur ta suse, car apt-rpm existe aussi sur cette distro...
      Arf c'est cool ouaip super j'en saute de joie...
      1- Fallait le savoir
      2- Ce genre d'outils doit être fourni en standard
      3- Je pensais que yast était suffisant
      (de toute façon, après il était trop tard)
  • # je te conseille slackware ou gentoo

    Posté par  . Évalué à 5.

    hé hé couché le troll

    parce qu'avec ma slackware j'avais kde 3.3 le lendemain de sa sortie (pas le jour même parce que j'avais la flegme de faire ça le soir même et envie de dormir :-)

    Et ça n'a pas bousillé mon système. Comme quoi, ne pas avoir de système de gestion de paquets complètement tordu ça peut aider parfois...

    euh en fait la gentoo j'ai pas essayé, mais t'aurais eu la joie d'attendre la fin de la compil. Et je pense aussi que ca aurait marché du premier coup !! (je crois aussi qu'il doit y avoir qq part des paquets précompilés)

    "gentooistes" dites-moi si j'ai raison !
  • # Pas malin pour deux sous

    Posté par  . Évalué à 4.

    1 - c'est un troll stupide. Quand on décide de changer de distrib, on regarde ce qu'il existe et comment elle marche. Pour les packages sous SUSE, Yast est probablement l'un des meilleurs outils toutes distribs confondues. Ah oui, il faut juste apprendre comment ça marche. Et en plus la documentation de la SUSE est un vrai trésor.

    2 - Sur google : tu tapes apt suse et le preier lien retourné est http://linux01.gwdg.de/apt4rpm/(...) . Je l'utilise, ça marche. Donc tu n'as pas cherché. Les pilotes Wifi, ils y sont. Par défaut. Je le sais, j'ai juste eu à brancher mon adaptateur USB et hop. Ton KDE 3.3 tu l'as installé à coup de rpm --force --nodeps ou quoi ? Ici sous Suse 9.1, apt-get upgrade et hop, kde 3.3 fonctionnel.

    3 - N'installe surtout pas une Debian, la SUSE étant probablement la distrib la plus simple, tu vas nous péter un câble. Tu sais qu'il faut faire quasiment tout à la main dessus ?

    4 - Je remarque cependant que tu es courageux, tu as installé et configuré un Mandrake. Chose peu aisée quand on voit la baisse constante de la qualité des releases de cette distrib depuis la 9.0. Des betas en permanence.

    Signé : Un type avec une machine sous SUSE 9.1, une autre sous Debian Sarge et une troisième sous Mandrake 10 Official.
    • [^] # Re: Pas malin pour deux sous

      Posté par  . Évalué à 1.

      1- Je me suis informé, mais Yast ne se comportait pas comme décrit...
      2- Pilotes Wifi : ils ont marché au début (après recherche d'un firmware) mais ce matin impossible de charger le moindre driver
      Perso pour installer KDE 3.3 j'ai voulu utiliser Yast, pas la commande rpm qui fait chier avec les deps. Ne me prend pas pour un con quand même...
      3- J'ai déjà utilisé un peu Debian, j'aime bien mais j'ai pas eu le temps d'approfondir à l'époque
      4- La 10.1 Beta 1 me paraît plus stable que la 10.0 :) Perso depuis la 9.0 j'ai eu une grosse déception sur la 9.2, et la 10.0 qui avait du mal sur certains PCs avec Magicdev
      • [^] # Re: Pas malin pour deux sous

        Posté par  . Évalué à 3.

        J'ai un seul conseil : installe apt4rpm depuis le lien ci-dessus.
        - Configure tes sources apt dans le /etc/apt/sources.list que tu récupères ici : http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/9.1-i386/examples/source(...)
        (copier/coller)
        - Interdit la MAJ du noyau et de la glibc (j'ai eu des suprises) dans ton /etc/apt/apt.conf.d/apt/conf :

        Hold {
        "glibc";
        "glibc-devel";
        "kernel";
        };

        et hop :
        apt-get update
        apt-get upgrade (fait un -s avant).

        Voila !
        • [^] # Re: Pas malin pour deux sous

          Posté par  . Évalué à 1.

          Quelqu'un avait dit sur ce forum à propos de apt4rpm sur fedora que ça emmerdait au niveau de la base de données rpm. Qu'en est-il vraiment ? Etait-ce une erreur ?
        • [^] # Re: Pas malin pour deux sous

          Posté par  (site Web personnel) . Évalué à 1.

          Une petite question :)

          rpm -q glibc
          glibc-2.3.3-98

          Ce sont quoi tes repertoires pour apt? Parce que je croyais que la mise a jour de la glibc venais d'update... Et je viens de vérifier, c'est pas le cas :/

          C'est quel rep qui evolue? base?

          Sinon, as tu ce probleme:
          http://lists.suse.com/archive/suse-kde/2004-Aug/0099.html(...)


          Pour finir, D.Pierre, a propose de ca:
          http://qa.mandrakesoft.com/show_bug.cgi?id=10256(...)
          Ce bug n'existe pas avec la 10.0(kde 3.2.0) ni avec un kde 3.2.3 compilé a la main avec konstruct. Par contre, les rpm de la Suse pour kde 3.2.1/kde3.2.2/kde3.2.3 ont exactement le meme probleme. Il a disparu avec kde 3.3. La question est: Laurent Montel n'aurait il pas intégré un patch from Suse?
          • [^] # Re: Pas malin pour deux sous

            Posté par  (site Web personnel) . Évalué à 2.

            Hmm, derniere chose, pour le bug de konqueror, normalement, il n'a lieu qu'avec un onglet d'ouvert, en clair, si tu dis a konqueror de cacher la barre d'onglet quand tu n'as qu'un onglet, le probleme devrait disparaitre si tu n'a qu'un onglet ;)
            • [^] # Re: Pas malin pour deux sous

              Posté par  . Évalué à 1.

              Sous Suse j'avais eu le bug mais je l'avais mis sur le dos de la mise à jour vers KDE 3.3 en cours de mise à jour.
              Ce qui me gêne c'est qu'en fait il est apparu entre 2 mises à jour, il aurait fallu chercher à ce moment là la solution au bug, maintenant c'est plus difficile : quel patch provoque ça ? Comment patcher le patch ?
          • [^] # Re: Pas malin pour deux sous

            Posté par  . Évalué à 2.

            Je n'ai aucun des bugs listés avec mon KDE 3.3. En fait le seul bug rencontré, c'est le screensaver : j'ai remis l'ancien kxsrun de kde 3.2.3.

            Côté apt, sous la SUSE (et les autre apt4rpm) les archives rpm sont dans /var/cache/apt/archives

            Concernant la glibc, j'ai (sur un P-IV) :

            rpm -qa | grep glibc
            glibc-info-2.3.3-98
            glibc-devel-2.3.3-97
            glibc-locale-2.3.3-98
            glibc-html-2.3.3-98
            glibc-2.3.3-97

            le apt propose une 2.3.3-98 mais c'est une version i586 (et pas i686) dont la stack (ou un truc comme ça) est pas bien paramétré ! Résultat : plus possible de faire marcher certaines applis comme winex ! J'ai donc gardé l'originale. En fait il semble qu'il y ait une différence entre la repository apt et les supports cd/dvd... Et apt se fout royalement, pour la glibc, de l'architecture ...

            Voila !
            • [^] # Re: Pas malin pour deux sous

              Posté par  (site Web personnel) . Évalué à 1.

              "Je n'ai aucun des bugs listés avec mon KDE 3.3."

              Merdum :(

              Ca veut dire que ca n'arrive que dans un certain cas bien particulier :/ Le bug de systray a disparu avec la derniere mise a jour de kdelibs mais chez moi la barre de tache fait tjs n'importe quoi... T'utilise bien cette derniere?
    • [^] # Re: Pas malin pour deux sous

      Posté par  . Évalué à 1.

      Tiens vu que tu sembles connaître suse, une question : pourquoi n'ont ils pas intégré "pour des raisons légales" les firmwares de certains périph wifi alors que dans mandrake ils sont inclus avec le noyau et sur debian ils sont fournis avec le driver normalement, pas en non-free ?
      • [^] # Re: Pas malin pour deux sous

        Posté par  . Évalué à 2.

        A cause de la législation allemande bien plus rigide. Ils ne fournissent pas non plus libdecss...
        • [^] # Re: Pas malin pour deux sous

          Posté par  . Évalué à 0.

          libdecss ça ne m'étonne pas, mais donc pour les firmware, ce qui me surprend, c'est que debian est bien dispo en allemagne, pourquoi n'ont ils pas du mettre les firmware en non-free ou non-de ?

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.