Forum Linux.noyau Carte réseau qui envoit/reçoit par intermittence

Posté par  .
Étiquettes : aucune
2
3
sept.
2012

Bonjour,

J'ai deux machines physiques identiques, l'une avec une Debian Squeeze, l'autre avec une Debian Wheezy. Les deux ont un Apache et sont situés derrière un répartiteur de charge HAProxy qui donnent 50% du trafic à chaque machine.

Je viens de remarquer quelque chose d'étrange. Avec la commande dstat --net je peux voir le débit réseau par seconde, et voici les résultats:

Première machine sous Squeeze (Linux 2.6.32)

1615k 3104k
   0     0 
1371k 3566k
   0     0 
1609k 3427k
   0     0 
(…)

Forum Linux.noyau OOM Killer, avec la moitié de la RAM utilisé par le cache

Posté par  .
Étiquettes :
0
6
jan.
2012

Bonjour,

je dispose d'un serveur avec 64Go de RAM et un Linux 2.6.39
Hier soir, le OOM Killer m'a tué un processus kvm, et je ne comprends pas pourquoi.

Voici l'utilisation mémoire actuelle:

MemTotal: 66108636 kB
MemFree: 1032244 kB
Buffers: 20732 kB
Cached: 29441080 kB
SwapCached: 1048556 kB
SwapTotal: 1925116 kB
SwapFree: 4300 kB

C'est plus ou moins pareil toute la journée. Il y a 29Go de cache, et il me semblait que le noyau allait se servir là dedans (…)

Forum Linux.général Apache qui cause des pics d'accès disque

Posté par  .
Étiquettes : aucune
1
22
fév.
2011

Bonjour,

j'ai un problème de pics de charge sur un de mes serveurs. Ces pics surviennent plus ou moins aléatoirement, et font souvent des pointes à 80-100, mais ne durent jamais plus de 2-3 secondes. Une fois passé, la charge redescend, jusqu'à que la même chose se reproduise.

  • Après un peu de monitoring j'en ai déduit que le process "flush" (anciennement pdflush je pense) monopolise les disques et me fout le bordel, vu que ça me bloque un paquet de (…)

Forum Linux.général Erreur "Cannot allocate memory" généralisée

Posté par  .
Étiquettes : aucune
0
17
fév.
2011
Bonjour,

je rencontre actuellement un gros soucis avec un de mes serveurs web/postgresql.
Lorsque je lui envoie du trafic (scripts PHP + quelques images), au bout d'un certain temps tous les process PHP meurt à cause d'une erreur "Out of memory". Au même moment, Postgresql log des erreurs "Cannot allocate memory". Et encore au même moment, exim4 log aussi une erreur "Cannot allocate memory" dans le paniclog...

Le plus étrange c'est que via htop je surveille l'utilisation de la mémoire, (…)

Forum Linux.noyau Limitation de la bande passante avec tc

Posté par  .
Étiquettes : aucune
0
24
jan.
2011
Bonjour,

je cherche à limiter sur un serveur de backup la bande passante utilisée par des dump postgresql à 30mbps maximum.
En fouillant je n'ai rien trouvé d'autre que d'utiliser "tc" pour le faire, donc en suivant plusieurs howto j'ai ce script:

tc qdisc del dev eth0 root
tc qdisc add dev eth0 root handle 1: htb default 1 r2q 160
tc class add dev eth0 parent 1: classid 1:1 htb rate 32000kbit burst 1m
tc class add dev eth0 (…)

Forum Linux.général Raid 5, secteurs défectueux, HP SmartArray P400

Posté par  .
Étiquettes : aucune
0
26
avr.
2010
Bonjour,

je dispose d'un serveur HP Proliant avec un contrôleur raid HP SmartArray P400.
Depuis ce matin et après avoir lu le paragraphe sur le raid 5 de wikipédia, notamment cette partie:
Tout ceci pourrait ne pas être bien grave et occasionner la perte d'une quantité de données minime (un secteur de disque), cependant, l'extrême majorité des contrôleurs RAID est incapable de gérer les défaillances partielles : ils considèrent généralement qu'un disque contenant un secteur illisible est totalement défaillant. À (…)

Forum Linux.noyau Flush disque qui fait "freezer" la machine

Posté par  .
Étiquettes : aucune
1
6
jan.
2010
Bonsoir,

je me trimballe un soucis depuis que je suis passé en 2.6.32 je pense, de temps à autre mes applications se retrouvent dans l'état "En attente disque".

Quand je regarde avec atop, à ce moment là ce qui utilise le plus le disque c'est soit un processus "flush-254:0" soit un processus "jbd/2".

D'après moi ce sont des processus du noyau, mais je n'ai aucune idée de pourquoi ça freeze...ça arrive le plus souvent quand je lance deux applis qui (…)

Forum Linux.général Corruption graphique avec les drivers ATI

Posté par  .
Étiquettes : aucune
3
27
oct.
2009
Bonjour,

depuis longtemps j'ai des soucis avec les drivers ATI libres: lorsque je scroll dans n'importe quelle application, il m'arrive souvent d'avoir de la corruption, qui se traduit par une "ligne" de la fenêtre qui se retrouve sur une autre. Par exemple, dans Konsole, je fais mon travail, je tape une commande et là l'affichage de la commande se met sur la commande précédente, il manque donc un bout de l'affichage. Et le truc c'est que si je scroll un (…)

Forum général.hors-sujets Indemnités chômages

Posté par  .
Étiquettes : aucune
0
1
oct.
2009
Bonjour,

parce que j'arrive pas à trouver de vrais réponses sur le net, je me suis dit qu'ici quelqu'un pourrait savoir.

Le contexte: j'étais pendant un an en contrat d'apprentissage, suivi d'un CDD de 1 mois. Aujourd'hui, je ne travaille plus donc.

Sur le site de l'assedic, ils parlent de "périodes", celle qui me concernerait serait celle là:
"182 jours d’affiliation ou 910 heures de travail au cours des 22 mois qui précèdent la fin du contrat de travail (terme (…)

Forum Linux.gui Équivalent de GNU Screen pour une session X

Posté par  .
Étiquettes : aucune
2
16
sept.
2009
Bonjour,

question rapide, existe-t-il un équivalent à screen pour une session X ?
C'est à dire, je lance ma session sur mon poste à la maison, de n'importe où je me connecte à la maison et je retrouve ma session comme je l'ai laissé avant. Le même principe que screen mais en graphique.

Merci.

Forum Linux.général Disque dur non reconnu après un benchmark Bonnie++

Posté par  .
Étiquettes : aucune
1
6
sept.
2009
Bonjour,

aujourd'hui j'ai voulu faire un benchmark d'un volume LVM, j'ai donc utilisé bonnie++, avec une commande dans ce style (je l'ai plus exactement en tête):
bonnie++ -d bench -s 4096 -n 256 -x 5 -q
Donc le test se passe, et arrivé un moment ça plante: je n'ai plus le message d'erreur complet, mais en gros c'était "système de fichiers en lecture seule".
Déjà je me dis "Ouhla", donc je vais dans le répertoire et essaye de supprimer les (…)

Forum Linux.général Créer un volume LVM sans perte de données

Posté par  .
Étiquettes : aucune
0
4
mai
2009
Bonjour,

je dispose de 2 disques durs:
- un de 1To, /dev/sdc, une unique partition /dev/sdc5 en ext3
- un de 640Go, /dev/sda

Actuellement, /dev/sdc est monté sur mon home, et je monte /dev/sda dans un dossier dans /mnt, mais ça ne me plaît pas trop.
J'aimerai donc utiliser ces disques pour créer un volume LVM unique, par contre je ne souhaite pas perdre mes données sur /dev/sdc (environ 340go utilisé).

Dans le man de pvcreate, je lis que ça (…)