Forum Astuces.divers [Web/Mozilla] désactiver la restauration de session sous bon echo/firefox 2.0

Posté par .
Tags : aucun
0
26
sept.
2006
Depuis la beta 1 de bon echo, ce navigateur propose *par défaut* un système de restauration de session (i.e. l'ensemble des pages ouvertes) après une interruption non considérée comme normale.
Cela peut devenir un problème si l'on n'a pas le même point de vue sur une interruption normale du navigateur (par exemple, je ne ferme jamais le navigateur avant un shutdown, et je ne m'attends pas spécialement à pouvoir retrouver mes pages).

Il n'est pas prévu apparemment de préférence pour désactiver ce système, et si apparemment une préférence cachée est prévue ( http://wiki.mozilla.org/Session_Restore#Preferences ), elle ne semble pas visible pour le moment dans about:config
Il va donc falloir l'ajouter à la main...

Fermer complètement firefox sinon ce que l'on va faire va être écrasé à la fermeture du logiciel.
dans son repertoire home, ouvrir
.mozilla/firefox/<nom de session>/prefs.js (parfois ce répertoire va changer de nom selon la distribution)
ajouter une ligne
user_pref("browser.sessionstore.enabled", false);
enregistrer, relancer le logiciel
  • # about:config

    Posté par . Évalué à 2.

    J'ai pas installé bon echo mais je pense que meme si l'option n'est pas prevu dans le about:config tu peux l'ajouter sans passer par le pref.js en faisant un bouton droit dans le about:config :
    nouvelle > valeur booleene
    et lui donner comme nom browser.sessionstore.enabled et comme valeur false
  • # et forcer a l'activer?

    Posté par . Évalué à 1.

    Salut,

    Chez moi Bon Echo me demande si je veux restaurer la session ou en démarrer une nouvelle quand je le lance après un reboot, saurais-tu s'il y a un moyen de toujours restaurer la session?

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.