Forum général.général Accès à certains serveurs impossible : comment diagnostiquer ?

Posté par  (site Web personnel) . Licence CC By‑SA.
1
21
oct.
2020

Sommaire

Hello,

J'ai récemment constaté un problème assez étrange et néanmoins bien gênant sur mon réseau local derrière ma box : il se trouve que je ne peux pas me connecter à (au moins) 2 serveurs publics :

  • remonterletemps.ign.fr en IPv4 soit 185.113.40.99
  • smtp.gmail.com en IPv6 soit 2a00:1450:400c:c02::6c

Ce qui est très étrange, c'est que rien ne permette de trouver de points communs révélateurs de l'origine du problème.

remonterletemps.ign.fr

ping

$ ping remonterletemps.ign.fr
PING remonterletemps.ign.fr (185.113.40.99) 56(84) octets de données.
^C
--- statistiques ping remonterletemps.ign.fr ---
3 paquets transmis, 0 reçus, 100% packet loss, time 2039ms

curl

$ curl -v https://remonterletemps.ign.fr
*   Trying 185.113.40.99:443...
^C

traceroute TCP - HTTPS

$ mtr -4 -r -c3 -T -P443 remonterletemps.ign.fr
Start: 2020-10-21T13:21:21+0200
HOST: leto                        Loss%   Snt   Last   Avg  Best  Wrst StDev
  1.|-- _gateway                   0.0%     3    0.3   0.3   0.3   0.4   0.1
  2.|-- ???                       100.0     3    0.0   0.0   0.0   0.0   0.0
  3.|-- lag-111.nctou101.Toulouse  0.0%     3    4.3   2.4   1.3   4.3   1.7
  4.|-- 193.252.160.9             66.7%     3    3.3   3.3   3.3   3.3   0.0
  5.|-- ae43-0.nipoi201.Poitiers.  0.0%     3    7.2   9.4   7.2  13.6   3.6
  6.|-- 193.252.137.18             0.0%     3   11.9  11.4  11.1  11.9   0.5
  7.|-- hundredgige0-1-0-13.pastr 33.3%     3  3051. 1532.  13.8 3051. 2148.3
        hundredgige0-2-0-14.pastr4.-.opentransit.net
  8.|-- zayo-8.gw.opentransit.net  0.0%     3   13.2  23.8  13.2  44.5  17.9
        zayo-9.gw.opentransit.net        
  9.|-- ae4.mpr2.cdg12.fr.zip.zay  0.0%     3   13.3  13.4  13.3  13.5   0.1
 10.|-- ???                       100.0     3    0.0   0.0   0.0   0.0   0.0

Le ping ne passe pas, HTTPS non plus. C'est clair, c'est net.

smtp.gmail.com

ping

$ ping smtp.gmail.com
PING smtp.gmail.com(wa-in-x6c.1e100.net (2a00:1450:400c:c0b::6c)) 56 octets de données
64 octets de wa-in-x6c.1e100.net (2a00:1450:400c:c0b::6c) : icmp_seq=1 ttl=105 temps=16.2 ms
64 octets de wa-in-x6c.1e100.net (2a00:1450:400c:c0b::6c) : icmp_seq=2 ttl=105 temps=16.5 ms
^C
--- statistiques ping smtp.gmail.com ---
2 paquets transmis, 2 reçus, 0% packet loss, time 1002ms
rtt min/avg/max/mdev = 16.185/16.325/16.466/0.140 ms

$ ping -4 smtp.gmail.com
PING  (74.125.133.108) 56(84) octets de données.
64 octets de wo-in-f108.1e100.net (74.125.133.108) : icmp_seq=1 ttl=103 temps=19.1 ms
^C
--- statistiques ping  ---
1 paquets transmis, 1 reçus, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 19.068/19.068/19.068/0.000 ms

telnet

$ telnet smtp.gmail.com 465
Trying 2a00:1450:400c:c0b::6c...
^C

$ telnet 74.125.133.108 465
Trying 74.125.133.108...
Connected to 74.125.133.108.
Escape character is '^]'.
^CConnection closed by foreign host.

traceroute TCP - SMTPS

$ mtr -4 -r -c3 -T -P465 smtp.gmail.com
Start: 2020-10-21T13:19:20+0200
HOST: leto                        Loss%   Snt   Last   Avg  Best  Wrst StDev
  1.|-- _gateway                   0.0%     3    0.5   0.4   0.3   0.5   0.1
  2.|-- ???                       100.0     3    0.0   0.0   0.0   0.0   0.0
  3.|-- lag-111.nctou101.Toulouse  0.0%     3    1.6   1.8   1.2   2.6   0.7
  4.|-- 193.252.160.9             66.7%     3    1.8   1.8   1.8   1.8   0.0
  5.|-- ae43-0.nipoi201.Poitiers.  0.0%     3    7.1   7.5   7.1   7.7   0.3
  6.|-- 193.252.137.18             0.0%     3   11.5  11.4  11.1  11.7   0.3
  7.|-- hundredgige0-10-0-28.auvt 33.3%     3   12.4  12.1  11.8  12.4   0.4
        hundredgige0-6-0-32.auvtr5.-.opentransit.net
  8.|-- 209.85.173.98              0.0%     3   11.2  11.4  11.2  11.7   0.3
        72.14.219.248                    
        209.85.148.16                    
  9.|-- 108.170.245.5             66.7%     3   14.4  14.4  14.4  14.4   0.0
 10.|-- 142.250.224.92             0.0%     3   13.0  13.0  12.2  13.8   0.8
        216.239.48.26                    
        216.239.48.146                   
 11.|-- 108.170.244.176            0.0%     3   13.5  13.1  12.2  13.8   0.8
        108.170.244.240                  
        108.170.244.177                  
 12.|-- 108.170.230.209            0.0%     3   11.9  15.6  11.9  18.7   3.4
        108.170.235.99                   
        74.125.37.57                     
 13.|-- 209.85.241.117             0.0%     3   19.1  20.9  19.0  24.6   3.2
        216.239.48.37                    
        216.239.51.118                   
 14.|-- 216.239.59.155             0.0%     3   16.2  17.4  16.2  18.6   1.2
        108.170.231.161                  
        74.125.37.57                     
 15.|-- 209.85.241.239             0.0%     3   19.0  19.3  18.4  20.4   1.1
        209.85.243.87                    
        209.85.241.119                   
 16.|-- ???                       100.0     3    0.0   0.0   0.0   0.0   0.0
 17.|-- ???                       100.0     3    0.0   0.0   0.0   0.0   0.0
 18.|-- ???                       100.0     3    0.0   0.0   0.0   0.0   0.0
 19.|-- ???                       100.0     3    0.0   0.0   0.0   0.0   0.0
 20.|-- ???                       100.0     3    0.0   0.0   0.0   0.0   0.0
 21.|-- ???                       100.0     3    0.0   0.0   0.0   0.0   0.0
 22.|-- ???                       100.0     3    0.0   0.0   0.0   0.0   0.0
 23.|-- ???                       100.0     3    0.0   0.0   0.0   0.0   0.0
 24.|-- wo-in-f108.1e100.net      66.7%     3   16.3  16.3  16.3  16.3   0.0

$ mtr -6 -r -c3 -T -P465 smtp.gmail.com
Start: 2020-10-21T13:19:45+0200
HOST: leto                        Loss%   Snt   Last   Avg  Best  Wrst StDev
  1.|-- 2a01:cb19:85e4:f800:769d:  0.0%     3    0.5   0.4   0.4   0.5   0.1
  2.|-- ???                       100.0     3    0.0   0.0   0.0   0.0   0.0

Le ping passe, en IPv4 et en IPv6. Par contre la connexion TCP ne passe qu'en IPv4 (pas de bol évidemment, l'IPV6 est choisie par défaut ce qui induit des latences importantes lors des envois de mails).

So what?

Les tests ont été effectués depuis plusieurs machines sur mon LAN (Archlinux et Ubuntu), avec le même résultat. Il ne s'agit donc pas d'un problème de firewall sur un poste en particulier.

Je suis connecté par la fibre Orange avec une Livebox 4.

Sur cette box, la connectivité IPv6 est activée sur l'interface d'admin, le pare-feu est en mode "Personnalisé" et les règles en place autorisent l'accès aux ports ouverts via les règles de NAT/PAT.

Il ne s'agit pas d'un problème de résolution DNS, ni d'un problème directement lié à l'IPv6 puisque je constate aussi un problème sur IPv4.

J'ai contacté l'IGN (mon premier et seul problème identifié à l'origine) afin de savoir si mon IP n'était pas dans une blacklist chez eux pour une raison ou une autre, mais apparemment ce n'est pas le cas. Impossible d'en être sûr à 100% cela dit.

Pour le SMTP de Gmail par contre, il y a, à mon sens, fort peu de chances que le blacklistage soit la raison. En tout cas il ne durerait pas plusieurs mois comme j'ai réalisé que c'était le cas jusqu'ici.

Tous les tests similaires effectués depuis une autre connexion (box SFR ou serveur chez Gandi) indiquent que le problème est vraiment lié à ma connexion, mais impossible de savoir exactement où.

J'ai déjà eu des problèmes étranges de connexion à certains serveurs il y a quelques années, mais ils étaient localisés à 1 ou 2 machines, et il se trouvait que c'était celles où j'avais essayé de bidouiller un peu les MTU pour activer les Jumbo Frames… En revenant sur des valeurs standards, les problèmes avaient disparu.

Quels autres tests pourrais-je faire qui me permettraient d'en savoir un peu plus et de cibler plus précisément l'origine du problème ?

  • # virer IPV6 coté livebox

    Posté par  . Évalué à 0 (+0/-2).

    ca évitera que les machines tentes l'IPv6 qui deconne parfois.
    ca a resolu pas mal de soucis chez mes différents amis qui ont une livebox

    pour ton test gmail, il est possible que leur service ne soit ouvert qu'en ipv4 pour l'instant, et si ton pc/box résoud en ipv6 d'abord, forcement, ca pose souci

    enfin le test de ping peut etre irrelevant, car une machine peut ne pas répondre en ping mais etre parfaitement fonctionnelle

    • [^] # Re: virer IPV6 coté livebox

      Posté par  (site Web personnel) . Évalué à 1 (+0/-0).

      Oui j'avais pensé à désactiver l'IPv6 puis mes tests semblaient démontrer que le problème n'était - au moins uniquement - limité à cet aspect, donc j'ai préféré le laisser car pour certains cas d'usage c'est pratique.

      Le test Gmail en IPv6 fonctionne parfaitement depuis une autre connexion que celle de chez moi, donc non a priori le service est ouvert et opérationnel (le contraire serait étonnant de la part de Google).

      Effectivement le test de ping est un simple complément au reste. Ça permet surtout de valider la partie IP sans la partie TCP.

      • [^] # Re: virer IPV6 coté livebox

        Posté par  . Évalué à 3 (+1/-0).

        Oui j'avais pensé à désactiver l'IPv6 puis mes tests semblaient démontrer que le problème n'était - au moins uniquement - limité à cet aspect, donc j'ai préféré le laisser car pour certains cas d'usage c'est pratique.

        Ok, mais essaye le conseil de Neox, ne serait-ce que pour avancer dans le diagnostic.

        • [^] # Re: virer IPV6 coté livebox

          Posté par  (site Web personnel) . Évalué à 1 (+0/-0).

          Effectivement, c'est le minimum.

          Bon par contre ça ne change rien, hélas : toujours pas de connexion en IPv4 sur remonterletemps.ign.fr :

          $ mtr -4 -r -c3 -T -P443 remonterletemps.ign.fr
          Start: 2020-10-22T11:47:07+0200
          HOST: leto                        Loss%   Snt   Last   Avg  Best  Wrst StDev
            1.|-- _gateway                   0.0%     3    0.4   0.4   0.4   0.5   0.0
            2.|-- ???                       100.0     3    0.0   0.0   0.0   0.0   0.0
            3.|-- lag-111.nctou101.Toulouse  0.0%     3    1.4   1.6   1.1   2.3   0.6
            4.|-- 193.252.160.9             33.3%     3  3210. 2109. 1008. 3210. 1556.9
            5.|-- ae43-0.nipoi201.Poitiers.  0.0%     3    6.9   9.8   6.9  14.7   4.3
            6.|-- 193.252.137.18             0.0%     3   11.6  14.8  11.6  20.9   5.2
            7.|-- hundredgige0-5-0-22.pastr  0.0%     3  3171. 1066.  13.5 3171. 1823.4
                  hundredgige0-2-0-14.pastr4.-.opentransit.net
                  hundredgige0-4-0-13.pastr4.-.opentransit.net
            8.|-- zayo-8.gw.opentransit.net  0.0%     3   24.9  28.3  24.9  30.3   3.0
                  zayo-9.gw.opentransit.net        
            9.|-- ae4.mpr2.cdg12.fr.zip.zay  0.0%     3   93.8  97.2  93.8 101.8   4.1
           10.|-- ???                       100.0     3    0.0   0.0   0.0   0.0   0.0
          
          $ curl -v https://remonterletemps.ign.fr
          *   Trying 185.113.40.99:443...
          ^C
          

          Et la connexion en IPv4 vers le SMTP de Gmail fonctionne toujours - comme attendu - mais toujours pas en IPv6 puisque… ben je l'ai désactivé.

  • # Et un de plus

    Posté par  (site Web personnel) . Évalué à 1 (+0/-0).

    Ah un de plus… Maintenant y'a aussi imap.gmail.com en IPv6 qui passe plus (à supposer qu'il passait avant, j'ai pas vérifié).

    Ni ping ni connexion TCP.

    $ ping imap.gmail.com
    PING imap.gmail.com(wr-in-x6d.1e100.net (2a00:1450:400c:c0c::6d)) 56 octets de données
    ^C
    
    $ mtr -r -c3 -TP993 imap.gmail.com
    Start: 2020-10-23T10:59:38+0200
    HOST: leto                        Loss%   Snt   Last   Avg  Best  Wrst StDev
      1.|-- 2a01:cb19:85e4:f800:769d:  0.0%     3    0.4   0.4   0.3   0.5   0.1
      2.|-- ???                       100.0     3    0.0   0.0   0.0   0.0   0.0
    

    En IPv4 toujours aucun problème évidemment.

    Je suis dans le flou :\

  • # Résolution (partielle)

    Posté par  (site Web personnel) . Évalué à 1 (+0/-0).

    Cette nuit j'ai perdu l'accès SSH à mon serveur chez Gandi.

    Temps d'accès SSH

    Après un ticket inutile qui a confirmé que le problème était bien de mon côté, j'ai tenté de redémarrer la box.

    Et évidemment tout remarche (IGN, Gmail, SSH). Probablement suite au changement d'IP de la box (de 90.76.235.192 à 86.206.2xx.xxx).

    Alors impossible de comprendre ce qui a bien pu coincer, mais une chose est quasi-sûre c'est que ça peut recommencer à n'importe quel moment, et c'est bien handicapant.

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.