Forum général.général Boot BIOS UEFI

Posté par . Licence CC by-sa.
Tags :
1
13
jan.
2019

Bonjour,

Sur ma config flambant neuve, j'ai installé une Fedora en GPT UEFI et LLVM. Depuis, je n'ai plus accès au BIOS UEFI, en appuyant sur Suppr au démarrage ou sur F2 ne fait rien. Ma carte mère est une Asrock Fatal1ty B450 gaming ITX.
Comment faire pour récupérer le BIOS UEFI ?

  • # coincidence

    Posté par . Évalué à 4.

    installer un système d'exploitation et accéder au setup bios ne se fait pas au même moment durant l'initialisation et Fedora ne vient pas toucher au système d'initialisation propriétaire situé sur une EEPROM donc techniquement il n'y a pas de lien de cause à effet.

    Teste avec d'autres claviers ou branche le sur un port différent (teste aussi le PS/2 si tu peux). C'est fort probablement de là que vient ce problème de reconnaissance du clavier.
    Après tu n'es pas à l'abri d'un bug à la con de l'UEFI du genre le clavier n'est pas détecté durant le POST si tu fais un reboot à chaud ou quand un support de stockage est détecté.

    • [^] # Re: coincidence

      Posté par (page perso) . Évalué à 2.

      Étant donné l'existence de https://fwupd.org/ j'aurais tendance à être moins catégorique quant à l'absence totale d'interaction entre OS et UEFI…

      Debian Consultant @ DEBAMAX

      • [^] # Re: coincidence

        Posté par . Évalué à 2.

        C'est plutôt rare pour les constructeurs de cartes ATX/ITX vendues au détail d'y participer. Et ça demande une action volontaire de l'administrateur.

        Étant donné le risque de badflash et de brick, je serais étonné que Fedora fasse tourner fwupd automatiquement, encore plus durant une installation.

  • # Fast boot

    Posté par (page perso) . Évalué à 8.

    Certains systèmes d'exploitations ont un mode de démarrage nommé « fast boot » pour Windows. L'UEFI n'est pas accessible lorsqu'on démarre de cette manière.
    Pour Linux je n'ai jamais entendu parler de cette option. C'est donc probablement activé dans ton UEFI.

    Le plus simple est de déconnecter le périphérique de démarrage (disque-dur ou SSD en général). Tu accèdes alors à l'UEFI.

    Une entrée de forum qui en parle :
    https://linuxfr.org/forums/general-general/posts/fastboot-et-acces-aise-au-bios

    • [^] # Re: Fast boot

      Posté par . Évalué à 2.

      Exact, j'ai activé le fastboot ! C'est donc là le problème et non de Fedora. Ce qui est ennuyeux dans l'affaire, c'est que mon disque dur est un ssd forma Ultra M.2, connecteur derrière la carte mère. Je suis pour un démontage et un remontage :/

      • [^] # Re: Fast boot

        Posté par . Évalué à 3. Dernière modification le 13/01/19 à 20:58.

        Exact, j'ai activé le fastboot !

        il faut alors etre tres rapide pour intercepter ce "fastboot" et acceder aux options UEFI

        autre possibilité, il me semble avoir lu que les linux un peu recents peuvent activer (et donc desactiver) le fastboot pour redemarrer en mode "normal"

        • [^] # Re: Fast boot

          Posté par . Évalué à 2.

          En fait, dans le manuel du BIOS/carte mère il est dit que le fast boot désactive l'USB, donc impossible puisque mon clavier est en USB… à voir si je peux trouver un adaptateur USB vers PS/2.

        • [^] # Re: Fast boot

          Posté par . Évalué à 2.

          L'autre possibilité c'est de modifier le bon fichier efivars de la partition efi… mais trop risqué, je viens de regarder (il faut passer par un éditeur hexadécimal).

        • [^] # Re: Fast boot

          Posté par . Évalué à 8.

          me semblait bien que j'avais lu un truc en ce sens,
          et 1°) c'est plus direct,
          2°) c'est officiel et documenté

          https://www.freedesktop.org/software/systemd/man/systemctl.html#--firmware-setup

          un simple appel à

          systemctl reboot --firmware-setup

          devrait suffire

          • [^] # Re: Fast boot

            Posté par (page perso) . Évalué à 3.

            systemctl reboot --firmware-setup

            Quand je pense que c'est mon métier, et que je ne connaissais même pas :-)

            Cela dit je n'en ai jamais eu besoin, ça aide à ne pas connaître. Les seuls enquiquinements que j'ai pour accéder à l'UEFI sont sur des machines qui ne sont plus capables de démarrer le Windows installé sur le disque-dur.

          • [^] # Re: Fast boot

            Posté par . Évalué à 2.

            un simple appel à

            systemctl reboot --firmware-setup

            devrait suffire

            Ah merci beaucoup ! Je ne connaissais pas.

  • # Entrée dans Grub

    Posté par . Évalué à 4.

    Hello,

    Est-ce que tu n'as pas une entrée dans Grub qui indique "System" soit directement sur la page d'accueil soit dans le démarrage avancé ?

    Julien_c'est_bien (y'a pas que Seb)

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.