Forum général.général Problème drivers nvidia + X.org

Posté par  (site Web personnel) .
Étiquettes : aucune
0
20
août
2004
Salut !

J'aimerais savoir si quelqu'un peut m'aider car j'ai un probleme avec mes drivers nvidia 6111.
Je m'explique: je suis sous mandrake 10.1 beta, donc avec x.org, j'ai une gf2 mx400.
J'ai installé les derniers drivers (c'est pas la première fois que je le fais), tout s'est bien passé, il a compilé le module, en me rappelant que rivafb etait compilé comme module. j'ai ensuite modifé XF86Config pour lancer le module nvidia.
Au démarrage de x, l'image nvidia apparait de temps en temps, un lsmod me dit que rivafb n'est pas chargé (de toutes façons j'avais fait un modprobe -r rivafb), et que nvidia est chargé. nvidia-seetings marche bien, cependant glxgears refuse de tourner :

Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't get an RGB, Double-buffered visual

Les drivers nvidia ne m'avait jamais posé de problèmes lorsque j'étais sour xfree, donc je ne pense pas que ça ait rapport avec mdk beta, mais plus avec X.org.

je vous remercie tous d'avance !
valente

ps : glxinfo http://www.chez.com/valentein/private/glxinfo.txt(...)
ps2 : modinfo nvidia http://www.chez.com/valentein/private/modinfo.txt(...)
  • # rtfm...

    Posté par  . Évalué à 4.

    j'ai ensuite modifé XF86Config pour lancer le module nvidia.
    hum... des fois faut lire la doc non?

    ftp://download.nvidia.com/XFree86/Linux-x86/1.0-6111/README.txt(...)
    • [^] # Re: rtfm...

      Posté par  (site Web personnel) . Évalué à 0.

      Pourquoi ce commentaire est "inutilisé" ? (à -1 à 15:31), c'est parfaitement ridicule, il a complètement raison de lui dire ca, en plus il a l'obligence de donner le lien qui va bien : une recherche du terme 'xorg' dans ce fichier donne (des la premiere reponse)

      The X.org configuration file name, though it uses the same syntax as XFree86's XF86Config file, is called /etc/X11/xorg.conf

      Desfois je comprends vraiment pas les gens.
  • # fichier de configuration

    Posté par  (site Web personnel) . Évalué à 1.

    Merci de ton aide teuz !
    Cependant, chez moi X.org utilise le fichier XF86Config, je l'ai verifé dans le log. j'ai par ailleurs vu dans le readme qu'il fallait ajouté la commande Load 'glx", mais a ce moment X.org refuse de demarrer en me disant qu'il ne connait pas la commande Load !
  • # petit rappel ...

    Posté par  (site Web personnel) . Évalué à 2.

    Le module rivafb est tout à fait incompatible avec le driver proprio nvidia.

    Donc, mieux vaut ne pas compiler rivafb et utiliser vesafb.
  • # réglé

    Posté par  (site Web personnel) . Évalué à 1.

    Merci a tous de votre aide !
    Le probleme est reglé: il fallait juste enlevait les # devant Load "glx" dans la section modules de XF86Config !

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.