Forum général.général probleme montage samba

Posté par  . Licence CC By‑SA.
Étiquettes : aucune
0
31
août
2014

Salut à tous,

Alors voila j'ai comme un petit probleme avec samba pour acceder à mes fichiers :
j'ai un disque dur sur une box (via un port USB de la box).
Avec un gestionnaire de fichier (nautilus ou pcmanfm) j'arrive bien à accéder au contenu du disque.
Si je fais un montage en ligne de commande :
mount -t cifs //neufbox/sams250 smb_neufBox/ -o guest,uid=500,gid=500,rw
je peux (toujours en ligne de commande) descendre dans le répertoire, voir mes fichiers mais j'ai un probleme d'acces :
par exemeple mplayer toto.avi me renvoie :
Playing toto.avi.
File not found: 'toto.avi'
Failed to open toto.avi.

si je fait leafpad toto.txt j'ai comme erreur :
"l'ouverture du fichier toto.txt a echoué permission non accordée"

Pourtant un ls -als confirme que je suis bien propriétaire des fichiers et qu'ils sont bien présents (les option uid et gid marchent donc bien correctement).
j'ai besoin du fonctionnement en ligne de commande car ensuite c'est pour mettre sur un systeme sans ecran, donc tout en ligne de commande.

Merci pour votre aide.

  • # Option guest en trop ?

    Posté par  . Évalué à 1.

    Salut,

    Est-ce que tu ne dois pas préciser un user et un mot de passe plutôt que guest dans les options de montage ?
    Je ne connais pas la neufbox mais il est possible qu'il faille s'authentifier pour pouvoir accéder aux fichiers du NAS. Les droits que tu vois avec un «ls -l» sont ceux que tu indiques dans les options (rw) mais les droits CIFS viennent se positionner en plus du côté du serveur.
    Quand tu accèdes au partage avec Nautilus, est-ce que tu indiques un user et un mot de passe ? (si tu as enregistré les identifiants, il est possible que Nautilus ne te poses plus la question) Est-ce que tu peux alors bien lire tes vidéos et éditer tes fichiers texte ?

    A+
    JJD

    • [^] # Re: Option guest en trop ?

      Posté par  . Évalué à 1.

      Ben justement, je n'ai pas d'identifiant de configuré.
      Si je ne mets pas l'option guesst il me demande un login passwd que je n'ai pas.
      Sur Nautilus, je n'ai jamais rien précisé.
      Apres, je n'ai jamais essayé de creer un "compte" sur la 9box.
      il n'y a dessus à priori que le compte admin.
      Je vais te,ter d'utiliser celui la…
      merci

      • [^] # Re: Option guest en trop ?

        Posté par  . Évalué à 2.

        Apres, je n'ai jamais essayé de creer un "compte" sur la 9box.

        et tu te connectes en guest.

        regardes dans les droits configurés sur la 9box, si ca se trouve guest ne peut que "lister" les fichiers
        mais pas les lire/copier/effacer

        • [^] # Re: Option guest en trop ?

          Posté par  . Évalué à 1.

          Oui mais avec nautilus (ou autre) ca marche, je peux lire / éditer les fichiers de mon disque.
          c'est ça qui me laisse perplexe…

      • [^] # Re: Option guest en trop ?

        Posté par  . Évalué à 1.

        getfacl, setfacl et paramètre security=user ou =share dans smb.conf ?

  • # Compliqué

    Posté par  . Évalué à 2.

    J'ai jeté un coup d'oeil au man de mount.cifs, et apparemment il y a de bonnes subtilités à savoir sur la propriété et les permissions des répertoires partagés.
    Il y a une section consacrée à cela, et j'avoue ne pas avoir tout compris les différences entre uid, forceuid, noperm et dynperm.
    Si cela peut t'inspirer …
    lien vers le man

    • [^] # Re: Compliqué

      Posté par  . Évalué à 1.

      Bon,

      j'ai a peu près essaye tous vos conseil, rien à faire :
      le forceuid et forcegid : toujours pareil,
      j'ai essaye de me connecter avec le login admin plutot que guest : toujours pareil.
      JE sèche completement…

  • # je vais dire une betise mais...

    Posté par  . Évalué à 1.

    si ca marche avec nautilus/pacman, pourquoi tu veux le faire en ligne de commande ?

    • [^] # Re: je vais dire une betise mais...

      Posté par  . Évalué à 2.

      Lit jusqu'au bout sa demande…

      • [^] # Re: je vais dire une betise mais...

        Posté par  . Évalué à 1. Dernière modification le 02/09/14 à 08:10.

        ah oui, désolé

        donc il faut faire un
        mount -t cifs -o username=COMPTE, password=PASS, uid=UID, gid=GID SRC DST

        avec :
        COMPTE : le compte autorisé à lire et ecrire sur la box
        PASS : le mot de passe du compte utilisé juste avant

        UID et GID : les UID/GID qui seront utilisés sur la machine de l'utilisateur, les distributions recentes commencent les UID/GID à 1000 (je ne sais pas d'ou sortent les 500 utilisés dans son exemple)

        SRC : la box, et le chemin vers le dossier partagé

        DST : le point de montage

        si on veut eviter le mot de passe dans la ligne de commande, on peut utiliser un fichier qui contiendra ce qu'il faut et que ne sera lisible que par root.

        • [^] # Re: je vais dire une betise mais...

          Posté par  . Évalué à 2.

          C'est EXACTEMENT la commande que j'ai essayée en dernier, en utilisant le
          seul compte existant sur la box et qui est le compte admin.
          Il semblerait que sur cette box, il n'y ait pas de possibilité de créer un autre compte (à la limite je m'en fous) et je n'ai pas accès au système de fichier pour voir si il y a un smb.conf.
          Pour info l'UID 500 c'est le premier nombre proposé par défaut sur la distrib (MAgeia) ou je fais
          pour l'instant les tests avant de passer sur le raspberrypi.
          L'autentification avec le compte admin marche bien, je suis bien proprio des fichiers une fois le montage effectué. Mais les applis ne les trouvent pas même si je mets le chemin en absolu !
          = meme comportement avec l'option guest ou avec un "vrai" login/passwd.
          Je sèche toujours !

          • [^] # Re: je vais dire une betise mais...

            Posté par  . Évalué à 1.

            comme tu le dis toi meme, l'UID 500 c'etait celui de mageia
            mais sous ton raspberryPI, ce n'est peut-etre pas le meme.

            dans les pages de man de CIFS

            The core CIFS protocol does not provide unix ownership information or mode for files and directories.
            Because of this, files and directories will generally appear to be owned by whatever values the uid= or
            gid= options are set, and will have permissions set to the default file_mode and dir_mode for the mount. Attempting to change these values via chmod/chown will return success but have no effect.

            donc si tu fais ton mount avec uid/gid=500
            mais que ton utilisateur courant est 1000/1000, ca ne marchera pas

            ton utilisateur a quels IDs ?
            il suffit de taper id dans la ligne de commande.

            sinon tu as essayé avec les options dir_mode et file_mode ?
            pour eventuellement dire que le montage sera en mode 777 pour que tous puissent lire/ecrire dedans.

            • [^] # Re: je vais dire une betise mais...

              Posté par  . Évalué à 1.

              Pour l'instant tous les essais que je fais c'est à partir
              d'un portable sur mageia j'ai bien l'IUD 500 (plus facile pour les tests que directement sur le raspberry). Quand tout marche, je comptais transposer sur le raspberry.
              j'ai aussi essayé les options dir_mode et file_mode.
              Quand je fais un ls -als, je vois bien les fichiers, j'en suis bien le propriétaire ET leur accès est bien 777.
              Donc tout ce passe bien tant que je n'essaye pas d'en ouvrir un (une video par example).
              MAis vu que ca coince toujours je vais tenter sur le raspberry… des fois que le comportement soit différent.

              • [^] # Re: je vais dire une betise mais...

                Posté par  . Évalué à 1.

                Pareil avec le raspberry (en mettant UID=1000 bien sur…).
                more toto.txt : permission denied.
                donc toujours aussi sec, pour un truc qui devait me prendre 1 minute à mettre en place!

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.