Forum Linux.debian/ubuntu ajouter un paramètre à un module au boot

Posté par (page perso) .
Tags : aucun
0
13
juil.
2011

Bonjour,

avec ubuntu natty, sur ma machine, il faut que le module firewire-ohci soit chargé avec le paramètre quirks=0x10. j'ai en effet ce bug avec ma machine.

J'ai essayé d'indiquer ce paramètre dans /etc/modules/,

firewire-ohci  quirks=0x10

ou dans un fichier dans /etc/modprobe.d/,

options firewire-ohci  quirks=0x10

mais ça n'est pas pris en compte après un reboot. Probablement parce que le module est déjà chargé ?

Il y a moyen d'indiquer ça ailleurs ? grub ?

  • # Module? What module? :-)

    Posté par . Évalué à 4.

    indiquer ce paramètre dans /etc/modules/

    Mouaif, bof... Utilise plutôt la seconde solution :

    dans un fichier dans /etc/modprobe.d/

    Le fichier doit finir en '.conf'.

    mais ça n'est pas pris en compte après un reboot.

    Par défaut, Debian et Ubuntu (kof!kof!... ;-]) démarrent sur un initrd. Si le module est chargé à partir de l'initrd, alors il faut re-générer cet initrd pour qu'il prenne en compte les nouvelles options que tu as spécifiées :

    update-initramfs -u -k KERNEL_VERSION
    

    Hop,
    Moi.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.