Forum Linux.debian/ubuntu Connexion en SSH

Posté par  . Licence CC By‑SA.
Étiquettes :
0
3
déc.
2016

Bonjour, ou bonsoir :)
Je débute dans linux, et je rencontre un problème avec SSH.
Je souhaiterais faire profiter un ami de ma raspberry à distance, je lui ai donc créé un utilisateur "UTILISATEUR" avec un mot de passe "MOT DE PASSE". J'ai ouvert le port 22 de ma box via NAT, afin de lui permettre de se connecter. SSH est activé par défaut sur Raspbian, pas besoin d'installer de paquets.

Il réussit à se connecter via l'ip publique de ma raspberry, au message "login as:" il répond UTILISATEUR, puis il entre le mot de passe. Mais, la console lui renvoie le message Access denied, même si le mot de passe est bon.
De mon côté, j'essaie de me connecter par mon ip publique, ça fonctionne, je me login, ça fonctionne je suis connecté !

Je ne sais pas trop pourquoi lui ne peut se connecter (peut être un pare feu au login d'IPs d'une autre box…). Je lui ai même donné le compte root, en toute confiance, c'est un très bon ami, mais le problème subsiste…

Faut-il modifier un fichier du dossier ssh ?

Merci d'avance :)
Auberginette

  • # Il faut lire le journal

    Posté par  . Évalué à 3.

    Il y a marqué quoi dans /var/log/auth.log ?
    Tu demandes à ton ami de tenter une connexion, puis tu regardes la fin de ce fichier.
    Ou dans /var/log/messages
    Ou encore /var/log/syslog
    Etc.
    En principe une explication à peu près précise s'y trouve.

  • # ssh -vvv

    Posté par  (site Web personnel) . Évalué à 5.

    Passe l'option -vvv à ssh pour te connecter, ça te donnera beaucoup plus d'infos. Tu es sûr que tu autorises le login par mot de passe ?

  • # ca devrait fonctionner

    Posté par  . Évalué à 6.

    J'ai ouvert le port 22 de ma box via NAT,

    mais suivant la box, tu arrives peut-etre en SSH sur la box, et non sur ton raspberry pi.

    essaie en configurant un NAT (en fait un PAT) sur un autre port
    ex : port 2222 exterieur => port 22 du RPi

    et demande à ton ami de se connecter en SSH sur ton IP publique, pot 2222

  • # Voir la configuration de sshd

    Posté par  (site Web personnel) . Évalué à 1.

    Bonjour,

    Accédez au fichier /etc/ssh/sshd_config, et voyez s'il s'y trouve une ligne commençant par AllowUsers, si elle s'y trouve et qu'elle contient votre login, de cette manière: AllowUsers votre_login, cela veut dire que votre serveur ssh n'autorise la connexion qu'à vous, il vous faudra alors ajouter le login de votre ami.

  • # surtout pas

    Posté par  (site Web personnel) . Évalué à 3.

    Faut-il modifier un fichier du dossier ssh ?

    Si les permissions sont incorrectes, la connexion sera refusée.

    Système - Réseau - Sécurité Open Source

  • # Recommandations

    Posté par  (site Web personnel) . Évalué à 2.

    Je recommande de changer le port par défaut, parce que le port 22 va se faire continuellement attaquer.

    Autant éviter d'avoir des tas de log d'erreurs…

    Pourquoi bloquer la publicité et les traqueurs : https://greboca.com/Pourquoi-bloquer-la-publicite-et-les-traqueurs.html

  • # authlog

    Posté par  . Évalué à 3.

    En plus des conseils précédents, je te conseille de regarder le fichier /Var/log/auth.log. Le serveur y expliquera pourquoi il refuse la connexion (si c'est bien lui qui refuse)

    « Rappelez-vous toujours que si la Gestapo avait les moyens de vous faire parler, les politiciens ont, eux, les moyens de vous faire taire. » Coluche

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.