Forum Linux.debian/ubuntu Contrôler ventilateurs Dell Studio 1555

Posté par .
0
17
août
2012

Bonjour à tous,

Mon Dell Studio 1555 faisant beaucoup de bruit (les ventilateurs tournent en continue…), j'ai voulu essayer de m'occuper de ce problème.
Mais j'ai un gros problème, lm-sensors n'a pas l'air de supporter mes ventilateurs.
Je vous passe tout le détail, mais quand je fais sensors-detect, j'ai ceci :

Trying family `National Semiconductor/ITE'...               Yes
Found `ITE IT8512E/F/G Super IO'                            
    (no support yet)

Driver `coretemp':
  * Chip `Intel digital thermal sensor' (confidence: 9)

To load everything that is needed, add this to /etc/modules:
#----cut here----
# Chip drivers
coretemp
#----cut here----
If you have some drivers built into your kernel, the list above will
contain too many modules. Skip the appropriate ones!

D'après le site officiel, il n'y a même pas de trace de ITE IT8512E/F/G …

Bien entendu quand je fais pwmconfig, j'ai droit à cette erreur :

/usr/sbin/pwmconfig: There are no pwm-capable sensor modules installed

Je voulais savoir si j'ai loupé un truc concernant mon fameux IT8512E/F/G (d'ailleurs ça porte un nom ce machin ? C'est un capteur ?) ou si vous avez des conseils pour pouvoir régler mes ventilateurs d'une autre manière ? Ou un quelconque retour d'expérience.

Merci.

  • # Kernel ?

    Posté par . Évalué à 2.

    Ça pourrait pas venir d'un module kernel qui ne serait pas inclus dans le noyal qui tourne sur ta machine ?

    • [^] # Re: Kernel ?

      Posté par . Évalué à 1.

      Oui il n'y a pas de module pour les puces it85** (d'après le site officiel no driver).

      Par contre tu peux essayer avec le module générique it87 :

      modprobe it87 force_id=0x8512

      • [^] # Re: Kernel ?

        Posté par (page perso) . Évalué à 4.

        Attention, à cause de l'acpi foireux sur ma carte mère, j'ai dû ajouter l'option acpi_enforce_ressources=lax au noyau pour que ce module fonctionne.

        « Rappelez-vous toujours que si la Gestapo avait les moyens de vous faire parler, les politiciens ont, eux, les moyens de vous faire taire. » Coluche

        • [^] # Re: Kernel ?

          Posté par . Évalué à 1.

          Ça n'a pas l'air de fonctionner.
          modprobe -v it87 force_id=0x8512
          insmod /lib/modules/3.2.0-3-amd64/kernel/drivers/hwmon/it87.ko force_id=0x8512
          ERROR: could not insert 'it87': No such device

          J'ai bien rajouté acpi_enforce_resources=lax dans /etc/default/grub :
          GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_enforce_resources=lax"

          Plus je cherche, plus je désespère. Je suis pas très fort en anglais, mais en lisant ce thread qui parle de l'ITE IT8512 et ce message, mon désespoir s'amplifie.

          Ps : après quelques recherches, c'est bien resources et non ressources pour l'option du kernel.

          • [^] # Re: Kernel ?

            Posté par (page perso) . Évalué à 3.

            J'ai bien rajouté acpi_enforce_resources=lax dans /etc/default/grub :
            GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_enforce_resources=lax"

            Et tu as bien redémarré après ça ?

            Ps : après quelques recherches, c'est bien resources et non ressources pour l'option du kernel.

            Désolé, j'ai écris ça avec mon smartphone et j'ai dû déraper.

            « Rappelez-vous toujours que si la Gestapo avait les moyens de vous faire parler, les politiciens ont, eux, les moyens de vous faire taire. » Coluche

            • [^] # Re: Kernel ?

              Posté par . Évalué à 1.

              Et tu as bien redémarré après ça ?

              Oui, bien entendu. Et j'ai même fait un update-grub avant de redémarrer.

              Désolé, j'ai écris ça avec mon smartphone et j'ai dû déraper.

              Pas de soucis, j'ai précisé au cas où un jour quelqu'un tombe sur ce thread.

  • # A ta place

    Posté par . Évalué à 1.

    Je démonterais le PC et je nettoierais le radiateur. Ta machine a 3ans, c'est le bon moment.

    Note que si tu fumes, que tu ne fais pas super souvent la poussière chez toi, ou que tu as les cheveux fins, ton score de "je dois nettoyer mon PC" augmente.

    • [^] # Re: A ta place

      Posté par . Évalué à 2.

      Si tu as des chats aux poils fins et que ton ordi est dans le cabanon du potager ça augmente encore plus !

      Là je crois franchement pas que ce soit la cause de son problème. Plutôt le cas typique, assez rare mais bien chiant, d'un device qui marche pas sous linux pour d'obscures raisons à base de spécifications pas disponibles et/ou de device trop exotique… J'ai travaillé plusieurs années comme technicien de maintenance pour Dell et je peux dire que même sous Windows certaines machines étaient vraiment mal foutues, avec des gros drivers de 50 Mo basé sur .NET pour faire marcher une carte réseau…

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.