Forum Linux.debian/ubuntu Downgrade libpango 1.8.2 en 1.8.1

Posté par  .
Étiquettes : aucune
0
17
août
2005
Bonjour,

voila mon problème est simple a comprendre.

Je travaille sous Debian (oui je sais j'ai de la chance... mais ce n'est pas officielle !) et j'utilise comme mes collegues windowsiens l'IDE perl Komodo.

J'ai fait recemment une mise a jour de mon systeme avec apt-get upgrade, en faisant attention dans la liste des paquets que cela ne m'amenait pas de bug.

Mais voila, cela a mis a jour libpango 1.8.1 en libpango 1.8.2........ du coup l'affichage de mon Komodo est tout tremblant.

C'est un bug repertorié chez ActiveState depuis le 11.08
http://bugs.activestate.com/Komodo/show_bug.cgi?id=40388(...)

Si je veux donc pouvoir continuer a utiliser ma Debian il me faut donc revenir a la version précédente de libpango.

Mais comment fait t'on ?

Les packages sont libpango1.0-0 et libpango1.0-common.
Si je veux les supprimer le apt-get remove m'annonce qu'il faut supprimer

bluez-pin bluez-utils dia dia-common gconf2 gftp-common gftp-gtk gimp gksu glchess gnome-keyring grdesktop
gtk2-engines-geramik gtk2-engines-qtpixmap libbonoboui2-0 libeel2-2 libgail-common libgail17 libgconf2-4 libgimp2.0
libgksu0 libgksuui1.0-0 libglade2-0 libgnome-keyring0 libgnome2-0 libgnome2-common libgnomecanvas2-0 libgnomeui-0
libgnomevfs2-0 libgnomevfs2-common libgtk2.0-0 libgtk2.0-bin libgtk2.0-common libgtkglext1 libgtkmm-2.4-1 libgtkspell0
libpango1.0-0 libpango1.0-common librsvg2-2 librsvg2-common libswt2.1-gtk2-java libswt2.1-gtk2-jni libvte4
mozilla-firefox mozilla-firefox-locale-fr-fr mozilla-mplayer nvidia-settings python-gtk2 python2.3-gtk2 synaptic


En gros tout ce que j'utilise , c'est pas la joie :-(

Je suis tout ouie .....

Merci d'avance

Sébastien Gamier
  • # Downgrader un paquet Debian

    Posté par  (site Web personnel) . Évalué à 5.

    Alors, tu vas sur http://snapshot.debian.net/(...) , et tu recherche le paquet à downgrader (ici libpango dans le champ "package name pattern"), là il vas te donner une ligne à rajouter dans ton sources.list (exemple : deb http://snapshot.debian.net/archive pool pango1.0).
    Ensuite tu fait un apt-get update, puis un apt-get install libpango1.0-0=1.8.1-1 (fait un apt-cache policy libpango1.0-0 pour voir toutes les versions disponibles).
    Là, soit tout se passe bien, et ça downgrade ton paquet, soit ça marche pas, et tu vas devoir downgrader beaucoup de paquets. Tu peux donc recommencer pour tous les paquets à downgrader (ex : apt-get install libpango1.0-0=1.8.1-1 libpango1.0-common=1.8.1-1 etc...).

    Voilà, bon courage.
  • # Scintilla

    Posté par  (site Web personnel) . Évalué à 3.

    Je ne connais pas Komodo, mais ca n'utiliserait pas scintilla par hasard ? Ce dernier a un bug similaire avec les dernieres versions de pango, qui est corrigé dans le cvs de scintilla. Fouille un peu de ce coté, a mon avis ca sera bien plus pratique que de devoir downgrader.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.