Forum Linux.debian/ubuntu Freeze lors d'une forte utilisation du CPU

Posté par  . Licence CC By‑SA.
Étiquettes : aucune
0
17
avr.
2021

Bonjour à tous,

J'ai depuis quelques semaines un problème de freeze de mon Linux Mint (comme il est basé sur Ubuntu je l'ai mis ici) :

Lors de forte utilisation du CPU j'ai un freeze total que ne ne peux résoudre qu'avec un redémarrage violent.

Je ne sais pas quoi faire pour comprendre ce qui se passe, vous pouvez m'aider ?

Des information en plus ^ ^ :

Lors du freeze tentative de alt-ctrl-f3 pour passer sur un autre terminal sans succès et après une après midi il a pas repris la main.

Cas de plantage :
Jeu : Risk of rain 2 lorsqu'il y a beaucoup d'ennemis
lancement d'un "stress test" pour voir : phoronix-test-suite run john-the-ripper

Autre fait étrange : l'outil en cli bashtop plante au bout d'un moment (err:134) et juste avant un plantage je tenter de le relancer et un vu des message d'erreur (avec "Core dump" je crois)

mon linux :

 $ cat /etc/linuxmint/info
    RELEASE=19
    CODENAME=tara
    EDITION="MATE"
    DESCRIPTION="Linux Mint 19 Tara"
    DESKTOP=Gnome
    TOOLKIT=GTK

Merci d'avance

  • # Alim + memtest

    Posté par  . Évalué à 6 (+5/-0).

    J'ai déjà rencontré le freeze sous forte charge, deux possibilités :

    1) Faire un Memtest86+ et regarder s'il y a des erreurs.

    2) Si c'est un PC fixe, essaye une autre alim. Il se peut que la tienne soit fatiguée et galère à fournir un courant stable sous forte charge.

    • [^] # Re: Alim + memtest

      Posté par  . Évalué à 3 (+2/-0).

      La ram provoquerait des erreurs et pas seulement à forte charge.

      L'alim peut-être, ou le cpu qui chauffe (si le radiateur est frais c'est autre chose), à une certaine température il se mets en sécurité. Même chose pour le processeur vidéo soit il chauffe soit il n'est plus assez alimenté en forte charge = forte consommation.

      Il y a des réglages dans le bios pour le ventilo si c'est une surchauffe, si c'est le cpu qui est mûr peut-être en le sous clockant légèrement (valable aussi pour certaines barrettes de ram) ou des réglages gpu.

      • [^] # Re: Alim + memtest

        Posté par  . Évalué à 1 (+0/-0).

        J'avais penser à la température : le CP oscille entre 65° et 85° ça ne m'a pas inquiéter mais peut être à tors et je n'ai pas pensé à toucher le radiateur, pour le prochain plantage .

        le GPU est autours de 50°, ça me semble bien.

        Merci pour ton aide

    • [^] # Re: Alim + memtest

      Posté par  . Évalué à 1 (+0/-0).

      Merci pour ton aide !

      Je galère un peu pour utiliser memtest86+ : avec l'aide d'un tuto (https://debian-facile.org/doc:materiel:memoire-ram:memtest86) j'ai installer memtest86+.
      apt-get install memtest86+
      par contre il n’apparaît pas dans le GRUB (j'ai aussi fouiller UEFI).
      Aurais tu une idée ou un bon tuto :p

      pour la piste de l'alimentation je ne l'ai que depuis 3 ans, elle peut déjà être abîmé ? il y a t il un moyen de la tester au faut il en acheter un autre pour servir de témoin ?

      Merci encore !

      • [^] # Re: Alim + memtest

        Posté par  . Évalué à 1 (+0/-0).

        Lorsque j'ai installé memtest86+ avec le gestionnaire de paquets de Debian, il est apparu directement sous Grub. Le fait que tu aies un UEFI pose peut-être problème. Il y a ce doc officiel qui traite du sujet. Par contre, Remico a raison, et je me suis emballé : lorsque j'ai eu de la RAM défectueuse, ça faisait planter les grosses applications (Firefox) mais pas le PC entier.

        Pour l'alim, ça m'est arrivé sur une Corsair CX achetée d'occasion. Je suis tombé sur une série défectueuse (et je me suis fait avoir), donc le problème s'est vu tout de suite. 3 ans, ça me paraît trop jeune. C'est quel modèle ?

        • [^] # Re: Alim + memtest

          Posté par  . Évalué à 1 (+0/-0).

          EVGA SuperNOVA 750 G3, 80 Plus Gold 750W, Fully Modular, Eco Mode pour le model de l'alim

          • [^] # Re: Alim + memtest

            Posté par  . Évalué à 1 (+0/-0).

            Ok c'est pas une alim toute pourrie genre Advance, ça serait pas de chance si elle était fautive.

      • [^] # Re: Alim + memtest

        Posté par  . Évalué à 2 (+0/-0).

        memtest est disponible sur quelques liveCD, dont ubuntu

        donc le mieux ca reste de faire une clé de boot, qui contiendra memtest directement,
        ainsi tu es independant de l'OS installé sur la machine, et ca peut te servir pour d'autres machines.

        • [^] # Re: Alim + memtest

          Posté par  . Évalué à 1 (+0/-0). Dernière modification le 19/04/21 à 11:44.

          La piste de l'alim semblant se refermer pour une alim de trois ans assez puissante.

          La température de 85° me semble trop élevée, j'en avais un qui gelait l'écran et tout le reste à 70° mais c'était il y a longtemps.

          Le ventirad n'est pas forcément brûlant vu qu'il refroidit mal.

          En trois ans la poussière s'accumule et la pâte thermique sur le cpu sèche et remplis mal son rôle.

          Peut-être un bon nettoyage suffirait, faut faire hyper gaffe à ne pas abîmer un composant autour.

          Le renouvellement de la pâte thermique est plus risqué, des fois les pattes de montage des ventirad d'origine cassent, du coup faut acheter un autre ventirad. Cela ne va pas faire des miracles mais gagner quelques degrés.

          Il en faut très très peu, j'en ai un tube d'artic silver, j'ai monté plein de cpu avec et je pourrais encore en faire quelques dizaines.

          Ce serait aujourd'hui, je ne reprendrais pas d'artic silver à 15 euros mais un plus petit tube à 5 euros et pour le ventirad je ferais comme j'avais fait à l'époque rechercher le modèle choisi sur les sites de test pour vérifier que ce n'est pas une buse qui fait un bruit d'hélicoptère, vaut mieux perdre du temps à faire une bonne recherche sur le net en évitant les sites promotionnels qui font acheter des ventirad hors de prix, et le bon site de vente aussi. Vite fait comme ce n'est pas pour moi sur ldlc en triant les ventilateurs pour processeurs par prix, il y a un zalman à 6 euros qui à l'air pas mal silencieux 23db, à vérifier s'il est compatible avec la config, pour un pc de trois ans faut pas se ruiner.

  • # Consommation mémoire ?

    Posté par  . Évalué à 3 (+1/-0). Dernière modification le 25/04/21 à 00:16.

    Question bête mais as-tu regardé la mémoire vive occupée ?
    La dernière fois que j'ai vu ces symptômes c'était sur une machines qui n'avait pas de swap et plus de mémoire vive disponible.

    • [^] # Re: Consommation mémoire ?

      Posté par  . Évalué à 1 (+0/-0).

      Non je n'ai pas monitoré, je vais peut être me faire un script qui log les infos intéressantes même si je n'ai eu qu'un plantage depuis 1 mois

  • # Des nouvelles

    Posté par  . Évalué à 1 (+0/-0). Dernière modification le 08/05/21 à 06:35.

    Bonjour,

    dsl je vous ai pas tenu au courant, peu manque de motivation .

    Alors bizarrement j'ai beaucoup moins déplantage alors que je n'ai rien fait.

    Pour info j'avais refait la pose de la pâte thermique (j'en avais pas mi assez je pense) mais je ne pense pas que ce soit lier : les problème on disparu 4-5j plus tard et j'ai des température CPU qui peuvent monter à 90°

    • [^] # Re: Des nouvelles

      Posté par  . Évalué à 2 (+0/-0). Dernière modification le 08/05/21 à 12:16.

      N'hésites pas à retenter un stress test en en suivant l'utilisation mémoire. Sinon effectivement 90C° ça me parait un peu élevé, c'est quoi comme CPU et quel type de ventillo/dissipateur est monté dessus ? Quelle est la quantité de RAM et de swap ?
      En s'acharnant un peu on va trouver la cause.

      • [^] # Re: Des nouvelles

        Posté par  . Évalué à 1 (+0/-0).

        Ok merci,

        pour information :

        CPU : Intel Core i7 9700K (3.6 GHz)
        Ventirad : Noctua NH-U9S

        • [^] # Re: Des nouvelles

          Posté par  . Évalué à 2 (+0/-0). Dernière modification le 10/05/21 à 16:59.

          Vu la qualité du ventirad ça me paraît vraiment énorme cette température.
          Il y quelque chose qui cloche là.
          Il tourne à la fréquence d'origine ce processeur ?

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.