Forum Linux.debian/ubuntu gitk & git gui sous Wayland

Posté par  . Licence CC By‑SA.
Étiquettes :
1
17
mai
2020

Bonjour,

Je teste Ubuntu 18.04 LTS avec Wayland. J'utilise gitk et git gui lancés depuis un terminal pour explorer et préparer des commits pour git. Bien souvent l'un et l'autre refusent de démarrer. Plus précisément la commande gitk ou la commande git gui s'exécute, il n'y a aucun message d'erreur dans le terminal, mais la fenêtre n'apparaît pas. Apparemment pour gitk, le programme ne démarre pas (il n'y a rien à son sujet dans le moniteur système). Pour git gui il y a bien un processus, mais pas de fenêtre non plus.

De temps en temps pourtant cela fonctionne, je ne sais pas pourquoi, je me dis donc qu'il y a peut-être quelque chose à faire pour permettre l'affichage de la fenêtre du programme.

Comme contournement il y a bien gitg qui fonctionne sous Wayland, mais la version fournie par ma distribution ne permet pas de pousser les commits. Et comme je n'ai pas encore réussi à comprendre comment utiliser git push en ligne de commande pour pousser un commit préparé avec gitg sur une branche secondaire sans me prendre un message d'erreur, j'aimerais bien pouvoir utiliser git gui et gitk avec lesquels j'arrive à me débrouiller.

Est-ce un problème de configuration, un bug Wayland/Xwayland sur Ubuntu 18.04 qui est corrigé (ou pas) sur Ubuntu 20.04, ou bien un truc que je ne fais pas comme il faut ?

Merci de votre aide.

  • # Problème autre

    Posté par  . Évalué à 2.

    Salut,

    N'étant pas utilisateur de gitk, je viens de l'installer (ok, sur une debian buster, mais ça ce n'est pas le débat).

    Depuis une console, gitk se lance sans problème particulier avec l'utilisateur courant si je suis dans un répertoire "gité", sinon j'ai une erreur (graphique).

    C'est peut-être un problème d'affichage car l'utilisateur courant n'a pas accès aux ressources si tu n'est pas le seul à utiliser la machine ?

    De mon côté :

    $ lsb_release -d
    Description: Debian GNU/Linux 10 (buster)

    $ apt-cache show gitk
    […]
    Version: 1:2.26.2-1~bpo10+1
    […]

    Et ça marche.

    Matricule 23415

    • [^] # Re: Problème autre

      Posté par  . Évalué à 2. Dernière modification le 17/05/20 à 15:41.

      Merci du test. Tu es bien sous Wayland et non pas Xorg ? Parce que dans une session Xorg je n'ai pas de problème. Mais j'aimerais bien que ça marche dans la session Wayland.

      Sinon la machine en question est un portable et je suis le seul à l'utiliser.

      • [^] # Re: Problème autre

        Posté par  . Évalué à 1. Dernière modification le 17/05/20 à 17:40.

        Salut,

        Tu es bien sous Wayland et non pas Xorg ?

        Euh oui, oui. désolé, j'ai oublé de préciser :

        $ loginctl show-session loginctl|grep kaos|awk '{print $1}' -p Type
        Type=tty
        Type=tty
        Type=tty
        Type=wayland

        Donc oui…

        Matricule 23415

        • [^] # Re: Problème autre

          Posté par  . Évalué à 1.

          Re-salut,

          Plus possible de modifier, je me suis fait eu par le markdown…

          loginctl show-session `loginctl|grep <USER>|awk '{print $1}'` -p Type
          

          Enfin bref, wayland quoi ;)

          Matricule 23415

      • [^] # Re: Problème autre

        Posté par  . Évalué à 1.

        Encore salut,

        J'ai eu un doute, donc j'ai fait l'installation sur mon laptop qui me sert de terminal quand je suis vautré dans mon canapé (même version de debian, mais au cas où…)

        Bin pareil, ça se lance. En erreur evidemment vu qu'il n'y a pas encore de répertoire git dessus, mais j'ai une petite fenêtre qui me le dit.

        Et si tu dégomme .config/git/gitk (ou plutôt le déplace dans un coin temporaire), pareil ?

        Matricule 23415

        • [^] # Re: Problème autre

          Posté par  . Évalué à 1.

          Re-re-re salut,

          Bon en fait sur le laptop je suis en session X11 :(

          Mais ça marche aussi :/

          Matricule 23415

        • [^] # Re: Problème autre

          Posté par  . Évalué à 2.

          J'ai négligé de préciser : bien sûr je lance gitk et git gui depuis un répertoire dans lequel il y a un dépôt Git. Et quand je lance les mêmes commandes dans une session X11 les 2 programmes se lancent normalement. Enfin presque : parfois il faut que j’appuie sur une touche avant de voir apparaître la fenêtre. Mais dans la session wayland, même en appuyant sur une touche, le fenêtre n'apparaît pas. J'ai aussi essayé de lancer d'abord une autre appli X11 dans le terminal comme Synaptic (j'avais posé une question à son sujet sur ce même forum) et après l'avoir refermé, il semble que parfois cela aide gitk et git gui à démarrer. Ça ressemble gravement à de l'incantation magique. ;-)

          Bref c'est complètement flou et je ne vois aucun indice de ce qui fait marcher ou empêche de marcher gitk et git gui.

          Supprimer .config/git/gitk n'a pas l'air de résoudre le problème, même si parfois ça marche.

          • [^] # Re: Problème autre

            Posté par  . Évalué à 2.

            Salut,

            Je ne sais vraiment pas, mais comme ça a l'air d'être du shell/tk, j'ai regardé un peu le début des sources (les premières lignes, en gros).

            > # A simple scheduler for compute-intensive stuff.
            > # The aim is to make sure that event handlers for GUI actions can
            > # run at least every 50-100 ms.  Unfortunately fileevent handlers are
            > # run before X event handlers, so reading from a fast source can
            > # make the GUI completely unresponsive.

            Je met l'emphase :
            so reading from a fast source can make the GUI completely unresponsive

            Bon, donc voilà, déjà dès le début, il n'est pas certain qu'il ne puisse pas y avoir de petits problèmes.

            Ensuite, lancer gitk et git gui en même temps… J'ai probablement mal compris le "use case". Mais c'est une autre chose ;)

            Matricule 23415

            • [^] # Re: Problème autre

              Posté par  . Évalué à 2.

              Encore salut !

              Bon, en allant plus loi, je vois ce commentaire :

              # should never happen...

              Je ne dis pas que je ne l'ai jamais écrit non plus, mais voilà ;)

              Matricule 23415

            • [^] # Re: Problème autre

              Posté par  . Évalué à 2.

              Merci de ton intérêt pour mon problème :-)

              Je met l'emphase :
              so reading from a fast source can make the GUI completely unresponsive

              Cela voudrait donc dire que si le code à lire est sur un support trop rapide (un SSD par exemple, ce qui est bien sûr le cas), l'interface pourrait ne pas répondre ? Dans ce cas il n'y a rien à faire, sinon soit corriger le code (ce que je ne saurais pas faire), soit changer de logiciel.

              Sinon je ne lance pas les gitk et git gui en même temps, même si c'est possible, puisqu'on peut lancer git gui depuis gitk.

Suivre le flux des commentaires

Note : les commentaires appartiennent à celles et ceux qui les ont postés. Nous n’en sommes pas responsables.