Forum Linux.debian/ubuntu Haut-parleur

Posté par  . Licence CC By‑SA.
Étiquettes : aucune
1
26
juil.
2021

Bonjour à tous !

Je suis sous Ubuntu 20.04 depuis quelques mois maintenant et je commence à prendre mes marques (c'est ma première distrib Linux). Cependant, mon pc est en dual boot avec Windows 10, et en utilisant ce dernier récemment je me suis rendu compte que le son était beaucoup plus élevé. Et en effet, sous Linux, un des haut-parleurs interne de mon pc portable n'est pas utilisé. Savez-vous à quoi cela est du ? Merci d'avance pour votre aide

  • # Simple réglage ?

    Posté par  . Évalué à 2 (+0/-0).

    Très curieux, en général ça ne marche pas du tout ou ça marche très bien, mais n'avoir que la moitié du son c'est inattendu.

    Peut-être un simple problème de réglage dans les préférences du son ?

    En théorie, la théorie et la pratique c'est pareil. En pratique c'est pas vrai.

    • [^] # Re: Simple réglage ?

      Posté par  . Évalué à 1 (+0/-0). Dernière modification le 26/07/21 à 19:09.

      Je crois que j'ai déjà eu un souci dans ce genre, si je me souviens bien ça venait du fait que c'était la mauvaise sortie qui était active.

      Enfin, je ne suis pas sûr et ça fait beaucoup trop longtemps pour que je puisse aider

      Les vrais naviguent en -42

      • [^] # Re: Simple réglage ?

        Posté par  . Évalué à 1 (+0/-0).

        Je n'ai qu'une sortie dispo et c'est bien la bonne (haut-parleur interne), merci quand même ;)

    • [^] # Re: Simple réglage ?

      Posté par  . Évalué à 1 (+0/-0).

      Je viens d'aller vérifier et RAS de ce côté.

      • [^] # Re: Simple réglage ?

        Posté par  . Évalué à 1 (+0/-0). Dernière modification le 26/07/21 à 20:06.

        En faite je crois posséder 3 speakers interne, un principal, un à gauche et un à droite (pour une meilleure immersion et un son plus spatial), sauf que c'est le principal qui ne fonctionne pas sous Linux, donc le son est bien moins puissant…

        • [^] # Re: Simple réglage ?

          Posté par  . Évalué à 2 (+0/-0).

          regarde si y a pas un reglage pour passer en 2.1 (2 enceintes latérales + 1 caisson de basse)

          • [^] # Re: Simple réglage ?

            Posté par  . Évalué à 1 (+0/-0).

            Il n'y a rien de cela dans les paramètres…

            • [^] # Re: Simple réglage ?

              Posté par  . Évalué à 2 (+0/-0).

              Autre possibilité, que ce soit une sortie différente du point de vue de la carte son, comme par exemple "analog output 1" et "analog output 2".

              En théorie, la théorie et la pratique c'est pareil. En pratique c'est pas vrai.

              • [^] # Re: Simple réglage ?

                Posté par  . Évalué à 1 (+0/-0).

                Oui c'est possible, mais où puis-je voir ceci ?

                • [^] # Re: Simple réglage ?

                  Posté par  . Évalué à 2 (+0/-0). Dernière modification le 27/07/21 à 18:15.

                  Difficile à dire, dans les menus de réglages audio, en farfouillant…

                  Tiens sinon tu peux envoyer le résultat de la commande aplay -l ?

                  Si tu n'as pas la commande, tu peux l'installer via le paquet alsa-utils je crois.

                  En théorie, la théorie et la pratique c'est pareil. En pratique c'est pas vrai.

                  • [^] # Re: Simple réglage ?

                    Posté par  . Évalué à 1 (+0/-0).

                    Je n'ai pas ça dans mes paramètres de son en tout cas…

                    La commande me renvoie :

                    **** Liste des Périphériques Matériels PLAYBACK ****
                    carte 0: PCH [HDA Intel PCH], périphérique 0: ALC285 Analog [ALC285 Analog]
                    Sous-périphériques: 0/1
                    Sous-périphérique #0: subdevice #0
                    carte 0: PCH [HDA Intel PCH], périphérique 3: HDMI 0 [HDMI 0]
                    Sous-périphériques: 1/1
                    Sous-périphérique #0: subdevice #0
                    carte 0: PCH [HDA Intel PCH], périphérique 7: HDMI 1 [HDMI 1]
                    Sous-périphériques: 1/1
                    Sous-périphérique #0: subdevice #0
                    carte 0: PCH [HDA Intel PCH], périphérique 8: HDMI 2 [HDMI 2]
                    Sous-périphériques: 1/1
                    Sous-périphérique #0: subdevice #0
                    carte 0: PCH [HDA Intel PCH], périphérique 9: HDMI 3 [HDMI 3]
                    Sous-périphériques: 1/1
                    Sous-périphérique #0: subdevice #0
                    carte 0: PCH [HDA Intel PCH], périphérique 10: HDMI 4 [HDMI 4]
                    Sous-périphériques: 1/1
                    Sous-périphérique #0: subdevice #0

  • # Est-ce que le problème est présent avec le média d'installation Ubuntu ?

    Posté par  . Évalué à 1 (+0/-0).

    J'ai eu des problèmes sur un PC portable avec le son : ça marchait à l'installation ou en live avec le média d'installation, mais pas lorsque je démarrais sous le système installé.

    J'ai été contraint de garder le dernier noyau LTS sur cette machine pendant quelques temps.

  • # C'est pas toujours câblé pareil...

    Posté par  . Évalué à 1 (+0/-0). Dernière modification le 26/07/21 à 20:40.

    Bonsoir,

    Selon les portables, une même (i.e. même nom) carte son peut apparemment, en pratique, légèrement varier… en principe, pour un modèle connu, le module kernel détecte ta configuration, mais il y a des cas où il faut finir le réglage à la main. C'est probablement ce qu'à fait ton constructeur sous Windows. Les paramètres par défaut peuvent varier entre les différentes versions d'où sûrement la différence observée entre live CD, kernel LTS, et distribs…

    Ton module kernel accepte certainement des paramètres. Tu peux regarder (exemple avec Intel HDA mais ta carte est peut-être une autre):
    https://doc.ubuntu-fr.org/audio_intel_hda

    • [^] # Re: C'est pas toujours câblé pareil...

      Posté par  . Évalué à 1 (+0/-0).

      J'ai essayé la solution mise en avant, à savoir inscrire la ligne options snd-hda-intel model=***** en remplaçant ***** par le nom de ma carte son dans le fichier /etc/modprobe.d/alsa-base.conf. Mais cela ne change rien non plus

  • # profile audio

    Posté par  . Évalué à 3 (+0/-0).

    Sur ta distrib tu utilises probablement pulseaudio. Je te conseille d'installer l'outil pulseaudio volume control et d'aller voir dans l'onglet "Configuration" (le dernier) le profil utilisé par ta carte sonore. Il est bien possible que tu utilises par défaut un profile mono au lieu de stereo. Sur ma carte j'ai bien une trentaine de profiles différent disponibles.

    • [^] # Re: profile audio

      Posté par  . Évalué à 1 (+0/-0).

      J'ai essayé mais aucune configuration ne produit de son à) part celle qui était présente de base…

  • # D'autres idées ?

    Posté par  . Évalué à 1 (+0/-0).

    Quelqu'un aurait une nouvelle idée ? C'est le problème le plus dur à résoudre que j'ai eu jusqu'à présent sous Linux mais je suis vraiment bloqué là… Je suis presque en train de me dire que c'est impossible. En effet, la configuration de la carte son m'a l'air bonne et le son du speaker droit et gauche fonctionne parfaitement, mais le master speaker n'est reconnu nul part, pas même dans le menu 'alsamixer'.

    • [^] # Re: D'autres idées ?

      Posté par  . Évalué à 3 (+1/-0).

      peux-tu faire un "lspci -v" (attention, ça peut te donner un très long résultat) et nous copier ici le, ou les, parties correspondant à ton matériel son.
      En gros celles où il y a "Audio device:" tout au début.

      Avec ça, on pourra aller chercher sur les forums anglais si quelqu'un d'autre a eu le problème et a réussi à le résoudre.

      • [^] # Re: D'autres idées ?

        Posté par  . Évalué à 1 (+0/-0).

        Merci pour ton aide ! Cette commande : lspci -v | grep -i 'audio device' me renvoie :

        00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21) (prog-if 80)

        • [^] # Re: D'autres idées ?

          Posté par  . Évalué à 2 (+0/-0).

          j'ai trouvé ça : https://doc.ubuntu-fr.org/audio_intel_hda
          avec une liste assez complète de marques de pc et l'option du driver qui correspond.

          sinon il y a aussi cette page : https://askubuntu.com/questions/1129013/speakers-not-working-sunrise-point-lp-hd-audio
          Apparemment dans le contrôle de volume de pulse, il ne voyait pas le mute, mais dans alsamixer il est visible et peut être changé.

          • [^] # Re: D'autres idées ?

            Posté par  . Évalué à 1 (+0/-0).

            Encore merci pour ton aide, le premier lien que tu as envoyé j'avais déà essayé mais le modèle de mon ordinateur ne figure malheuresement pas dans la liste. J'ai cependant fait ce qui est dit dans la première partie de la page mais cela n'a rien amélioré… Le deuxième lien je ne l'avais pas vu, et effectivement l'option 'auto-mute' était dans l'état 'enabled', je l'ai donc changé pour 'disabled' mais cela n'a rien changé non plus… Je suis vraiment perdu avec ce problème, je pense effectivement que la configuration a était fini à la main par mon constructeur mais que cela a été fait naturellement pour Windows.

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.